#1  
Old 23rd December 2010, 20:25
b00gz b00gz is offline
Member
 
Join Date: Dec 2006
Posts: 55
Thanks: 1
Thanked 0 Times in 0 Posts
Default Issues with the Job Queue

I am having issues with jobs not being done in the queue. I then login via SSH and run

rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock
/usr/bin/php -q /usr/local/ispconfig/server/server.php

and then it processes them just fine. I also am having notifications of heavy usage which I am not sure why that is either. Can someone please point me in the direction to resolving these issues.

Server online since: 29 days, 13:31 hours
Users Online: 5
System load 1 minute: 31.51
System load 5 minutes: 31.39
System load 15 minutes: 31.25
Reply With Quote
Sponsored Links
  #2  
Old 23rd December 2010, 20:54
akamarinos akamarinos is offline
Junior Member
 
Join Date: Jan 2009
Posts: 24
Thanks: 6
Thanked 6 Times in 5 Posts
Default

what are your systems specs (cpu ram etc. etc.)?
how many domains are you hosting?

give us the output of

Code:
top
Reply With Quote
  #3  
Old 24th December 2010, 12:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

I suggest you install munin to find out why you have this heavy load (maybe slow hard drives, etc.).
http://www.howtoforge.com/server-mon...n-debian-lenny
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 25th December 2010, 19:22
b00gz b00gz is offline
Member
 
Join Date: Dec 2006
Posts: 55
Thanks: 1
Thanked 0 Times in 0 Posts
Default

It is a vm and it is hosting 20 sites / email domains with very low usage. I have more than enough resources allocated to it. The storage is a SAN and none of my other VMs have any issues. I am sure this is just a misconfiguration but I am unable to figure out what it is.

In my system log I see this every minute
There is already an instance of server.php running. Exiting.

I just setup munin today.

Top output as follows

Tasks: 573 total, 2 running, 571 sleeping, 0 stopped, 0 zombie
Cpu(s): 7.6%us, 2.7%sy, 0.0%ni, 87.6%id, 0.0%wa, 0.0%hi, 2.1%si, 0.0%st
Mem: 3055368k total, 1689048k used, 1366320k free, 154436k buffers
Swap: 1052216k total, 330052k used, 722164k free, 556088k cached


8286 www-data 20 0 278m 45m 5372 S 7.9 1.5 0:07.19 apache2
9406 www-data 20 0 289m 56m 6224 S 3.9 1.9 0:44.42 apache2
19395 root 20 0 19512 1744 992 R 0.7 0.1 0:00.07 top
899 root 15 -5 0 0 0 S 0.3 0.0 73:27.40 kjournald
1 root 20 0 4028 644 512 S 0.0 0.0 0:09.67 init
2 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/0
4 root 15 -5 0 0 0 S 0.0 0.0 0:04.24 ksoftirqd/0
5 root RT -5 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
6 root 15 -5 0 0 0 S 0.0 0.0 0:01.43 events/0
7 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 khelper
8 root RT -5 0 0 0 S 0.0 0.0 0:00.00 kstop/0
9 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kintegrityd/0
10 root 15 -5 0 0 0 S 0.0 0.0 7:39.95 kblockd/0
11 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
12 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kacpi_notify
13 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 cqueue
14 root 15 -5 0 0 0 S 0.0 0.0 0:00.01 ata/0
15 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ata_aux
16 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ksuspend_usbd
17 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 khubd
18 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kseriod
19 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kmmcd
20 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 btaddconn
21 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 btdelconn
22 root 20 0 0 0 0 S 0.0 0.0 0:01.80 pdflush
23 root 20 0 0 0 0 S 0.0 0.0 109:17.03 pdflush
24 root 15 -5 0 0 0 S 0.0 0.0 0:13.65 kswapd0
25 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 aio/0
26 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ecryptfs-kthrea
29 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 pciehpd
30 root 15 -5 0 0 0 S 0.0 0.0 0:00.02 scsi_eh_0
31 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 scsi_eh_1
32 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kstriped
33 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kmpathd/0
34 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kmpath_handlerd
35 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ksnapd
36 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kondemand/0
37 root 10 -10 0 0 0 S 0.0 0.0 0:00.00 krfcommd
314 root 15 -5 0 0 0 S 0.0 0.0 0:00.64 mpt_poll_0
673 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 scsi_eh_2
924 root 20 0 37040 692 688 S 0.0 0.0 0:00.00 sendmail
925 root 20 0 37028 696 692 S 0.0 0.0 0:00.01 postdrop
937 root 20 0 12200 308 304 S 0.0 0.0 0:00.01 rkhunter
938 root 20 0 4032 400 396 S 0.0 0.0 0:00.01 lsof



root@zeus:/etc# cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 16
model : 2
model name : Quad-Core AMD Opteron(tm) Processor 2352
stepping : 3
cpu MHz : 2096.472
cache size : 512 KB
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow constant_tsc up rep_good tsc_reliable pni cx16 hypervisor lahf_lm extapic abm sse4a misalignsse 3dnowprefetch
bogomips : 4189.49
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate


root@zeus:/etc# cat /proc/meminfo
MemTotal: 3055368 kB
MemFree: 595484 kB
Buffers: 153660 kB
Cached: 551584 kB
SwapCached: 14932 kB
Active: 1541532 kB
Inactive: 684936 kB
Active(anon): 1075080 kB
Inactive(anon): 446960 kB
Active(file): 466452 kB
Inactive(file): 237976 kB
Unevictable: 0 kB
Mlocked: 0 kB
SwapTotal: 1052216 kB
SwapFree: 722104 kB
Dirty: 692 kB
Writeback: 0 kB
AnonPages: 1508128 kB
Mapped: 37304 kB
Slab: 126564 kB
SReclaimable: 91620 kB
SUnreclaim: 34944 kB
PageTables: 58708 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 2579900 kB
Committed_AS: 4397992 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 263412 kB
VmallocChunk: 34359463707 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 2048 kB
DirectMap4k: 10240 kB
DirectMap2M: 3135488 kB


Cron output
root@zeus:/etc# crontab -l
0 16 * * * /etc/webmin/cron/tempdelete.pl #Delete Webmin temporary files
* * * * * /usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log
30 00 * * * /usr/local/ispconfig/server/cron_daily.sh > /dev/null 2>> /var/log/ispconfig/cron.log

Last edited by b00gz; 25th December 2010 at 20:15.
Reply With Quote
  #5  
Old 25th December 2010, 20:23
b00gz b00gz is offline
Member
 
Join Date: Dec 2006
Posts: 55
Thanks: 1
Thanked 0 Times in 0 Posts
Default

If I manually run rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock it will work for a few minutes and then I get the same thing again.


2010-12-25 14:21 zeus.domain.com Debug There is already an instance of server.php running. Exiting.
2010-12-25 14:20 zeus.domain.com Debug No Updated records found, starting only the core.
2010-12-25 14:20 zeus.domain.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2010-12-25 14:19 zeus.domain.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2010-12-25 14:19 zeus.domain.com Debug No Updated records found, starting only the core.
2010-12-25 14:19 zeus.domain.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2010-12-25 14:18 zeus.domain.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2010-12-25 14:18 zeus.domain.com Debug No Updated records found, starting only the core.
2010-12-25 14:18 zeus.domain.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
Reply With Quote
  #6  
Old 26th December 2010, 12:56
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

which ispconfig version do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 26th December 2010, 19:38
b00gz b00gz is offline
Member
 
Join Date: Dec 2006
Posts: 55
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

ISPConfig 3.0.3.1
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
delay in sending email Hellbound General 4 9th November 2012 10:53
Unable to Receve Email walner8080 Installation/Configuration 8 30th September 2010 05:58
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
mail stop on one account provell General 10 26th November 2009 21:29
ISPConfig with postfix problem Chrisssssss General 30 20th January 2007 23:34


All times are GMT +2. The time now is 16:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.