Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th September 2005, 06:00
rytech rytech is offline
Junior Member
 
Join Date: Sep 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Web Issues - Access Forbidden!

I just installed ISPConfig using the SuSE 9.3 because I am more familiar with it and we use it on multiple servers here. After the setup, I tried acessing the webpage for the new site that i created, I get a message saying Access forbidden! - You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

I know the reason I am getting the error, but not sure why I am getting the error. The reason is because the webserver is trying to access the /srv/www/htdocs directory rather than /srv/www/web1/web directory.

The actual error message from log files is " Directory index forbidden by rule: /srv/www/htdocs/"

Does anyone know how to change this so that I can get it to access the correct directories. All the email portion is working fine along with all DNS.

I would like to really get this working because it will save us time in setting up our customers domains. Any help would be greatly appreciated. I noticed someone else had an error with this in another forum but there was no resolution except for he changed to another server.

Last edited by rytech; 28th September 2005 at 08:01.
Reply With Quote
Sponsored Links
  #2  
Old 28th September 2005, 09:18
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,269
Thanks: 84
Thanked 25 Times in 21 Posts
Default

Quote:
Originally Posted by rytech
... the webserver is trying to access the /srv/www/htdocs directory rather than /srv/www/web1/web directory.

The actual error message from log files is " Directory index forbidden by rule: /srv/www/htdocs/".
I am using Debian but I had to select advanced mode during install to point to the right web server folder - in the Debian howto Sarge it is indicated at the end of the tutorial that you have to do this if you want to use su-exec, I don't know about the Suse tutorial.

But why don't you go to your ISPcfg administration pane land go to server settings select category web and I am sure you can set the path to your web there...
Reply With Quote
  #3  
Old 28th September 2005, 10:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by rytech
I just installed ISPConfig using the SuSE 9.3 because I am more familiar with it and we use it on multiple servers here. After the setup, I tried acessing the webpage for the new site that i created, I get a message saying Access forbidden! - You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

I know the reason I am getting the error, but not sure why I am getting the error. The reason is because the webserver is trying to access the /srv/www/htdocs directory rather than /srv/www/web1/web directory.

The actual error message from log files is " Directory index forbidden by rule: /srv/www/htdocs/"

Does anyone know how to change this so that I can get it to access the correct directories. All the email portion is working fine along with all DNS.

I would like to really get this working because it will save us time in setting up our customers domains. Any help would be greatly appreciated. I noticed someone else had an error with this in another forum but there was no resolution except for he changed to another server.
Did you follow the tutorial for SuSE 9.3? http://www.howtoforge.com/perfect_setup_suse_9.3
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 28th September 2005, 18:31
uralter_artifex uralter_artifex is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same issue here...

Hello there,

I followed Falko's tutorial on preparing SuSE 9.3 for ISPConfig and afterwards the installation howto on ispconfig.org. Everything works fine, except for the web access to subdirectories of the individual document root (/home/www/webXX/web). I can access the index.html via the browser, but when I try to access any subdirectories (including the individual error pages) Apache gives me an 403 error.
The permissions are set to the site's admin (web1_adm.web1). "Chown -R wwwrun.www" and even "chmod -R 777" didn't solve it. A new installation from scratch with /srv/www as DocumentRoot had the same result.
When I set up a new site manually without having it managed by ISPConfig, everything works fine. So I guess it must be an issue with ISPConfig's way on setting up SuSE's Apache2.

Last edited by uralter_artifex; 28th September 2005 at 18:41.
Reply With Quote
  #5  
Old 28th September 2005, 20:23
rytech rytech is offline
Junior Member
 
Join Date: Sep 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I followed the guide to installing the software. I also had a support guy log in and he could not see anything wrong with apache saying it should be working fine.

I did install using expert mode and chose the directory according to the guide - "/srv/www". I think i agree with uralter_artifex and this could be a problem with ISPconfig and SuSE.

I really like the SuSE package because it's really nice to use. If I have to change software any recommendations?
Reply With Quote
  #6  
Old 28th September 2005, 22:45
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Generally, ISPConfig works fine with SuSe 9.3 and SuSe 10, it has been tested many times.

Are the vhosts written correctly to the file Vhost_ispconfig.conf or is the file empty?
Are there any errors in the ispconfig logfile?

/home/admispconfig/ispconfig/ispconfig.log
Reply With Quote
  #7  
Old 28th September 2005, 23:15
uralter_artifex uralter_artifex is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the quick reply.
The ispconfig.log shows no errors. The apache log has the line
Code:
[Wed Sep 28 12:59:18 2005] [error] an unknown filter was not added: PHP
in it, but .php files work as long as they are in /home/www/web1/web and not in a subdirectory below that.

The Vhosts_ispconfig.conf looks like this:
Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 85.214.25.27:80
#
#
######################################
# Vhost: www.luxev-ratingen.de:80
######################################
#
#
<VirtualHost 85.214.25.27:80>
ServerName www.luxev-ratingen.de:80
ServerAdmin webmaster@luxev-ratingen.de
DocumentRoot /home/www/web1/web
ServerAlias luxev-ratingen.de
DirectoryIndex index.html index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /home/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/home/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
</VirtualHost>
When I try to access the directory /home/www/web1/web/quickstart-3.8.0 which is part of typo3, Apache shows
Code:
Forbidden

You don't have permission to access /quickstart-3.8.0/typo3/install/index.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.53 (Linux/SUSE) Server at www.luxev-ratingen.de Port 80
Permissions for these directories and files are still set to the site's admin (web1_adm.web).
I created the subdirectoy /home/www/web1/web/test and copied the original index.html into it. That works perfectly. Does the number of subdirectories make a difference? Or the softlink in the typo3 files?
There are no problems with typo3 on SuSE 9.3/Apache2 virtual hosts without ISPConfig.

Last edited by uralter_artifex; 28th September 2005 at 23:38.
Reply With Quote
  #8  
Old 29th September 2005, 00:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What are the permissions of quickstart-3.8.0/typo3/install/index.php? Maybe Apache is allowed to access the directories, but not the file index.php because it has no read permissions on that file.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 29th September 2005, 00:57
uralter_artifex uralter_artifex is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Permissions for these directories, subdirectories and files are set to the site's admin (web1_adm.web).
chmod -R 777 /home/www/web1/web/ -> still 403
chown -R wwwrun.www /home/www/web1/web/ -> still 403
Reply With Quote
  #10  
Old 29th September 2005, 03:53
rytech rytech is offline
Junior Member
 
Join Date: Sep 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I reinstalled SuSE on the machine, works fine now.

Thanks for the help
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
/stats doesn't work (password not accepted) Hellbound General 6 15th September 2005 16:34
Can't access ISPConfig by http://...:81 driftguy Installation/Configuration 7 14th September 2005 15:47
FTP Access ProTrooper Installation/Configuration 17 16th August 2005 18:53
Access Denied on Port: 81 nandhu Installation/Configuration 2 10th August 2005 15:05
Restrict access to my SystemImager server cornelius Installation/Configuration 1 7th June 2005 12:35


All times are GMT +2. The time now is 22:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.