Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th December 2010, 19:15
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default PureFTP on FC13

Hi Falco/All,

I have installed step by step this tutorial:

Virtual Hosting With PureFTPd And MySQL (Incl. Quota And Bandwidth Management) On Fedora 13

I am finding difficulty when trying to authenticate a user (step 6). I am able to connect and I can see that mysql db is there. Everything seems to be running as it should as explained in the tutorial. When I enter password for user i get an error "530 Login Authentication failed".

Do you know the cause of the error? What else can I check? I have tried to create various users but in vain.

Thanks for you time and help!

regards,
Dustin
Reply With Quote
Sponsored Links
  #2  
Old 29th December 2010, 00:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Please make sure that SELinux is disabled.

If it still doesn't work, make sure you try both active and passive transfers in your FTP client.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 30th December 2010, 17:38
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi,

Thanks for the reply.

I am using filezilla at the moment and i tried using both passive and active FTP transfers but both are giving the same error.

Selinux is disabled. Do you have any suggestion what i might check?

regards,
Dustin
Reply With Quote
  #4  
Old 31st December 2010, 15:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Is this a virtual machine or a physical server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 31st December 2010, 17:10
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi,

It's a physical server.

Regards,
Dustin
Reply With Quote
  #6  
Old 4th January 2011, 00:33
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi Falko,

Do you have any other suggestion??

Thanks!
Reply With Quote
  #7  
Old 4th January 2011, 15:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Do you have a firewall running on the server? What's the output of
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 6th January 2011, 09:16
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi Falko,

Below is my output:
iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Also, I can only connect successfully with Anonymous user.
Regards,
Dustin

Last edited by sammd006; 6th January 2011 at 09:20.
Reply With Quote
  #9  
Old 7th January 2011, 00:13
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
Default

Hi Falko,

Apparently my issue is solved... From my side I did nothing special but last night I just switched off my PC hosting my fedora CORE 13.

This morning I have booted up and while I decided to give it another try users authenticated successfully. I was quite puzzled to be honest!!

I could also connect from outside my home network too (since i configured my router too). I am very thankful for your time and wish you all in this forum a happy new year!

Best regards,
Dustin
Reply With Quote
  #10  
Old 10th January 2011, 09:06
sammd006 sammd006 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 2
Thanked 2 Times in 1 Post
 
Default

Dear All,

I am now encountering a diffuclty in setting Quotasize for the Virtual FTP users on the DB. I am only allowed to set up to 32767k amount.

Do you a workaround to this problem?

thanks,
Dustin
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fail2ban pureftp admins Installation/Configuration 13 10th November 2010 01:16
PureFTP "Your MySQL client libraries aren't properly installed" CarbonCopy Server Operation 4 17th May 2010 00:52
IPSConfig using Pureftp on Ubutu 8.04 lts rusty Installation/Configuration 5 15th April 2010 22:37
pureftp manager fisherofer Feature Requests 4 21st October 2009 16:21
restricting where pureftp users to web directory vmos Server Operation 2 8th January 2009 19:40


All times are GMT +2. The time now is 16:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.