Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st December 2010, 05:55
wachira wachira is offline
Member
 
Join Date: Apr 2010
Posts: 52
Thanks: 2
Thanked 0 Times in 0 Posts
Default My Dovecot is failing when i install ISPConfig 3

All my instalation went well only to the point were I install ISPconfig I get
Dovecot Imap: Error: mail_plugin_dir: Can't access directory: /usr/lib/dovecot/imap/: No such file or directory Fatal: Invalid configuration in /etc/dovecot.conf.
I have tried all the postings northing seems to be working. Can some one help me out on this one.
Reply With Quote
Sponsored Links
  #2  
Old 21st December 2010, 12:53
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,754
Thanks: 840
Thanked 5,603 Times in 4,414 Posts
Default

1) Which Linux distribution?
2) Is this a 32Bit or 64Bit system?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st December 2010, 16:35
wachira wachira is offline
Member
 
Join Date: Apr 2010
Posts: 52
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I am running Centos 5.5 and its a 32 bit system
Reply With Quote
  #4  
Old 21st December 2010, 17:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Which tutorial (URL) did you use to set up the server?

What are the outputs of
Code:
ls -la /usr/lib/dovecot/imap/
ls -la /usr/lib64/dovecot/imap/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 21st December 2010, 18:19
wachira wachira is offline
Member
 
Join Date: Apr 2010
Posts: 52
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I used http://www.howtoforge.com/perfect-se...64-ispconfig-3. But i would replace the 64 bit part with i386.

The out puts for
[root@wachkama ~]# ls -la /usr/lib64/dovecot/imap/
ls: /usr/lib64/dovecot/imap/: No such file or directory
[root@wachkama ~]# ls -la /usr/lib/dovecot/imap/
ls: /usr/lib/dovecot/imap/: No such file or directory
Reply With Quote
  #6  
Old 22nd December 2010, 16:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you run this command

Code:
rm -fr /usr/lib/dovecot/
from chapter 10 on http://www.howtoforge.com/perfect-se...ispconfig-3-p4 ?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd December 2010, 20:59
wachira wachira is offline
Member
 
Join Date: Apr 2010
Posts: 52
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Yes I did follow the whole setup very well and at Installing Dovecot I did it to the letter and when I started dovecot it started well. Could it be affected by SquirrelMail webmail. because wen i installed SquirrelMail webmail I didnt get its interface up running. Then when i installed ISPconfig dovecot failed to restart.
Reply With Quote
  #8  
Old 23rd December 2010, 15:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

The
Code:
rm -fr /usr/lib/dovecot/
is the problem - this command is intended only for 64bit systems because there the Dovecot libraries are in /usr/lib64/dovecot/. On 32bit systems they are in/usr/lib/dovecot/, and you deleted that directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 23rd December 2010, 20:44
wachira wachira is offline
Member
 
Join Date: Apr 2010
Posts: 52
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Nice it worked perfectly. My ISPconfig is up running. one error only on Install A Chrooted DNS Server (BIND9). When i try to start it it has an error.
Error in named configuration:
/etc/named.conf:29: open: /var/named/chroot/etc/named.conf.local: file not found
[FAILED]
Do u know why?

And in ispconfig it shows that mydns is offline am thinking it is becaues of the above problem.
Reply With Quote
  #10  
Old 23rd December 2010, 20:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,754
Thanks: 840
Thanked 5,603 Times in 4,414 Posts
 
Default

Quote:
Originally Posted by wachira View Post
Do u know why?
Seems as you did not install bind as described in the tutorial:

http://www.howtoforge.com/perfect-se...ispconfig-3-p5

The tutorial instructs you to create that file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 17:59
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Tips/Tricks/Mods 1 30th September 2009 19:08
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Installation/Configuration 0 10th April 2009 05:54
Rebuilding server after install of ISPConfig 3 DantePasquale Installation/Configuration 3 28th March 2009 20:15
New ISPConfig Install nubtool Installation/Configuration 15 18th May 2008 17:46


All times are GMT +2. The time now is 23:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.