Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 20th December 2010, 21:36
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

You have downloaded HTML files instead of actual spamassassin rules files.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Sponsored Links
  #12  
Old 20th December 2010, 22:05
macross macross is offline
Junior Member
 
Join Date: Dec 2010
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Default

OK everything is looking really good. Just the two last issues.

the aforementioned parse error and a clamav issue.

Ubuntu comes with amavis-new..should i leave that installed ? Will it conflict with permissions?

Right now in mail.log i see

MailScanner[6459]: Cannot find Socket (/var/run/clamav/clamd.ctl) Exiting!

Thanks so much for your support!
Reply With Quote
  #13  
Old 20th December 2010, 22:06
macross macross is offline
Junior Member
 
Join Date: Dec 2010
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by topdog View Post
You have downloaded HTML files instead of actual spamassassin rules files.

Oh really ? How should I go about redownloading the correct files?
Reply With Quote
  #14  
Old 20th December 2010, 22:18
macross macross is offline
Junior Member
 
Join Date: Dec 2010
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Default

ahhh

/usr/bin/wget http://www.rulesemporium.com/rules/70_sare_header0.cf


-2010-12-20 15:18:26-- http://www.rulesemporium.com/rules/70_sare_header0.cf
Resolving www.rulesemporium.com... 72.52.4.74
Connecting to www.rulesemporium.com|72.52.4.74|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2010-12-20 15:18:27 ERROR 404: Not Found.



the files don't exist anymore
Reply With Quote
  #15  
Old 20th December 2010, 22:45
macross macross is offline
Junior Member
 
Join Date: Dec 2010
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Ok i manually got the .cf files I could find, so I am all set.


So back to the original issue.


Report: MailScanner: Message attempted to kill MailScanner

This still occurs and in my log file I see
Dec 20 15:28:36 belatrix MailScanner[9362]: Reading configuration file /opt/MailScanner/etc/conf.d/README
Dec 20 15:28:36 belatrix MailScanner[9362]: Read 867 hostnames from the phishing whitelist
Dec 20 15:28:36 belatrix MailScanner[32693]: Warning: skipping message ED315440084.A2C21 as it has been attempted too many times
Dec 20 15:28:36 belatrix MailScanner[32693]: Quarantined message ED315440084.A2C21 as it caused MailScanner to crash several times
Dec 20 15:28:36 belatrix MailScanner[32693]: Saved entire message to /var/spool/MailScanner/quarantine/20101220/ED315440084.A2C21
Reply With Quote
  #16  
Old 20th December 2010, 23:56
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Did you try to reinstall clamav? After you've reinstalled it, run freshclam to update the defs. It may take a few mins. After that, I would restart mailscanner and check the logs.
__________________
Home of the SpamSnake
Reply With Quote
The Following User Says Thank You to Rocky For This Useful Post:
macross (22nd December 2010)
  #17  
Old 21st December 2010, 00:49
macross macross is offline
Junior Member
 
Join Date: Dec 2010
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Default

ok looking good. was i correct to uninstall amavis-new? It was running clam amavis user and causing issues during initial install.

Last edited by macross; 21st December 2010 at 00:57.
Reply With Quote
  #18  
Old 21st December 2010, 04:44
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Yes, this setup does not use amavis, no clue why it was installed. So is everything sorted out now?
__________________
Home of the SpamSnake
Reply With Quote
  #19  
Old 21st December 2010, 06:13
macross macross is offline
Junior Member
 
Join Date: Dec 2010
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Smile

Everything appears to be running smoothly and no more false positives or errors. I would like to get the rest of those cf files it seems that site www.rulesemporium.com is down.

fuzzy-mysql cleaner kills my cpu when it's run not to sure why, i was going to trace that.

I need to do some more poking around to ensure a clean setup and start a decent backup regimen. Plus ensure I can handle any outages or daemon failures.

Thanks again.
Reply With Quote
  #20  
Old 21st December 2010, 14:23
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
 
Default

There is a cron job for Baruwa that updates spamassassin so you don't have to. Look at the guide, I'm sure it's there. You can run it like:
manage.py updatesarule

If you mail log looks clean, then I won't thing everything's running as it should.

Make sure you change the database connection settings of /usr/sbin/fuzzy-cleanmysql to whatever you used for your FuzzyOcr database.
__________________
Home of the SpamSnake
Reply With Quote
The Following User Says Thank You to Rocky For This Useful Post:
macross (22nd December 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 9th May 2009 00:00
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 15:31
Perfect SpamSnake - Emails Stuck in MailScanner Incomming queue teixeira HOWTO-Related Questions 2 4th December 2008 03:49
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 18:37
Xen doesn't start: Kernel panic - not syncing: Attempted to kill init! stormrider Kernel Questions 2 23rd October 2007 21:52


All times are GMT +2. The time now is 18:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.