#1  
Old 21st December 2010, 06:04
RKB RKB is offline
Member
 
Join Date: Oct 2008
Posts: 34
Thanks: 12
Thanked 0 Times in 0 Posts
Default Installing Magento

Trying to install Magento, it looks to me that all of the requirements for magento are installed, but clearly they are not. I can not change the file permissions in the magento installation and I get the white screen.

The Magento-checker shows it all, I think.

http://www.thepatchshop.com.au/check.php This is the result I want.

http://www.farmsforsale.net.au/check.php This is what I am getting.

The patchshop is on a different server

Any clue's
__________________
Thanks for taking the time to read this post.

Cheers

Ron
Queensland
Australia
Reply With Quote
Sponsored Links
  #2  
Old 21st December 2010, 11:57
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

First, make sure that you selected as php mode "php-fcgi" and that the "Suexec" checkbox in the website settings is enabled.

Then edit the php.ini file and ensure that short_open_tag is set to on:

short_open_tag = On
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
RKB (21st December 2010)
  #3  
Old 21st December 2010, 12:28
RKB RKB is offline
Member
 
Join Date: Oct 2008
Posts: 34
Thanks: 12
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
First, make sure that you selected as php mode "php-fcgi" and that the "Suexec" checkbox in the website settings is enabled.

Then edit the php.ini file and ensure that short_open_tag is set to on:

short_open_tag = On
Hi Till,
I have done all of this, but still no good.

I am not totally confident that the pdo_mysql extension has been installed properly, I have not been able to find a pdo_mysql 64bit RPM for SuSe 11.3 yet.

What are the chances of a 'Total Screwup' if I do a full re-install of the latest version of PHP 5. ?

Cheers

Ron
__________________
Thanks for taking the time to read this post.

Cheers

Ron
Queensland
Australia
Reply With Quote
  #4  
Old 21st December 2010, 12:45
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Please add:

short_open_tag = On

in the custom php.ini field on the options tab of the website and click on save. Then wait a few minutes and try again.

If this wont help, then please add a php file with the following content:

<?php
phpinfo();
?>

in the farmsforsale webspace and check in the output if short_open_tag is on or not. The current probem is not related to pdo_mysql as far as I see.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
RKB (21st December 2010)
  #5  
Old 21st December 2010, 22:19
RKB RKB is offline
Member
 
Join Date: Oct 2008
Posts: 34
Thanks: 12
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Please add:

short_open_tag = On

in the custom php.ini field on the options tab of the website and click on save. Then wait a few minutes and try again.

If this wont help, then please add a php file with the following content:

<?php
phpinfo();
?>

in the farmsforsale webspace and check in the output if short_open_tag is on or not. The current probem is not related to pdo_mysql as far as I see.

Good Morning,
I have done this,

I placed
<?php
phpinfo();
?>
in a new file called php_info.php, also added it into the index.php page

I am not sure where you want me to check output.

Still no good.

Backto pdo_php for a second

I searched the server for all of the Magento Requirements:
mcrypt
and
pdo_mysql
were not found, so, I installed mcrypt from Yast. pdo_mysql is not available in Yast, the only way so far that I have found to get it is in a full copy of php5

Till,
Thanking you for your help here

Ron
__________________
Thanks for taking the time to read this post.

Cheers

Ron
Queensland
Australia
Reply With Quote
  #6  
Old 22nd December 2010, 14:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Quote:
Originally Posted by RKB View Post
I have done this,

I placed
<?php
phpinfo();
?>
in a new file called php_info.php, also added it into the index.php page

I am not sure where you want me to check output.
Call the php_info.php file in a browser; this will show you all your PHP settings.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd December 2010, 23:04
RKB RKB is offline
Member
 
Join Date: Oct 2008
Posts: 34
Thanks: 12
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
Call the php_info.php file in a browser; this will show you all your PHP settings.
Good Morning Till,

Yes, short_open_tag = On

Well I am baffled, it all looks ok to me http://www.farmsforsale.net.au/phpinfo.php

I notice that pcre.ini and simplexml.ini don't appear in the "Additional .ini files parsed" section, but are 'enabled' lower down on the report.

Have the same php.ini content in ect/php5/ and the website.

I have adjusted the php.ini in farmsforsale to reflect the php output from thepatchshop, remember thepatchshop is on a commercial server

But it is still not correct.

I have put a message on the openSuSe forum asking does anyone have Magento operational on SuSe 11.3 with ISPConfig 3, but no reply yet.
__________________
Thanks for taking the time to read this post.

Cheers

Ron
Queensland
Australia

Last edited by RKB; 23rd December 2010 at 08:41. Reason: additional info
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail Server Setup With Exim, MySQL, Cyrus-Imapd, Horde Webmail On Centos 5.1 - works? gsp HOWTO-Related Questions 124 21st April 2010 20:53
Magento setup in root folder and htaccess provell General 6 14th January 2010 11:02
Problems with installation on openSUSE 10.2 douglaslopezt Installation/Configuration 3 24th August 2007 22:04
Interface for installing SSL Intermediate Certificate LumpyOne Feature Requests 3 20th November 2006 20:28
error while installing..... securitywonks Installation/Configuration 1 23rd December 2005 12:07


All times are GMT +2. The time now is 16:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.