Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th December 2010, 08:49
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default System update vhost problems

Hello,

Two days ago I update Debian lenny by apt-get update and now my websites not load, when I restart apache show,

... waiting [Tue Dec 07 08:31:36 2010] [warn] NameVirtualHost my.ip.:443 has no VirtualHosts

I enter on etc/apache2/sites-enabled and sites-available and I can see the vhosts files of the domains.

Please help

Thank you
Reply With Quote
Sponsored Links
  #2  
Old 8th December 2010, 03:26
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Up!

some idea for help please?
Reply With Quote
  #3  
Old 8th December 2010, 17:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 9th December 2010, 06:35
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Falko

Thank you for your reply

In the log of the domain I see so much like this:
[Wed Dec 08 19:44:17 2010] [error] [client 128.238.49.17] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.test0
[Wed Dec 08 19:46:09 2010] [error] [client 128.238.49.17] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.test0

In the apache log this I can see:

[Thu Dec 09 04:27:59 2010] [notice] caught SIGTERM, shutting down
[Thu Dec 09 04:27:59 2010] [notice] mod_fcgid: process /var/www/mydomain.com/web/categorias.php(1794) exit(shutting down), terminated by calling exit(), return code: 0
[Thu Dec 09 04:27:59 2010] [notice] mod_fcgid: process /var/www/mydomain2.com/web/index.php(22235) exit(shutting down), terminated by calling exit(), return code: 0
[Thu Dec 09 04:28:00 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Thu Dec 09 04:28:00 2010] [notice] Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny9 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
[Thu Dec 09 05:37:06 2010] [notice] mod_fcgid: call /var/www/mydomain.com/web/categorias.php with wrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter

Thank you

David
Reply With Quote
  #5  
Old 10th December 2010, 02:36
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Please somebody has some idea what can be the problem?

Thanks
Reply With Quote
  #6  
Old 10th December 2010, 12:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Can you post the output of
Code:
ls -la /var/www/mydomain2.com/web/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 10th December 2010, 13:46
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

server1:~# ls -la /var/www/mydomain2.com/web/
total 740784
drwxr-xr-x 26 web3 client0 4096 oct 8 03:53 .
drwxr-xr-x 6 root root 4096 dic 9 04:05 ..
drwxr-xr-x 4 web3 client0 4096 jun 8 2010 admin
-rw-r--r-- 1 web3 client0 1918 jun 8 2010 autocomplete.php
-rw-r--r-- 1 web3 client0 809 jun 8 2010 background.gif
-rw-r--r-- 1 web3 client0 4494 jun 8 2010 browse.php
drwxrwxrwx 2 web3 client0 4096 oct 31 20:31 cache
-rw-r--r-- 1 web3 client0 2163 jun 8 2010 categorias.php
drwxr-xr-x 2 web3 client0 4096 jul 19 2009 cgi-bin
-rw-r--r-- 1 web3 client0 193 jun 8 2010 conectar.php
-rw-r--r-- 1 web3 client0 2284 jun 8 2010 contact.php
drwxr-xr-x 3 web3 client0 4096 jun 11 11:24 admin2

Here is a part of the code I have so so much files on web folder

Thank you Falko for your help

Regards
Reply With Quote
  #8  
Old 11th December 2010, 12:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Hm, looks ok. What's in/var/www/php-fcgi-scripts/web3/.php-fcgi-starter?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 11th December 2010, 15:46
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Falko thank you another time

In this file i can see the next:

#!/bin/sh
PHPRC="/etc/php5/cgi/"
export PHPRC
PHP_DOCUMENT_ROOT="/var/www/clients/client0/web3"
export PHP_DOCUMENT_ROOT
PHP_FCGI_CHILDREN=8
export PHP_FCGI_CHILDREN
PHP_FCGI_MAX_REQUESTS=5000
export PHP_FCGI_MAX_REQUESTS
exec /usr/bin/php-cgi $1

Regards
Reply With Quote
  #10  
Old 12th December 2010, 19:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Does
Code:
/var/www/php-fcgi-scripts/web3/.php-fcgi-starter /var/www/mydomain2.com/web/index.php
or
Code:
/var/www/php-fcgi-scripts/web3/.php-fcgi-starter /var/www/mydomain.com/web/categorias.php
show any errors?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
Force ISPC3 to update apache2 vhost files archerjd Developers' Forum 5 19th December 2008 07:18
apt-get update problems Xpyd3r Server Operation 2 13th June 2008 04:23
Online update system PoleCat Feature Requests 6 31st July 2007 18:24
Mail system problems. SkIRmiS Installation/Configuration 27 24th November 2006 17:45


All times are GMT +2. The time now is 17:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.