#1  
Old 6th December 2010, 19:42
bboy8012 bboy8012 is offline
Junior Member
 
Join Date: Mar 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSL/TLS Pure FTPD

I have configured pure ftpd to accept TLS connections. I can connect using a local account from the sever securely and clear text, but cant connect from ispc3 site ftp users securely, can do clear text. Any insite to this? Thanks
Reply With Quote
Sponsored Links
  #2  
Old 7th December 2010, 09:10
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,783
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Please enable logging in pure-ftpd and then check the logfiles which error message gets logged.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th December 2010, 16:10
bboy8012 bboy8012 is offline
Junior Member
 
Join Date: Mar 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ive enabled verbose logging and this is what I get

SysLog:
Code:
Dec  7 08:06:09 ubuntuserver1 pure-ftpd: (?@69.97.110.110) [INFO] New connection from 69.97.110.110
Dec  7 08:06:09 ubuntuserver1 pure-ftpd: (?@69.97.110.110) [DEBUG] Command [auth] [TLS]
Filezilla:
Code:
Status:	Resolving address of djcminuz.com
Status:	Connecting to 71.42.199.157:21...
Status:	Connection established, waiting for welcome message...
Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:	220-You are user number 2 of 50 allowed.
Response:	220-Local time is now 08:06. Server port: 21.
Response:	220-This is a private system - No anonymous login
Response:	220-IPv6 connections are also welcome on this server.
Response:	220 You will be disconnected after 15 minutes of inactivity.
Command:	AUTH TLS
Response:	234 AUTH TLS OK.
Status:	Initializing TLS...
Error:	Connection timed out
Error:	Could not connect to server
Reply With Quote
  #4  
Old 8th December 2010, 17:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you try both active and passive transfers in your FTP client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th December 2010, 03:12
bboy8012 bboy8012 is offline
Junior Member
 
Join Date: Mar 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes falko, I've tried both, it is getting really frustrating. I can connect using my internal IP but not external.
Reply With Quote
  #6  
Old 9th December 2010, 10:01
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,783
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Quote:
I can connect using my internal IP but not external.
Ok,. So thats a problem of your router an not your server. Please check that you forwarded the ftp port and all ports within your passive ftp port range from the router to the server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 9th December 2010, 16:18
bboy8012 bboy8012 is offline
Junior Member
 
Join Date: Mar 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I followed this guide to activate passive port range

Code:
echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange
/etc/init.d/pure-ftpd-mysql restart
and added the range to my router, and Im still not able to connect.

Last edited by bboy8012; 9th December 2010 at 16:47. Reason: Found answer to my alternate question on how to setup passive port range
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pure Ftpd MySQL authorisation problem davebamford General 12 13th August 2014 09:02
Pure FTPd not running andreasnrb Installation/Configuration 8 20th March 2010 01:01
Pure domain DNS doesn't work SyRenity Installation/Configuration 7 12th December 2006 12:12
Document for setup Apache2 with SSL/TLS satimis Server Operation 2 25th November 2006 14:50
pop3 SSL/TLS not running, smtp+imap TLS/SSL ok st2xo Installation/Configuration 2 2nd February 2006 20:29


All times are GMT +2. The time now is 10:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.