#1  
Old 5th December 2010, 21:52
Rastus Rastus is offline
Junior Member
 
Join Date: Mar 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Default web site files.

OK,
I have set up my server with ISPConfig3 per the insrtuctions for Ubuntu 10.10 and everything went well.
I established clients and FTP access for each of the web sites that I host and uploaded some html files.

I host 4 sites:

1 works fine and goes to the files that I uploaded.
1 goes to the default page for ispconfig which is OK because I have not uploaded content to the site yet.
1 goes to the index.html file in the /var/www/ directory ( I know this because it is a modified file) but the correct files are in the /var/www/domain.org/web directory.
1 site gives me a 404 error message but the correct files are in the /var/www/domain.org/web directory.

In ISPConfig3, all of the sites are set up the same with
domain is set to domain.org
and auto-subdomain is set to www.

Clearly I have screwed something up.
I would appreciate any suggestions to figure this out.
R

Additionally, when I look at the /var/www/clients directory, there are 4 clients but I only have 3 clients in ISPConfig. Client0 has lots of web directories but does not seem to be an active client.??

Another thing, when I upload files via the FTP logins that I made for each site, the files default upload to the /var/www/domain.org/ directory not the /var/www/domain.org/web directory and if I try to upload to the /var/www/domain.org/web directory it says that I am not allowed to do that.???

If I log in with the FTP user ID set up for a specific client should that not take me to the default directory when I log in or do I need to specify the /web directory?

Sorry for the list of questions but I have been working on it and searching the forums with little success.
THanks

Last edited by Rastus; 5th December 2010 at 22:01.
Reply With Quote
Sponsored Links
  #2  
Old 5th December 2010, 23:31
Rastus Rastus is offline
Junior Member
 
Join Date: Mar 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Wink I should start all over.

OK,
If the first post didn't make much sense, there is a reason for that.

I had some DNS issues which were causing part of the problem.

That is fixed but the following problem remains:

I have 4 sites on an ISPConfig3 server.

3 work normally (now that I fixed the DNS) but one is giving me the 404 error:
Quote:
Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.16 (Ubuntu) Server at www.domain.org Port 80
I have checked the DNS for this site and it is OK. Why would it give me this error?

Lord, This is getting to be a long thread and it is all me.... Talk about needing to get a life....

Last edited by Rastus; 5th December 2010 at 23:46.
Reply With Quote
  #3  
Old 5th December 2010, 23:43
Rastus Rastus is offline
Junior Member
 
Join Date: Mar 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Another thing

Just to keep this long post going:

When I check the Apache log for errors I get this
Quote:
[Sun Dec 05 16:40:05 2010] [error] [client 209.215.151.126] PHP Notice: Undefined offset: 3 in /usr/local/ispconfig/interface/web/dashboard/dashboard.php on line 106, referer: http://www.domain.org:8080/index.php
That suggests to me that there is a PHP error in my ISPConfig3 setup.

It occurs to me about now that I may just be making things worse by continuing to muck about with them. I certainly hope that is not the case.

Last edited by Rastus; 5th December 2010 at 23:53.
Reply With Quote
  #4  
Old 5th December 2010, 23:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
That suggests to me that there is a PHP error in my ISPConfig3 setup.
Thats a notice and not a error and this notice is absolutely ok. You see this because there are wrong error reporting settings configured in your php.ini file. Notices should be disabled on production systems as they are debug messages for developers.

Quote:
If I log in with the FTP user ID set up for a specific client should that not take me to the default directory when I log in or do I need to specify the /web directory?
No, you have to set the web directory as default in your ftp client or switch to web if you want to upload to web. If ispconfig would direct you to the web folder, then all other files and folders in the website would become inaccessible by FTP. A website is more then the web folder.

Quote:
I have checked the DNS for this site and it is OK. Why would it give me this error?
check the apache error log of the website (and not the global error.log). You will find the reason for the error there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th December 2010, 23:59
Rastus Rastus is offline
Junior Member
 
Join Date: Mar 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Still more

OK TIll,
thanks for your reply.
the error log for that site says

Quote:
[Sun Dec 05 16:39:33 2010] [crit] [client 209.215.151.126] (13)Permission denied: /var/www/domain.org/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
I have no idea what this means.

I checked the directory and there is no file named .htaccess but I checked one of the directories of a working site and I don't see the file there either.

ADDENDUM:
Deleted the site, made a new site and uploaded the site documents and it works.
I may never know why but I am Happy!
THanks Till

Last edited by Rastus; 6th December 2010 at 00:22.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 10:58
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 15:49
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 21:43
The system is currently updating the configuration files. warlock General 8 21st February 2009 19:15
Can't start apache Musty Server Operation 12 9th March 2008 14:58


All times are GMT +2. The time now is 13:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.