Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th December 2010, 21:16
germinator germinator is offline
Member
 
Join Date: Nov 2010
Location: /root
Posts: 51
Thanks: 7
Thanked 16 Times in 9 Posts
Default HowTo WebDAV Windows XP bug Workaround

Hello HowtoForge Community,

I have been reading through endless documentations about WebDAV, and various tutorials, etc searching for a solution to the bug. Since I wanted to use the WebDAV function of ISPConfig badly. Yesterday I found the solution to make windows xp use the old version of the network devices manager. I had a lot of time today and made a quick how to:

First we create a WebDav user:


Now we can install our WebDAV drive in Windows XP. Go to My Network Places and click on "add a network place"

Click on "Next".
Click on "Choose another network location" and click "Next".
now comes the workaround,
usually at this point you type http://example.tld/webdav/
but to make windows use the old version of the network device manager simply type http://user: pass@example.tld/webdav/ without the space between : and pass


Click "Next"
Type your desired WebFolder name in the input-field and click "Next"

Now make sure to put a check in the "Open this network place when I click Finish." and click Finish

Now type in your user and pass in the inputs again and if you want put a check to make windows remember this.


I hope this helps, have fun

-Germinator
Reply With Quote
The Following 2 Users Say Thank You to germinator For This Useful Post:
falko (6th December 2010), till (5th December 2010)
Sponsored Links
  #2  
Old 27th February 2011, 20:54
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default webdav access problem

when I am trying to add network loaction in windows 7, I am getting the error the folder "folder you entered doesn't appears to be valid".

I have tried all options like I have created a doc folder in /webdav/doc in ISPCONFIG control panel

Now when I am trying to access the same by adding network location I have tried all possible combinations like
  1. http://user(actual user name)ass(actual password)@mydomain.tld/webdav/doc
  2. http://user(actual user name)ass(actual password)@mydomain.tld/doc
  3. http://mydomain.tld/doc

but none of the above work.
However one thing I have noticed which needs attention in particular that is "webdav folder is being created outsite the default /web folder. "Could this be the reason for the error?

Please help.
Reply With Quote
  #3  
Old 27th February 2011, 23:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
"Could this be the reason for the error?
No, thats not related. The webdav folder is outside of the web folder in ispconfig, as webdav is a separate service e.g. for sharing calendars and not meant to update or upload any files into the web folder.

Which ispconfig version are you using?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 28th February 2011, 00:34
nokia80 nokia80 is offline
HowtoForge Supporter
 
Join Date: Apr 2009
Posts: 187
Thanks: 30
Thanked 2 Times in 2 Posts
Send a message via Skype™ to nokia80
Default not alowd

hi all I try to login, just get this error HTTP method not alowd

any idea?

michael
Reply With Quote
  #5  
Old 28th February 2011, 10:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

I guess that the webdav modules are either not installed or not enabled in apache. Which Linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 28th February 2011, 15:37
nokia80 nokia80 is offline
HowtoForge Supporter
 
Join Date: Apr 2009
Posts: 187
Thanks: 30
Thanked 2 Times in 2 Posts
Send a message via Skype™ to nokia80
Default

Quote:
Originally Posted by till View Post
I guess that the webdav modules are either not installed or not enabled in apache. Which Linux distribution do you use?

debian lenny
Reply With Quote
  #7  
Old 1st March 2011, 16:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Try this:

Code:
a2enmod dav_fs
a2enmod dav
/etc/init.d/apache2 restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Localhost lookups in system log kieron General 4 4th August 2010 20:45
Misc Post config problems... tonysch Installation/Configuration 3 29th June 2009 08:45
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
apache2 problem laser144 Server Operation 8 15th March 2007 17:32
Howto synchronize BIND with Windows NT thunderbird Server Operation 3 27th July 2006 12:01


All times are GMT +2. The time now is 14:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.