#1  
Old 22nd October 2010, 02:15
donix donix is offline
Junior Member
 
Join Date: Sep 2009
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default strange default page

Hello, I'm running ispconfig 3 on debian. I'm experiencing some strange behavior with it. I have created a few sites and some domains for email.
I discovered to day, when I visit a email-domain with a web-browser it shows the first website I added to ISPC. I guess it's because the domain is starting with ab(alphabetically the first site). E.g. emaildomain.tld shows ab.domain.tld

I have some domains who only is used for email and therefore isn't added to "sites" in ISPC. These domains should not show anything when visited by a web-browser.

How do I change this behavior?
Reply With Quote
Sponsored Links
  #2  
Old 22nd October 2010, 11:24
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Plese see here:

http://www.howtoforge.com/forums/sho...07&postcount=4
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd October 2010, 15:44
donix donix is offline
Junior Member
 
Join Date: Sep 2009
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks.. I've tried to add
Code:
<VirtualHost _default_:*>
DocumentRoot /var/www/default
</VirtualHost>
to /etc/apache2/sites-available/default and then restarted apache2. It dosen't make a difference
Reply With Quote
  #4  
Old 25th October 2010, 16:09
donix donix is offline
Junior Member
 
Join Date: Sep 2009
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default

I've tried
Code:
<VirtualHost *:80>
  ServerName default
  Redirect 404 /
</VirtualHost>
<VirtualHost _default_:80>
  Redirect 404 /
</VirtualHost>
from http://drupal.org/node/497522 but it persists loading the first website. I've tried to add it to apache2.conf and also tried as a file in sites-enabled. Can anyone help me?
Reply With Quote
  #5  
Old 27th October 2010, 22:58
donix donix is offline
Junior Member
 
Join Date: Sep 2009
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default

No one? My sites-enabled folder contains a 000-default file - has it something to do with that?
Reply With Quote
  #6  
Old 23rd November 2010, 19:28
rohitbanerjee rohitbanerjee is offline
Junior Member
 
Join Date: Nov 2010
Location: Mumbai, India
Posts: 16
Thanks: 1
Thanked 5 Times in 3 Posts
Default

Quote:
Originally Posted by donix View Post
No one? My sites-enabled folder contains a 000-default file - has it something to do with that?

AFAMK goes, 000-default is the default vhost. Try the code in 000-default, both in sites-enabled and in sites-available

Let me know if your problem is solved.
Reply With Quote
  #7  
Old 25th November 2010, 23:09
donix donix is offline
Junior Member
 
Join Date: Sep 2009
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

I've got more than one IP pointing at my server. I found out that I mixed that up in my vhosts. By fixing this Apache now responds with the default "It works!" when no vhosts is created for a domain pointing at the server

Thanks for your reply.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 14:51
User creating shoevring Developers' Forum 7 25th July 2010 10:17
amavis: (!!)WARN: all primary virus scanners failed, considering ba jariasca Installation/Configuration 13 20th April 2010 17:34
Admin Program for Virtual Users and Domains Postfix courier etc...(Ubuntu 8.04)? the1rob HOWTO-Related Questions 11 4th August 2009 04:54
Exim MTA dazblade Server Operation 4 16th July 2007 18:42


All times are GMT +2. The time now is 11:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.