Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th October 2010, 16:32
MyKE MyKE is offline
Junior Member
 
Join Date: Feb 2010
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Default DNS not responding

Hi there,

I'm using bind and i followed Perfect Server - Debian Lenny (Debian 5.0) With BIND & Dovecot. I have set up correct IP in dns managment, fqdn. But pages does not work. Before bind, i was using mydns and it worked. Now i have bind and syslog shows this:

Code:
Oct 25 16:20:04 server1 named[20544]: loading configuration from '/etc/bind/named.conf'
Oct 25 16:20:04 server1 named[20544]: using default UDP/IPv4 port range: [1024, 65535]
Oct 25 16:20:04 server1 named[20544]: using default UDP/IPv6 port range: [1024, 65535]
Oct 25 16:20:04 server1 named[20544]: listening on IPv6 interfaces, port 53
Oct 25 16:20:04 server1 named[20544]: binding TCP socket: address in use
Oct 25 16:20:04 server1 named[20544]: listening on IPv4 interface lo, 127.0.0.1#53
Oct 25 16:20:04 server1 named[20544]: binding TCP socket: address in use
Oct 25 16:20:04 server1 named[20544]: listening on IPv4 interface eth0, 192.168.1.7#53
Oct 25 16:20:04 server1 named[20544]: binding TCP socket: address in use
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: 254.169.IN-ADDR.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: D.F.IP6.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: 8.E.F.IP6.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: 9.E.F.IP6.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: A.E.F.IP6.ARPA
Oct 25 16:20:04 server1 named[20544]: automatic empty zone: B.E.F.IP6.ARPA
Oct 25 16:20:04 server1 named[20544]: none:0: open: /etc/bind/rndc.key: permission denied
Oct 25 16:20:04 server1 named[20544]: couldn't add command channel 127.0.0.1#953: permission denied
Oct 25 16:20:04 server1 named[20544]: none:0: open: /etc/bind/rndc.key: permission denied
Oct 25 16:20:04 server1 named[20544]: couldn't add command channel ::1#953: permission denied
Oct 25 16:20:04 server1 named[20544]: zone 0.in-addr.arpa/IN: loaded serial 1
Oct 25 16:20:04 server1 named[20544]: zone 127.in-addr.arpa/IN: loaded serial 1
Oct 25 16:20:04 server1 named[20544]: zone 255.in-addr.arpa/IN: loaded serial 1
Oct 25 16:20:04 server1 named[20544]: zone electrohost.cz/IN: loaded serial 2010102405
Oct 25 16:20:04 server1 named[20544]: zone wzk.cz/IN: loaded serial 2010102404
Oct 25 16:20:04 server1 named[20544]: zone localhost/IN: loaded serial 2
Oct 25 16:20:04 server1 named[20544]: running
Oct 25 16:20:04 server1 named[20544]: zone electrohost.cz/IN: sending notifies (serial 2010102405)
Oct 25 16:20:04 server1 named[20544]: zone wzk.cz/IN: sending notifies (serial 2010102404)
Oct 25 16:20:04 server1 named[20544]: client 192.168.1.1#40626: received notify for zone 'electrohost.cz'
Oct 25 16:20:04 server1 named[20544]: client 192.168.1.1#19288: received notify for zone 'wzk.cz'
Oct 25 16:20:18 server1 named[3505]: client 81.92.148.241#40870: query (cache) 'www.vymenaodkazu.eu/A/IN' denied
Oct 25 16:20:19 server1 named[3505]: client 81.92.145.162#55410: query (cache) 'www.vymenaodkazu.eu/A/IN' denied
I'm using in ISPConfig 3.0.3 default dns templates so there is not mistake and i have correct NSSET.
Domain is wzk.cz.

Could you help me please set up working dns? Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 25th October 2010, 16:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

You had mydns installed on the same server and then switched the existing setup to bind without reinstalling the os?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th October 2010, 16:58
MyKE MyKE is offline
Junior Member
 
Join Date: Feb 2010
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Default

No, this is fresh installation of the os with Perfect Server lenny tutorial.
Reply With Quote
  #4  
Old 26th October 2010, 15:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

What's the output of
Code:
ls -la /etc/bind/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 26th October 2010, 15:26
MyKE MyKE is offline
Junior Member
 
Join Date: Feb 2010
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Default

output:
Code:
server1:~# ls -la /etc/bind/
celkem 24
drwxr-sr-x  3 root bind 1024 24.*říj 21.38 .
drwxr-xr-x 93 root root 6144 24.*říj 22.43 ..
-rw-r--r--  1 root root  353 10.*čen 21.32 db.empty
-rw-r--r--  1 root root  270 10.*čen 21.32 db.local
-rw-r--r--  1 root root 2878 10.*čen 21.32 db.root
-rw-r--r--  1 root root  237 10.*čen 21.32 db.0
-rw-r--r--  1 root root  271 10.*čen 21.32 db.127
-rw-r--r--  1 root root  237 10.*čen 21.32 db.255
-rw-r--r--  1 root bind  907 10.*čen 21.32 named.conf
-rw-r--r--  1 root bind  235 24.*říj 21.39 named.conf.local
-rw-r--r--  1 root bind  572 10.*čen 21.32 named.conf.options
-rw-r--r--  1 root bind  773 24.*říj 21.32 pri.electrohost.cz
-rw-r--r--  1 root bind  693 24.*říj 21.39 pri.wzk.cz
-rw-r-----  1 bind bind   77 24.*říj 20.33 rndc.key
drwxr-s---  2 root bind 1024 24.*říj 20.40 slave
-rw-r--r--  1 root root 1317 10.*čen 21.32 zones.rfc1918
Reply With Quote
  #6  
Old 27th October 2010, 14:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

What's in /etc/default/bind9?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 27th October 2010, 15:40
MyKE MyKE is offline
Junior Member
 
Join Date: Feb 2010
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Default

there is output:

Code:
server1:~# cat /etc/default/bind9
# run resolvconf?
RESOLVCONF=yes

# startup options for the server
OPTIONS="-u bind"
Reply With Quote
  #8  
Old 28th October 2010, 17:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Looks exactly like on my server (the same goes for the permissions). I have no idea what's wrong...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 28th October 2010, 19:30
MyKE MyKE is offline
Junior Member
 
Join Date: Feb 2010
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
Default

okay maybe is wrong nsset. but thanks for support guys
Reply With Quote
  #10  
Old 21st December 2010, 16:51
MyKE MyKE is offline
Junior Member
 
Join Date: Feb 2010
Posts: 28
Thanks: 4
Thanked 1 Time in 1 Post
 
Default

Hi, For a long time I haven't solved DNS problem. I start from begin.

I have Debian lenny ISPConfig 3.0.3.1 with myDNS. Created NSSet at domain registrator with glue records to my server IP. Server has open all ports (is in DMZ zone). Configured myDNS SOA with correct records. Correct hostname, static IP address. I dont know where is problem why online tools, dig, etc... shows that dns server is down at domain electrohost.cz. My hostname is server.electrohost.cz. Firts i look at netstat.

Quote:
netstat -tap | grep dns

tcp 0 0 server.electroho:domain *:* LISTEN 3478/mydns
tcp 0 0 localhost:domain *:* LISTEN 3478/mydns
tcp6 0 0 localhost:domain [::]:* LISTEN 3478/mydns
I think its okay.

Next resolv.conf

Quote:
cat /etc/resolv.conf
nameserver 192.168.1.1
nameserver 93.185.0.141
First name server is my router with DNS from ISP and next is my Public IP address my server.

Ports are open i tried it. DNS records are also in correct form with my own NS. ISPConfig shows all services online.
Looks like DNS server must work when i type address in browser but it doesn't work. I tried everything, 3 times reinstalled server with bind, mydns but same problem. I don't know where is problem. All is up, configured... I hope that anybody help me. At last i'm going to contact my ISP if block my services, i don't know. I know its my problem but I really dont know what to do I hope in some good idea. Thank you really for any help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS data from Standalone servers to Primary DNS server SamTzu Tips/Tricks/Mods 7 15th November 2009 13:38
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Google Apps dayjahone General 19 29th March 2008 17:25
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34


All times are GMT +2. The time now is 00:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.