Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd November 2010, 06:32
santasi24 santasi24 is offline
Junior Member
 
Join Date: Sep 2007
Posts: 10
Thanks: 6
Thanked 0 Times in 0 Posts
Default Installation error for dovecot

Hi guys while trying to install dovecot; the following error occurs, any ideas?



[root@mail ~]# rpm -ivh http://dl.atrpms.net/all/dovecot-1.2...c13.x86_64.rpm
Retrieving http://dl.atrpms.net/all/dovecot-1.2...c13.x86_64.rpm
warning: /var/tmp/rpm-tmp.je4mS8: Header V4 DSA/SHA1 Signature, key ID 66534c2b: NOKEY
error: Failed dependencies:
libpq.so.5()(64bit) is needed by dovecot-1:1.2.16-1_114.fc13.x86_64
Reply With Quote
Sponsored Links
  #2  
Old 22nd November 2010, 08:17
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
Default

Try:

Code:
yum update
yum clean all
and also try this:

https://public.commandprompt.com/pro.../Configure_Yum
__________________
Best regards

Jim
Reply With Quote
The Following User Says Thank You to itsnedkeren For This Useful Post:
santasi24 (23rd November 2010)
  #3  
Old 22nd November 2010, 08:28
kevin186 kevin186 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Thanks: 1
Thanked 4 Times in 3 Posts
Default

I had that same error when I was following the fedora 14 with ispconfig 3 tutorial. I did a yum install libpqxx.x86_64 and that shut it up. After finishing the install, I was never able to get dovecot running without errors. I scrapped that project and just installed fedora 13 with ispconfig 3 and it runs great.
Reply With Quote
The Following User Says Thank You to kevin186 For This Useful Post:
santasi24 (23rd November 2010)
  #4  
Old 23rd November 2010, 11:52
santasi24 santasi24 is offline
Junior Member
 
Join Date: Sep 2007
Posts: 10
Thanks: 6
Thanked 0 Times in 0 Posts
Default

I ended up doing the same as you kevin186(Fedora 13 setup),,,it works fine with outlook express, office 2003, thunderbird, but office 2010 crashes as soon as I send receive.

Very strange.
Reply With Quote
  #5  
Old 23rd November 2010, 14:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by santasi24 View Post
Hi guys while trying to install dovecot; the following error occurs, any ideas?



[root@mail ~]# rpm -ivh http://dl.atrpms.net/all/dovecot-1.2...c13.x86_64.rpm
Retrieving http://dl.atrpms.net/all/dovecot-1.2...c13.x86_64.rpm
warning: /var/tmp/rpm-tmp.je4mS8: Header V4 DSA/SHA1 Signature, key ID 66534c2b: NOKEY
error: Failed dependencies:
libpq.so.5()(64bit) is needed by dovecot-1:1.2.16-1_114.fc13.x86_64
Do you have an x86_64 or an i386 system? What's the output of
Code:
uname -a
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 24th November 2010, 09:27
santasi24 santasi24 is offline
Junior Member
 
Join Date: Sep 2007
Posts: 10
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Here is the reply:


Linux mail.mydomain.com 2.6.34.7-61.fc13.x86_64 #1 SMP Tue Oct 19 04:06:30 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Reply With Quote
  #7  
Old 24th November 2010, 15:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

it's a 64bit system, so that's ok. What's the output of
Code:
yum search libpq
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 25th November 2010, 13:50
santasi24 santasi24 is offline
Junior Member
 
Join Date: Sep 2007
Posts: 10
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Here is the output:





libpqxx-devel.i686 : Development tools for libpqxx
libpqxx-devel.x86_64 : Development tools for libpqxx
libpqxx.i686 : C++ client API for PostgreSQL
libpqxx.x86_64 : C++ client API for PostgreSQL
ocaml-postgresql.x86_64 : OCaml library for accessing PostgreSQL databases
perl-pgsql_perl5.x86_64 : Pg - Perl5 extension for PostgreSQL
postgresql-odbcng.i686 : PostgreSQL ODBCng driver
postgresql-odbcng.x86_64 : PostgreSQL ODBCng driver
Reply With Quote
  #9  
Old 26th November 2010, 14:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Try
Code:
yum install libpqxx libpqxx-devel
and then try to install dovecot again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following 2 Users Say Thank You to falko For This Useful Post:
kevin186 (3rd December 2010), santasi24 (9th December 2010)
  #10  
Old 3rd December 2010, 16:17
kevin186 kevin186 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 6
Thanks: 1
Thanked 4 Times in 3 Posts
 
Default

Quote:
Originally Posted by falko View Post
Try
Code:
yum install libpqxx libpqxx-devel
and then try to install dovecot again.
I retried my installation of fedora 14 with ispconfig 3 using this tip from falko and everything worked perfectly this time. Thanks.
Reply With Quote
The Following User Says Thank You to kevin186 For This Useful Post:
santasi24 (9th December 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig installation into multiple OpenVZ containers letezo Installation/Configuration 11 3rd March 2009 22:47
CentOS 5.1 - ISPConfig Installation completed but init.d/ispconfig_server not found?? tozden Installation/Configuration 1 15th May 2008 10:21
Broken installation Endymion Installation/Configuration 4 12th October 2007 09:42
newbie ububtu 6.0.6 error PHP binary line 816 davidsky73 Installation/Configuration 8 17th September 2006 11:51
ISPC install stops str2etboy Installation/Configuration 19 28th January 2006 07:18


All times are GMT +2. The time now is 03:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.