#1  
Old 17th November 2010, 17:28
Mosquito Mosquito is offline
Member
 
Join Date: Nov 2006
Posts: 85
Thanks: 5
Thanked 4 Times in 3 Posts
Default Enable gzip compression

I've been using Google's web master tools and I keep getting the suggestion to enable gzip compression on my domains. How can I do this through ISPConfig?

I'm running 3.0.3.
Reply With Quote
Sponsored Links
  #2  
Old 18th November 2010, 16:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

You must set this up manually: http://www.howtoforge.com/apache2_mod_deflate
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th May 2012, 21:26
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 368
Thanks: 25
Thanked 47 Times in 42 Posts
 
Thumbs up

I, too, wondered how to enable GZIP compression in Apache on Debian (Ubuntu 10.04). Here are my findings.

1.) Add directives to Apache configuration, e.g., to /etc/apache2/httpd.conf:

Code:
<IfModule mod_deflate.c>
<Location />
# Insert filter
SetOutputFilter DEFLATE

# Netscape 4.x has some problems...
BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
# the above regex won't work. You can use the following
# workaround to get the desired effect:
# BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

# Don't compress images
SetEnvIfNoCase Request_URI \
\.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don't deliver the wrong content
Header append Vary User-Agent env=!dont-vary
</Location>
</IfModule>
Note: For versions of Apache <= 2.0.48, read the comments carefully; it is necessary to un-comment the last BrowserMatch directive.

Note: This above block comes straight from the Apache documentation.

2.) Enable the required modules; both mod_deflate and mod_headers are required. (mod_headers is required for the last directive in the above snippet.)

Code:
# a2enmod deflate
# a2enmod headers
# service apache2 restart
Pages should now be served with GZIP compression. There are a number of utilities with which to test, e.g., http://www.whatsmyip.org/http-compression-test/ .

Good luck!
Reply With Quote
The Following User Says Thank You to cbj4074 For This Useful Post:
falko (16th May 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation -- pcre_exec.c:403: internal compiler error: Segmentation fault zerman Installation/Configuration 2 23rd September 2008 23:58
PHP install problem SgtM Installation/Configuration 6 7th April 2007 17:45
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! micko_escalade Installation/Configuration 35 30th March 2007 11:31
Fedora Core 6 install issues moos3 Installation/Configuration 10 22nd March 2007 18:25
Another ERROR: The PHP binary coming with ISPConfig does not work properly on your sy hoopsx3 Installation/Configuration 2 29th January 2007 07:56


All times are GMT +2. The time now is 10:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.