#1  
Old 15th November 2010, 13:44
gring gring is offline
Member
 
Join Date: Mar 2009
Posts: 46
Thanks: 2
Thanked 3 Times in 3 Posts
Default postfix configuration for IDN

Hi, I have several domain names with accents (IDN).
the mail forwards for these domains work from an external mailbox (gmail), but you can't send mail to such an address from a mailbox on the ispconfig server.

postfix answers: " 5.1.3 Bad recipient address syntax"

I modified the master.cf file to change strict_rfc821_envelopes=yes to strict_rfc821_envelopes=no.

It still doesn't work.

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 15th November 2010, 16:51
gring gring is offline
Member
 
Join Date: Mar 2009
Posts: 46
Thanks: 2
Thanked 3 Times in 3 Posts
Default

It seems it would be more complicated:

The international domain names must me converted to punycode, it seems that's what Gmail smtp server does.

So Postfix would need to detect when an adress has an Unicode format, and convert it automatically to punycode.

I dont find doc about that.
Reply With Quote
  #3  
Old 16th November 2010, 16:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

I've added this to our bugtracker.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 21st November 2010, 10:11
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,677
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
 
Default

Have you entered the mail domain names in punicode in ispconfig?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
postfix idn rfc821

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
mail authentication failure - unknown user or password evok Installation/Configuration 9 16th October 2010 06:37
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 21:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.