#1  
Old 1st November 2010, 20:35
scmcmanus scmcmanus is offline
Junior Member
 
Join Date: Oct 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default VI E37 Error Message

Hello,

I don't know if I am sending my question to the correct spot. If not, please redirect me. Thanks.

I installed Ubuntu server and Kubuntu desktop version 10.10, and tried to edit several files (example: etc/network/interfaces, the primary network interface file) with vi and vim. When I tried to save my work by using the command ":q", I receive an "E37: No write since last change (add ! to override)" When I use ":q!" vi quits without saving my changes.

I am logged in as root, and have chmod 666 and chmod 777 to the interfaces file.

I am able to update software packages without problems. What is causing this problem?
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2010, 18:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Please use :x to save changes. Use :q if you didn't modify the file.

http://www.howtoforge.com/faq/12_15_en.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
vi e37 :q

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.