Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th October 2010, 22:58
kmullen kmullen is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default Testing websites/domains on local network

Little help please.

I crashed my Ispconfig 2 server during upgrade.

Built new server with Ispconfig 3 perfect server Ubuntu 10.10

Moved created all domains and dns records on new server and moved all webfiles.

I want to be able to test all domains and sites on server before deploying.

Changed DNS on interface to use Ispconfig as dns server.

I am not able to access the websites using their domain name. I am also not able to ping sites by domain name.

What do I have to do to fully test server before going live?
Reply With Quote
Sponsored Links
  #2  
Old 31st October 2010, 01:07
jtheed jtheed is offline
Member
 
Join Date: Jul 2007
Posts: 70
Thanks: 12
Thanked 4 Times in 3 Posts
Default

Quote:
Originally Posted by kmullen View Post
Little help please.

I crashed my Ispconfig 2 server during upgrade.

Built new server with Ispconfig 3 perfect server Ubuntu 10.10

Moved created all domains and dns records on new server and moved all webfiles.

I want to be able to test all domains and sites on server before deploying.

Changed DNS on interface to use Ispconfig as dns server.

I am not able to access the websites using their domain name. I am also not able to ping sites by domain name.
cWhat do I have to do to fully test server before going live?

If you are using a Windoze machine as the client, you can always edit the windows/system32/drivers/etc/hosts file and by just putting in the address of your server 192.168.0.1 www.domainname.com you can access it like your on the internet.
Reply With Quote
  #3  
Old 31st October 2010, 02:17
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by jtheed View Post
If you are using a Windoze machine as the client, you can always edit the windows/system32/drivers/etc/hosts file and by just putting in the address of your server 192.168.0.1 www.domainname.com you can access it like your on the internet.
Or edit your DNS servers in the network settings on your Win machine ---put the local IP of your server in there as the primary DNS server. When done, swap it back.
Reply With Quote
  #4  
Old 31st October 2010, 19:12
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 14 Times in 8 Posts
Talking

Quote:
Originally Posted by mini14 View Post
Or edit your DNS servers in the network settings on your Win machine ---put the local IP of your server in there as the primary DNS server. When done, swap it back.
Add to :
windows/system32/drivers/etc/hosts

ns1.mysite.local local_ip

and dns to network settings.
Reply With Quote
  #5  
Old 31st October 2010, 20:41
kmullen kmullen is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Success

Thanks for the answers.

I changed my dns servers to point to the ISPConfig box, and had IPSCONFIG setup as dns server. This didn't work.

However, modifying the host file on my Win7 machine did work and I was able to test all my sites successfully. Thank you all for your help. New box on the network.
Reply With Quote
  #6  
Old 3rd December 2010, 16:08
tbctr tbctr is offline
Member
 
Join Date: Dec 2010
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
Default Centos 5.5 + ISPConfig 3

Centos 5.5 + ISPConfig 3 installed.
I have the same problem. Local network access ISPConfig control panel no problem, added website but local network not access added web site. host file added ip, address - dns ip added server ip but not access added web site.
Reply With Quote
  #7  
Old 4th December 2010, 12:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Does the DNS record of the domain point to your server's public IP? Does your router support loopbacks? Also make sure that your ISP doesn't block port 80.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 4th December 2010, 17:53
tbctr tbctr is offline
Member
 
Join Date: Dec 2010
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Server local ip : 192.168.1.250
ISPConfig admin page access ok.
http://192.168.1.250 Apache2 test page ok

ISPConfig added dns and website, my local network not access website.
Reply With Quote
  #9  
Old 4th December 2010, 19:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
 
Default

Make sure that you selected the correct IP address in the website settings. If the ip is not in the list, then add it under system > server ip.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
Unable to connect to Mysql mbascombe Installation/Configuration 12 10th January 2010 22:46
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
I Fail at installing ispconfig where did I go wrong? stocker741 Installation/Configuration 14 30th October 2008 14:12
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30


All times are GMT +2. The time now is 08:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.