Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th October 2010, 22:58
pier56 pier56 is offline
Member
 
Join Date: Aug 2010
Posts: 37
Thanks: 10
Thanked 4 Times in 3 Posts
Default Impossible to add new mail or website domain with 3.03

Hello,

I created several DNS domains with Ispconfig 3.02
Then I updated to 3.03.

I can't create another domain in domain table.
I have created a new DNS domain. I have access to url.

But new domain record is not created, and unavailable in lists for creating mail domain and website. I have verified domain table by phpmyadmin.

A clue ? I installed net2ftp by this script.

The script modifies two files, but it backups them. I have restored initial files, and removed the added files.

Same problem.

What could it happen ?

Thanks !
Reply With Quote
Sponsored Links
  #2  
Old 30th October 2010, 13:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

You add a new website and it does not show up in ispconfig interface or does it show up in the interface but the directories dont get created on harddisk?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th October 2010, 13:20
pier56 pier56 is offline
Member
 
Join Date: Aug 2010
Posts: 37
Thanks: 10
Thanked 4 Times in 3 Posts
Default Impossible to add new mail domain or website domain by 3.03

I hope that this title is more precise...

I can create a new DNS domain, and it works.

But after the new dns domain creation, there is no new record into domain sql table.

And the new domain is unavailable in drop-down Domain lists for creating mail domain and website.

With 3.02 and 3.03, I created a dns domain, and it appeared in drop-down Domain lists, and domain sql table.

This problem has happened after installing net2ftp wich modified two php pages. I have restored the initial php pages, but the problem stays.

What (php ?) script could fail ?
Reply With Quote
  #4  
Old 30th October 2010, 13:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

The domain module is not connected to the dns module, neither in ispconfig 3.0.2 nor ISPConfig 3.0.3. If you use the domain module, then you have to add domains there to show up in the dropdown lists. So there is no problem in your setup.

I guess what you mix up here is that when you initially enable the domain module (which is disabled by default) then all existing website domains get imported.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
pier56 (30th October 2010)
  #5  
Old 30th October 2010, 14:57
pier56 pier56 is offline
Member
 
Join Date: Aug 2010
Posts: 37
Thanks: 10
Thanked 4 Times in 3 Posts
 
Default

That's right !

In admin client, domaine module was unselected...

Thanks.
Reply With Quote
The Following User Says Thank You to pier56 For This Useful Post:
AbannyvabVask (20th December 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
sneaking suspicion my postfix config has gone awry mjbarfoot Installation/Configuration 7 24th August 2010 12:23
CGI and FormMail Cracklefish Installation/Configuration 17 13th October 2009 13:40
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50


All times are GMT +2. The time now is 00:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.