Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th October 2010, 16:40
chume chume is offline
Member
 
Join Date: Sep 2010
Posts: 33
Thanks: 4
Thanked 1 Time in 1 Post
Default too many apache open processes

As a beginner with ISPconfig I encountered an odd behavior on a server I setup. This server has 2GB RAM and time and again apache will time out loading a web page.
When I grepped httpd I found that too many apache processes are running. After I restart httpd, apache starts up with 10 processes and works like a charm.
I have run apache since 2001 as a standalone and never encountered such a scenario.

Please I need help to resolve this problem.
Thank you.

Chume
Reply With Quote
Sponsored Links
  #2  
Old 25th October 2010, 16:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,373
Thanks: 833
Thanked 5,479 Times in 4,313 Posts
Default

Which ispconfig version do you have installed?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th October 2010, 16:59
chume chume is offline
Member
 
Join Date: Sep 2010
Posts: 33
Thanks: 4
Thanked 1 Time in 1 Post
Default

Thank you for the quick response Till.
I installed version 3.0.3
Reply With Quote
  #4  
Old 25th October 2010, 17:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,373
Thanks: 833
Thanked 5,479 Times in 4,313 Posts
Default

Please check the apache error log for errors. How many requests per minute do you get approx?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th October 2010, 18:03
chume chume is offline
Member
 
Join Date: Sep 2010
Posts: 33
Thanks: 4
Thanked 1 Time in 1 Post
Default

The only entry in the apache error log is below:

Quote:
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
Thank you Till
Reply With Quote
  #6  
Old 25th October 2010, 19:15
chume chume is offline
Member
 
Join Date: Sep 2010
Posts: 33
Thanks: 4
Thanked 1 Time in 1 Post
Default

Could the ProcessLifeTime of 7200 in each domain vhost configuration lead to this this kind of issue?
Quote:
# php as fast-cgi enabled
<IfModule mod_fcgid.c>
# SocketPath /tmp/fcgid_sock/
IdleTimeout 3600
ProcessLifeTime 7200
# MaxProcessCount 1000
DefaultMinClassProcessCount 3
DefaultMaxClassProcessCount 100
IPCConnectTimeout 8
IPCCommTimeout 360
BusyTimeout 300
</IfModule>
Reply With Quote
  #7  
Old 26th October 2010, 00:27
chume chume is offline
Member
 
Join Date: Sep 2010
Posts: 33
Thanks: 4
Thanked 1 Time in 1 Post
Default

After searching the Internet and tweaking several of the apache conf files, one solution seems to have helped so far.

Quote:
# php as fast-cgi enabled
<IfModule mod_fcgid.c>
# SocketPath /tmp/fcgid_sock/
IdleTimeout 3600
ProcessLifeTime 7200
# MaxProcessCount 1000
DefaultMinClassProcessCount 3
DefaultMaxClassProcessCount 100
IPCConnectTimeout 8
IPCCommTimeout 360
BusyTimeout 300
</IfModule>
Changing the value of "DefaultMinClassProcessCount" to 0 terminates the lingering apache processes.

Thank you
Reply With Quote
  #8  
Old 26th October 2010, 01:07
chume chume is offline
Member
 
Join Date: Sep 2010
Posts: 33
Thanks: 4
Thanked 1 Time in 1 Post
Default

My question is how to force ISPconfig to set DefaultMinClassProcessCount 3 to 0 when a vhost conf file is created.

Thank you
Reply With Quote
  #9  
Old 26th October 2010, 09:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,373
Thanks: 833
Thanked 5,479 Times in 4,313 Posts
Default

You can change all vhost variables by editing the vhost master template file in /usr/local/ispconfig/server/conf/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 26th October 2010, 14:02
chume chume is offline
Member
 
Join Date: Sep 2010
Posts: 33
Thanks: 4
Thanked 1 Time in 1 Post
 
Default

Thank you so much Till.
I modified the vhost variable on vhost.conf.master file.
After manually changing the vhost variables yesterday, the server is still holding up today.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem 100% CPU ispconfig_httpd -DSSL Captain Installation/Configuration 7 8th March 2010 21:50
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
open ports rayit General 6 18th January 2006 14:23


All times are GMT +2. The time now is 13:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.