Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th October 2010, 00:37
tylerishappy tylerishappy is offline
Member
 
Join Date: Nov 2008
Location: Saskatchewan, Canada
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default imapd: Error reading ACLs for : Invalid argument

I am recieving this error message every time I use Send / Received from Outlook.

I have a Ubuntu Server setup with ISPConfig 3.0

i have Outlook setup using IMAP



/var/log/mail.err
Oct 25 15:37:16 spider imapd: Error reading ACLs for : Invalid argument
Oct 25 15:43:12 spider imapd: Error reading ACLs for : Invalid argument
Oct 25 15:49:23 spider imapd: Error reading ACLs for : Invalid argument
Oct 25 15:52:13 spider imapd: Error reading ACLs for : Invalid argument
Oct 25 16:00:28 spider imapd: Error reading ACLs for : Invalid argument
Oct 25 16:01:14 spider imapd: Error reading ACLs for : Invalid argument
Oct 25 16:01:37 spider imapd: Error reading ACLs for : Invalid argument
Oct 25 16:22:21 spider imapd: Error reading ACLs for : Invalid argument
Reply With Quote
Sponsored Links
  #2  
Old 26th October 2010, 15:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Do you use Courier or Dovecot? Did you set up any whitelist or blacklist records in ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th October 2010, 16:52
tylerishappy tylerishappy is offline
Member
 
Join Date: Nov 2008
Location: Saskatchewan, Canada
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Courier
Just checked ISPConfig - no whitelist or blacklist
Reply With Quote
  #4  
Old 27th October 2010, 14:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Are you having problems fetching mails from the server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th October 2010, 16:43
tylerishappy tylerishappy is offline
Member
 
Join Date: Nov 2008
Location: Saskatchewan, Canada
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same account setup on multiple computers. On 1 of the computers I cannot send via my email address but I can receive. On the other 2 I can send and receive with no issues.

The reason I found this issue is because I am trying to find out why I cannot send. I have double checked all of my account settings and they match to the other computers.
Reply With Quote
  #6  
Old 28th October 2010, 18:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Your IMAP daemon has nothing to do with sending emails. Are there any Postfix errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 28th October 2010, 19:42
tylerishappy tylerishappy is offline
Member
 
Join Date: Nov 2008
Location: Saskatchewan, Canada
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Recent Mail Log

user@spider:/var/log$ tail mail.log
Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=5835, sent=50115, time=67
Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=367, sent=10406, time=69
Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=122, sent=5147, time=67
Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=2934, sent=25821, time=48
Oct 28 11:13:09 spider imapd: Connection, ip=[::ffff:11.IPADDRESS.11]
Oct 28 11:13:10 spider imapd: LOGIN, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], port=[51011], protocol=IMAP
Oct 28 11:13:10 spider imapd: Error reading ACLs for : Invalid argument
Oct 28 11:13:10 spider imapd: Connection, ip=[::ffff:11.IPADDRESS.11]
Oct 28 11:13:10 spider imapd: LOGIN, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], port=[51014], protocol=IMAP
Oct 28 11:13:57 spider imapd: Error reading ACLs for : Invalid argument
user@spider:/var/log$ tail mail.log
Oct 28 11:13:57 spider imapd: Error reading ACLs for : Invalid argument
Oct 28 11:15:00 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=5615, sent=49516, time=110
Oct 28 11:15:01 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=5751, sent=49884, time=111
Oct 28 11:15:01 spider imapd: Connection, ip=[::1]
Oct 28 11:15:01 spider pop3d: Connection, ip=[::1]
Oct 28 11:15:01 spider imapd: Disconnected, ip=[::1], time=0
Oct 28 11:15:01 spider pop3d: Disconnected, ip=[::1]
Oct 28 11:15:01 spider postfix/smtpd[30948]: connect from localhost[127.0.0.1]
Oct 28 11:15:01 spider postfix/smtpd[30948]: lost connection after CONNECT from localhost[127.0.0.1]
Oct 28 11:15:01 spider postfix/smtpd[30948]: disconnect from localhost[127.0.0.1]

Last edited by tylerishappy; 28th October 2010 at 22:16.
Reply With Quote
  #8  
Old 28th October 2010, 22:16
tylerishappy tylerishappy is offline
Member
 
Join Date: Nov 2008
Location: Saskatchewan, Canada
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Still cannot send email from the one account through the one server.
- computer: Windows 7, Office 2007
- Server: Ubuntu, ISPConfig 3
Reply With Quote
  #9  
Old 29th October 2010, 14:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

What are the outputs of
Code:
netstat -tap
and
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 29th October 2010, 19:19
tylerishappy tylerishappy is offline
Member
 
Join Date: Nov 2008
Location: Saskatchewan, Canada
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

USER@spider:~$ sudo netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 29635/mysqld
tcp 0 0 *:http-alt *:* LISTEN 6181/apache2
tcp 0 0 *:www *:* LISTEN 6181/apache2
tcp 0 0 *:tproxy *:* LISTEN 6181/apache2
tcp 0 0 *:ftp *:* LISTEN 22868/pure-ftpd (SE
tcp 0 0 spider.(MYDOMAIN).co:domain *:* LISTEN 26377/named
tcp 0 0 localhost:domain *:* LISTEN 26377/named
tcp 0 0 *:ssh *:* LISTEN 29355/sshd
tcp 0 0 localhost:953 *:* LISTEN 26377/named
tcp 0 0 *:smtp *:* LISTEN 25464/master
tcp 0 0 *:https *:* LISTEN 6181/apache2
tcp 0 0 localhost:10024 *:* LISTEN 2182/amavisd (ch10-
tcp 0 0 localhost:10025 *:* LISTEN 25464/master
tcp 1 0 localhost:51913 localhost:mysql CLOSE_WAIT 30916/amavisd (ch10
tcp 0 0 localhost:37662 localhost:mysql ESTABLISHED 2182/amavisd (ch10-
tcp 0 0 localhost:mysql localhost:37662 ESTABLISHED 29635/mysqld
tcp 0 52 spider.(MYDOMAIN).com:ssh h208-118-95-82.bi:32319 ESTABLISHED 12893/sshd: USER
tcp6 0 0 [::]op3 [::]:* LISTEN 26291/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 26258/couriertcpd
tcp6 0 0 [::]:ftp [::]:* LISTEN 22868/pure-ftpd (SE
tcp6 0 0 [::]:domain [::]:* LISTEN 26377/named
tcp6 0 0 [::]:ssh [::]:* LISTEN 29355/sshd
tcp6 0 0 localhost:953 [::]:* LISTEN 26377/named
tcp6 0 0 [::]:imaps [::]:* LISTEN 26280/couriertcpd
tcp6 0 0 [::]op3s [::]:* LISTEN 26308/couriertcpd
Reply With Quote
Reply

Bookmarks

Tags
imap, mail, ubuntu

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After updating Fedora 13 - Unable to login in kernel 3 and 5 Besrilo Kernel Questions 6 12th August 2010 19:01
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
squirrelmail and postfix witoszek General 12 1st December 2009 18:07
Mail not working epicuniversal General 5 13th June 2009 08:24
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22


All times are GMT +2. The time now is 04:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.