Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #51  
Old 28th August 2007, 14:18
Blacknight Blacknight is offline
Junior Member
 
Join Date: Aug 2007
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default Help me...

I'm a newbie please help me, i was installing Ispconfig in my PC and then i want to install squirrelmail for mailserver. then i'm trying to install this package but don't know how to install, please help me?? I use debian, thanks before.
Reply With Quote
Sponsored Links
  #52  
Old 28th August 2007, 14:22
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,351
Thanks: 810
Thanked 5,174 Times in 4,056 Posts
Default

Login to ispconfig, go to management > software > update and install the squirrelmail package from ispconfig.org
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Blacknight (28th August 2007)
  #53  
Old 28th August 2007, 14:37
Blacknight Blacknight is offline
Junior Member
 
Join Date: Aug 2007
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks till for the solve, its help me a lot
Reply With Quote
  #54  
Old 14th September 2007, 18:52
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

Quote:
Originally Posted by bwrob
For Squirrelmail not to show my true username.
Install virtusertable plugin.
In squirrelmail config.php:

$domain = 'substr($domain, strpos($domain, '.') + 1';
$imapServerAddress = 'localhost';
$imapPort = 143;
$useSendmail = false;
$smtpServerAddress = 'localhost';
$smtpPort = 25;
$sendmail_path = '/usr/sbin/sendmail';
$sendmail_args = '-i -t';
$pop_before_smtp = false;
$imap_server_type = 'dovecot';
$invert_time = false;
$optional_delimiter = 'detect';
$encode_header_key = 'yourencodetexthere';


Then make sure that squirrelmail user personal information is is filled up.

Also in my main httpd.conf i inserted.

Alias /squirrelmail /srv/www/squirrelmail/

That way got access from any website.

Works for me

bob
Where is the plugin? the code is the plugin? this code is wrong written.

This :
$domain = 'substr($domain, strpos($domain, '.') + 1';

Should be something like:

$domain = substr($username, strpos($username, '@') + 1';

Otherwise you will get "user@com"
Reply With Quote
  #55  
Old 14th September 2007, 19:50
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

Quote:
Originally Posted by fobicodam
Where is the plugin? the code is the plugin? this code is wrong written.

This :
$domain = 'substr($domain, strpos($domain, '.') + 1';

Should be something like:

$domain = substr($username, strpos($username, '@') + 1';

Otherwise you will get "user@com"
To Fix it do that:

on config/config.php line 32, replace:
'$domain = 'example.com';
sqgetGlobalVar('domainname',$domain,SQ_SESSION);

on redirect.php, line 50, add:
sqsession_register(substr($login_username, strpos($login_username, '@') + 1), 'domainname');

Fixed, every user will get the domain name they use to login.
Reply With Quote
The Following User Says Thank You to fobicodam For This Useful Post:
Feanwulf (2nd June 2008)
  #56  
Old 19th September 2007, 11:30
exmedia exmedia is offline
Junior Member
 
Join Date: Aug 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question error in squirrelMail

I just installed SquirrelMail en it seems that its working.. but in the inbox (where is new mail) I get this error:

Code:
Category:  PHP  
Message:  preg_split() expects parameter 4 to be long, string given  
FILE:  /home/admispconfig/ispconfig/web/squirrelmail/functions/imap_messages.php  
LINE:  926  
Category:  PHP  
Message:  Invalid argument supplied for foreach()  
FILE:  /home/admispconfig/ispconfig/web/squirrelmail/functions/mime.php  
LINE:  52
and it looks like that I cant send mail from SquirrelMail

I hope that someone can help me
Reply With Quote
  #57  
Old 20th September 2007, 14:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #58  
Old 25th October 2007, 13:44
flofly flofly is offline
Junior Member
 
Join Date: Oct 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Squirrelmail - Spamassassin Settings with ISPConfig

Hello

I want to add the possibility to add Spamassassin Configuration / Black-/Whitelisting, Quarantaine, .... to Squirrelmail. So that each user can easily change his settings.

At my previous server I used the amavisnewsql-Squirrelmail plugin for this purpose. Since ISPConfig is not working with Amavis I think this one will not work.

There are a few other Squirrelmail Plugins but they all are look quite outdated. Does anybody has some experience with that an can give me suggestion?

Thanks
Florian
Reply With Quote
  #59  
Old 23rd June 2008, 14:40
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 201
Thanks: 68
Thanked 13 Times in 11 Posts
Default

Hi all

I have problem with login to the squirrelmail on new server. First everything was ok:

Code:
Jun 11 14:09:17 s4 imapd: LOGIN, user=web2test, ip=[::ffff:127.0.0.1], port=[59198], protocol=IMAP
Jun 11 14:09:17 s4 imapd: LOGOUT, user=web2test, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=13, sent=86, time=0
but after few time a cannot login because squirrelmail started use domain of this user with username too:

Code:
Jun 11 15:14:34 s4 imapd: LOGIN FAILED, user=web2test@mydomain.cz, ip=[::ffff:127.0.0.1]
I tried delete squirrelmail and reinstall and reinstall whole ispconfig but without success .. maybe I changed something directly in user account when logged in? All what I did, except playing with squirrelmail, was installing of awstats.

Webmail works fine and squirrelmail on other servers works fine too.

Thanks for help

SupuS
Reply With Quote
  #60  
Old 23rd June 2008, 15:47
tebokkel tebokkel is offline
Member
 
Join Date: Feb 2007
Location: The Netherlands
Posts: 96
Thanks: 0
Thanked 9 Times in 9 Posts
 
Default

If anything, it has to do with your IMAP-server, which looks like Courier. The Courier authdaemon should then be configured, it it were wrong (it probably isn't).
As ISPConfig only supports real accounts (not virtual email-only accounts), you should try to login using an accountname, not the email address. You can have multiple web2test-addresses in different domains, but these are aliasses (or forwards) that get rewritten by (in my case) Postfix.

Stick to the account as login to Squirrelmail and it should work.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual users, domains Postfix.. & Squirrelmail laser144 HOWTO-Related Questions 6 4th May 2006 23:23
Help....package missing sbovisjb1 Installation/Configuration 3 31st March 2006 11:14
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 13th March 2006 23:58
Logging in to isp config Jrdgames General 43 6th March 2006 19:04
suse 9.3 install: E: Couldn't find package ncftp aallen Installation/Configuration 4 26th January 2006 20:02


All times are GMT +2. The time now is 12:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.