Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #41  
Old 7th December 2006, 01:06
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

I've got this nice "skin" that I would like to use, but I'm having some problems with it.

1) I can only login with web#nr#_name
2) The user needs to set all the seting in "Options - Personal Information" when loged in for the 1st time(it's not showing any info like name, emailaddress and domain name)

It's for sure some "hack" than I need to do in one or two files that come with the the "skin" version..

bkrausz (or any other person here), do you still know what file(s) you "hacked" to make it work with ISPconfig (like read all the needed data from the ISPconfig MySQL)?

Last edited by edge; 7th December 2006 at 01:14.
Reply With Quote
Sponsored Links
  #42  
Old 18th December 2006, 22:00
lns lns is offline
Junior Member
 
Join Date: Dec 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual domain trouble with Squirrelmail package

Hey all,

I recently installed the latest ispconfig and squirrelmail package addon from this thread - my customer is experiencing that whenever they log into Squirrelmail and send a message, it actually reaches its destination with the "original" domain set up and not their virtual domain suffix.

So, for example, when they log in with "user@domain2.com" and send an e-mail, the e-mail reaches it's recipient with "user@domain1.com".

Everything else seems to be working fine. Any ideas?

Sincerely,
Jordan

**EDIT**
My customer states that this is not specific to Squirrelmail, but an all-around ISPConfig thing (he created an Outlook profile and experienced the same issues)... If anyone could help it would be greatly appreciated... Thank you!!

Last edited by lns; 19th December 2006 at 02:00.
Reply With Quote
  #43  
Old 19th December 2006, 21:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

You must set the correct sender address in your email client (webmail, Outlook, Thunderbird, etc.), as you do with every other email account as well.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #44  
Old 29th December 2006, 00:53
dennsy dennsy is offline
Junior Member
 
Join Date: Dec 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Smile thanks

Thanks....
__________________
dennsy
Reply With Quote
  #45  
Old 29th December 2006, 13:28
jazeman jazeman is offline
Junior Member
 
Join Date: Dec 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default hmmmm

ok but maby there should be a script in ispconfig to sett up squirrelmail to add the right mailadress when it anyways creates the acount.
and I cant log inn and when i send a mail. I get a mail on the server but still get the error msg.
Reply With Quote
  #46  
Old 29th December 2006, 18:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by jazeman
ok but maby there should be a script in ispconfig to sett up squirrelmail to add the right mailadress when it anyways creates the acount.
But when you set up an account in a normal email client such as Outlook or Thunderbird, you also specify the sender address manually. Why should this be different in Squirrelmail?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #47  
Old 5th January 2007, 00:17
bwrob bwrob is offline
Member
 
Join Date: Jan 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Default

For Squirrelmail not to show my true username.
Install virtusertable plugin.
In squirrelmail config.php:

$domain = 'substr($domain, strpos($domain, '.') + 1';
$imapServerAddress = 'localhost';
$imapPort = 143;
$useSendmail = false;
$smtpServerAddress = 'localhost';
$smtpPort = 25;
$sendmail_path = '/usr/sbin/sendmail';
$sendmail_args = '-i -t';
$pop_before_smtp = false;
$imap_server_type = 'dovecot';
$invert_time = false;
$optional_delimiter = 'detect';
$encode_header_key = 'yourencodetexthere';


Then make sure that squirrelmail user personal information is is filled up.

Also in my main httpd.conf i inserted.

Alias /squirrelmail /srv/www/squirrelmail/

That way got access from any website.

Works for me

bob
Reply With Quote
  #48  
Old 16th May 2007, 17:35
bitonw bitonw is offline
Junior Member
 
Join Date: May 2006
Location: Redhill, UK
Posts: 13
Thanks: 3
Thanked 0 Times in 0 Posts
Default How about update of the Squirrelmail Package?

Thanks a very nice and easy to install package. But what about Squirrelmail updates?

bt
__________________
bit4net.com
biton

Last edited by bitonw; 16th May 2007 at 17:53.
Reply With Quote
  #49  
Old 18th May 2007, 22:18
cryptic cryptic is offline
Senior Member
 
Join Date: Sep 2006
Posts: 136
Thanks: 5
Thanked 6 Times in 5 Posts
Default

Is there an updated package yet to cover this advisory - http://secunia.com/advisories/25320/ ?
Reply With Quote
  #50  
Old 28th July 2007, 13:41
tebokkel tebokkel is offline
Member
 
Join Date: Feb 2007
Location: The Netherlands
Posts: 96
Thanks: 0
Thanked 9 Times in 9 Posts
 
Default

There is no current need to update. This is the most current version (1.5.1) and the advisory above is about the 1.4 branch.

I've just checked the package and compared it with Squirrelmail 1.5.1 from the squirrelmail.org site:

Quote:
# diff -ru squirrelmail-1.5.1/ squirrelmail/
Only in squirrelmail/: attach
Only in squirrelmail/config: config.php
Only in squirrelmail/: data
Only in squirrelmail/plugins: compatibility
Only in squirrelmail/plugins: vlogin
diff -ru squirrelmail-1.5.1/templates/default/login.tpl squirrelmail/templates/default/login.tpl
--- squirrelmail-1.5.1/templates/default/login.tpl 2006-02-08 23:02:46.000000000 +0100
+++ squirrelmail/templates/default/login.tpl 2006-06-16 20:59:07.000000000 +0200
@@ -35,7 +35,7 @@
</tr>
<tr>
<td class="sqm_loginFieldName">
- <?php echo _("Name:"); ?>
+ <?php echo _("Email Address:"); ?>
</td>
<td class="sqm_loginFieldInput">
<?php echo $login_field; ?>

The packaging is almost trivial (with the current version as baseline), so I think any security update could be available in hours after the new SM-release.

Paul
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual users, domains Postfix.. & Squirrelmail laser144 HOWTO-Related Questions 6 5th May 2006 00:23
Help....package missing sbovisjb1 Installation/Configuration 3 31st March 2006 12:14
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 14th March 2006 00:58
Logging in to isp config Jrdgames General 43 6th March 2006 20:04
suse 9.3 install: E: Couldn't find package ncftp aallen Installation/Configuration 4 26th January 2006 21:02


All times are GMT +2. The time now is 11:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.