Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 30th September 2006, 16:04
ikaros ikaros is offline
Member
 
Join Date: Aug 2006
Posts: 35
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Then it's installed within ISPConfig's web space, and you must use something like http(s)://example.com:81/squirrelmail/

yeap, https://www.example.com:81/squirrelmail did the trick. Thanx!
Reply With Quote
Sponsored Links
  #32  
Old 1st October 2006, 00:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by tom
I can't create an new folder whithin SquirrelMail whithout creating it as subfolder in INBOX. I've tried to create an new folder beside to INBOX called SPAMBOX but always I ge this error:




What's wrong?
What's in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #33  
Old 21st November 2006, 20:26
bosei bosei is offline
Member
 
Join Date: Aug 2005
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

STEP 3. link it to sites-enabled:
Code:
ln -s /etc/apache2/sites-available/webmail.conf /etc/apache2/sites-enabled/webmail.conf

This seems to be self referencing. What are we linking to what. Can the same thing be achieved by including webmail.conf in httpd.conf?
Reply With Quote
  #34  
Old 22nd November 2006, 16:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by bosei
STEP 3. link it to sites-enabled:
Code:
ln -s /etc/apache2/sites-available/webmail.conf /etc/apache2/sites-enabled/webmail.conf

This seems to be self referencing.
No, it isn't. You're linking /etc/apache2/sites-enabled/webmail.conf to /etc/apache2/sites-available/webmail.conf.

Quote:
Originally Posted by bosei
Can the same thing be achieved by including webmail.conf in httpd.conf?
Yes.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #35  
Old 22nd November 2006, 18:22
bosei bosei is offline
Member
 
Join Date: Aug 2005
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by falko
No, it isn't. You're linking /etc/apache2/sites-enabled/webmail.conf to /etc/apache2/sites-available/webmail.conf.

Yes.
Thanks Falco. On a quick read i missed the difference completely.
Reply With Quote
  #36  
Old 30th November 2006, 17:41
actionplant actionplant is offline
Junior Member
 
Join Date: Nov 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I installed in this fashion following the Perfect Setup Ubuntu 6.06 install. I installed the latest stable release of ISPConfig two days ago, then this Squirrelmail package. I set up websites, and under ISP Site in the User & Email tab created a new mail user for each domain.

I can get to the Squirrelmail login page for each domain, but after submitting with the email address and password (as configured for user web1_user, web2_user, etc as created in ISPConfig) I get the following error:

Quote:
ERROR: IMAP server closed the connection.
Server responded:* BYE [ALERT] Fatal error: Maildir: No such file or directory
I've noticed that even though I set up ISPConfig according to the install manual on their site, supposedly configured to go to http://odin.trekbeyond.org:81 I can get there with or without the "odin" subdomain, ie http://trekbeyond.org:81 also works. When I log into Squirrelmail, for one domain the first redirect is to http://odin.trekbeyond.org:81/squirr...c/redirect.php, but for another domain the redirect is to http://trekbeyond.org:81/squirrelmail/src/redirect.php but it doesn't seem to make a difference, I keep getting the same error. Any ideas?

What am I missing? Under Server Settings in ISPConfig the server name is odin, the Hostname is odin, and the domain is trekbeyond.org. So why is this happening?

Last edited by actionplant; 30th November 2006 at 17:58.
Reply With Quote
  #37  
Old 1st December 2006, 16:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You must send an email first to that user. Maildir is created when the first email arrives for that user.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #38  
Old 1st December 2006, 22:43
actionplant actionplant is offline
Junior Member
 
Join Date: Nov 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks falko, that worked.

And helped me discover a different problem. The email came through just fine, but when I responded, instead of showing up in the destination mailbox as being from the address I set up, which was damon@theamazingdump.com (heh, don't ask) it came from web1_damon_dump@example.com

Which is weird, considering the server is set up as odin.trekbeyond.org.

What the heck?

Edit- Oh yay! After a complete re-install (I was having issues and started over this morning from scratch so I could walk through carefully again) I got everything up and running. The server sent one single email, and promptly crashed. Oh well, I guess that's further than I got yesterday.

Last edited by actionplant; 1st December 2006 at 23:04.
Reply With Quote
  #39  
Old 2nd December 2006, 01:29
LumpyOne LumpyOne is offline
Junior Member
 
Join Date: Oct 2006
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Thumbs up

Just wanted to say thanks for making this so easy to install! Happy happy joy joy.

FYI, to make it easy for clients, I simply set up a page at www.example.com/mail for my clients, so that they could click to get to the secure URL for squirrelmail. It's an extra click, but easy to set up and my clients like it just fine.
Reply With Quote
  #40  
Old 2nd December 2006, 15:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by actionplant
And helped me discover a different problem. The email came through just fine, but when I responded, instead of showing up in the destination mailbox as being from the address I set up, which was damon@theamazingdump.com (heh, don't ask) it came from web1_damon_dump@example.com
You must set the email address in your email client (Outlook, Thunderbird, webmail, etc.).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual users, domains Postfix.. & Squirrelmail laser144 HOWTO-Related Questions 6 4th May 2006 23:23
Help....package missing sbovisjb1 Installation/Configuration 3 31st March 2006 11:14
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 13th March 2006 23:58
Logging in to isp config Jrdgames General 43 6th March 2006 19:04
suse 9.3 install: E: Couldn't find package ncftp aallen Installation/Configuration 4 26th January 2006 20:02


All times are GMT +2. The time now is 04:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.