Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th October 2010, 21:30
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default PHP and directory write permissions

Ok.. I've been chasing my tail here for a while now and I'm tired of running in circles ..LOL!

I've got suexec working fine for perl scripts but PHP scripts for some reason won't write to a file or a directory that is chmodded 755. If I chmod to 777 it works fine--but I don't want to do that!

What am I missing?

Centos 5.5 "perfect server", Apache 2, PHP 5.16 ISPC-2

Thanks in advance for a solution!
Reply With Quote
Sponsored Links
  #2  
Old 26th October 2010, 23:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Please see here:

http://www.howtoforge.com/install-su...2.20-and-above
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th October 2010, 23:46
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Thanks for the lead Till,

Does this play well with suexec for perl scripts? I am looking for a solution that will allow both perl and php to run correctly under their owners permissions and not that of the webserver.

Going to do my reading now
Reply With Quote
  #4  
Old 27th October 2010, 03:01
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
 
Default

Thanks Till.

All's well in my world now

As always I appreciate the help!

I did also have to track down a few issues but with the help of prior posts here in your forum I found the info to make everything happy!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error when install ISPConfig 2 with components built from source X-admin Installation/Configuration 5 30th April 2010 14:22
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
libWand.so.10 error Taxick Installation/Configuration 8 3rd May 2009 02:27
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 11:46
add web site serr57 Installation/Configuration 18 13th April 2008 12:40


All times are GMT +2. The time now is 07:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.