Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th October 2010, 06:29
florix.net florix.net is offline
Member
 
Join Date: Oct 2010
Posts: 42
Thanks: 4
Thanked 1 Time in 1 Post
Default Squiralmail - webmail alias not working

Hi,

I installed ISPConfig 3.0.3 on ubuntu 10.04.

Everything is working fine except the http://www.domain.com/webmail link.

It shows a 404 not found record.

In /var/www i can see a symlink like this

lrwxrwxrwx 1 root root 24 Oct 23 03:56 webmail -> /usr/share/squirrelmail/

What could be the error?

Please suggest.

Richard
Reply With Quote
Sponsored Links
  #2  
Old 24th October 2010, 12:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

This link will only work when the IP address that is used to access the server is not assigned to a website in ispconfig. There are several solutions:

1) dont assign the ip to a website and use * instead.
2) create a dedicated website for webmail e.g. webmail.yourdomain.com and install a webmail client of your choice into that website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th October 2010, 19:24
florix.net florix.net is offline
Member
 
Join Date: Oct 2010
Posts: 42
Thanks: 4
Thanked 1 Time in 1 Post
Default

Hi Till,

Removing the IP address association from the website did the trick ...

Now I am facing a strange problem ...

My newly added websites are showing default web server page.

Any idea? My webserver stopped working suddenly and I restarted the apache using /etc/init.d/apache start

Please help ...
Reply With Quote
  #4  
Old 25th October 2010, 11:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Then your server requires it that you assign the IP addresses to the sites. In that case, you have to use the second method for webmail that I mentioned in my post.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
florix.net (25th October 2010)
  #5  
Old 25th October 2010, 16:45
florix.net florix.net is offline
Member
 
Join Date: Oct 2010
Posts: 42
Thanks: 4
Thanked 1 Time in 1 Post
Default Florix.net

Hi,

Thank you for your response..

I did the complete reinstall of ubuntu and ISPConfig 3 setup.

I added one domain, not assigned any IP address.

The domain name is customsurveyor.com

In web domain setup, my values are per attachment.

My DNS zone has entry for www record

What value should I have for Auto sub domain .. I tried the *, www combinations but it does not work
Attached Images
 
Reply With Quote
  #6  
Old 25th October 2010, 16:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Select the IP address in the IP address field and select www for auto subdomain. By the way, why did you reinstall?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 25th October 2010, 17:02
florix.net florix.net is offline
Member
 
Join Date: Oct 2010
Posts: 42
Thanks: 4
Thanked 1 Time in 1 Post
Default

Hi,

I am using linode VPS, so reinstall was just few minutes.

If I assign the IP, then the webmail is not working for sure.

Now ...

http://www.customsurveyor.com/ is going to default page
http://customsurveyor.com/ is going to ISPConfig page

http://customsurveyor.com/webmail not working
http://www.customsurveyor.com/webmail is working ..

If I assign www subdomain in domain setup, then website works with www, but webmail does not working...

umm .. this is getting confusing

Please contact me at richard a-t florix.net


Thanks
Richard
Reply With Quote
  #8  
Old 11th December 2010, 08:52
ByteMe Networking ByteMe Networking is offline
Junior Member
 
Join Date: Dec 2010
Location: Virginia Beach VA.
Posts: 24
Thanks: 7
Thanked 7 Times in 3 Posts
Thumbs up Maby this will help.

I remember in cAnal when you added a new domain to your account, if setup properly it would automatically add a webmail.your.tld subdomain and would also allow your.tld/webmail to access webmail options.

I too have been looking for the best way to do this and I am by no means an expert (like Till or Falko , One Day!) but I have found a solution that worked for me.

The following will allow all domains, subdomains, and alias domains to access webmail using (as an example) http://your.tld/webmail

NOTE: I picked this up from some other post after hours of searching and did not bookmark the page but kept notes.

Step one: Make your symlink for webmail (taken from Step 17 of that link)
Code:
ln -s /usr/share/squirrelmail/ /var/www/webmail
Step two: Add global link for all sites
I use nano but you can use what you want:
Code:
nano /etc/apache2/conf.d/apache2-doc
Step three: Go to end of file and add
Code:
Alias /webmail /var/www/webmail/

<Directory "/var/www/webmail/">
Options Indexes FollowSymlinks
AllowOverride None
Order allow,deny
Allow from all
AddDefaultCharset off
</Directory>
This will work with a successful install of ISPConfig running on Debian.
Also if you have installed using the recommended install docs on the ISPConfig website you could choose to install SquirrelMail differently by changing the folder in Step one.
By doing so you can ultimately setup your /webmail to provide more than one webmail client.
EX: here

If you checked out the example you can see I offer more than just SquirrelMail but Horde and Roundcube.

Here is the concept:
If you follow Falko's "Perfect Setup guide" you will get to Step one (depending on your install) from the above post.

Insted of:
Code:
ln -s /usr/share/squirrelmail/ /var/www/webmail
Do
Code:
ln -s /usr/share/squirrelmail/ /var/www/webmail/squirrelmail
In doing so you link squirrelmail to /webmail/squirrelmail allowing yourself to add more than one webmail client to your /webmail link.
With some simple code you can create an index page that can point to your different webmail clients.

EX. (If your symlinks are setup correctly)
Code:
<!DOCTYPE html>
<html lang="en">
  <head>
    <title>Webmail</title>
  </head>
  <body>
<ul>
          <li><a href="/webmail/horde">Horde</a></li>
          <li><a href="/webmail/roundcube">Roundcube</a></li>
          <li><a href="/webmail/squirrelmail">SquirrelMail</a></li>
          </ul>
  </body>
</html>
If your looking for help on how to do that please use the following link.
http://lmgtfy.com/?q=how+to+write+html+code

With that I hope this helped. If not please let me know if I can update this post.

P.S.
Falko, Till.... I just what to say thanks for the time, effort, and charity.

Thanks,
Casey
Reply With Quote
The Following 3 Users Say Thank You to ByteMe Networking For This Useful Post:
brainz (2nd January 2011), falko (12th December 2010), onastvar (14th December 2010)
  #9  
Old 10th March 2011, 21:36
rocker2344 rocker2344 is offline
Junior Member
 
Join Date: Oct 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://aditlfai.com/webmail/index.php < it tries and downlaods the file i want it to work like when i go to http://ip/webmail
Reply With Quote
  #10  
Old 11th March 2011, 15:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Did you enable PHP for the aditlfai.com web site?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
webmail link squiralmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
Webmail not working - ISPConfig 3 FadeOUT Installation/Configuration 9 13th October 2009 12:39
post fix error after a year aberrio Server Operation 5 5th May 2009 21:33
Server name change stops webmail working shajazzi Installation/Configuration 3 16th May 2006 16:00
Webmail alias aethiolas HOWTO-Related Questions 2 21st November 2005 18:21


All times are GMT +2. The time now is 15:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.