#1  
Old 20th October 2010, 14:22
prithwis prithwis is offline
Junior Member
 
Join Date: Oct 2010
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default new website cannot be located

this is the first time i am configuring a shared web server like this so i will apologize in advance for my lack of understanding on some issues.

i am trying to create a shared web server that my students will use to create websites.

our institute sysadm has created a DNS entry in our school DNS that allows me to reach my host machine ( mislab.vgsom ) from anywhere inside our college network ( domain : iitkgp.ac.in)

this means that if i type http://mislab.vgsom.iitkgp.ac.in from inside our campus the machine is found.

the apache webserver root is located at var/www/index.html

i have "successfully" installed ISPConfig v2 !
i can create resellers, clients, websites ... and i can see that my website is there

for client c1 ( of reseller r1 ) i have created a website r1c1w where host is r1c1w and domain is mislab.vgsom.iitkgp.ac.in

i can see this website is lying in a folder called web12 in var/www and there is a "shortcut" folder called r1c1w.mislab.vgsom.iitkgp.ac.in and there is a proper index file there.

but i cannot reach this website !

when i type http://r1c1w.mislab.vgsom.iitkgp.ac.in ( from a different machine) i get "server not found"

when i type http://mislab.vgsom.iitkgp.ac.in ( from a different machine ) i am directed to the sharedip folder and i get a message " This IP address is shared. For access to the web site which you look for, enter its address instead of its IP."

there is obviously a problem with my DNS configuration but cannot understand what is the problem

when i created the website r1c1w in ISPConfig i checked the create DNS option .. so i was expecting the DNS to be updated.

i have deleted and recreated the reseller (r1),client (r1c1) and the website (r1c1w ) quite a few times ... but no improvement.

evidently i am making a big mistake somewhere.

do i have to request our institute sysadm to make some changes in the institute DNS ? if so, that is a problem .. i will be creating webserver for my students every now and then and i cannot go back to the institute sysadm each time.

please help me understand this problem and find a solution
Reply With Quote
Sponsored Links
  #2  
Old 21st October 2010, 15:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by prithwis View Post
when i type http://r1c1w.mislab.vgsom.iitkgp.ac.in ( from a different machine) i get "server not found"

when i type http://mislab.vgsom.iitkgp.ac.in ( from a different machine ) i am directed to the sharedip folder and i get a message " This IP address is shared. For access to the web site which you look for, enter its address instead of its IP."

there is obviously a problem with my DNS configuration but cannot understand what is the problem
You must ask your institute sysadmin to create a DNS record for r1c1w.mislab.vgsom.iitkgp.ac.in.

Quote:
Originally Posted by prithwis View Post
when i created the website r1c1w in ISPConfig i checked the create DNS option .. so i was expecting the DNS to be updated.
This works only if the ISPConfig server is the authoritative DNS server for iitkgp.ac.in (whici it isn't because your sysadmin created the records on another DNS server).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
prithwis (22nd October 2010)
  #3  
Old 22nd October 2010, 14:03
prithwis prithwis is offline
Junior Member
 
Join Date: Oct 2010
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default sysadm throws ball back in my court ....

it seems that the institute sysadm wants me to manage the DNS entries on the ISPConfig server itself and so i am forced to "try" configuring the DNS server on my machine based on the instructions given in another post in this forum

unfortunately after making all the changes, the /etc/init.d/bind9 start command fails !

i have created / edited four files :

a] /etc/bind/named.conf
b] /etc/bind/named.conf.options
c] /etc/bind/zones/mislab.vgsom.iitkgp.ac.in.db
d] /etc/bind/zones/rev.33.43.10.in-addr.arpa

would be grateful if someone can look through these files and tell me where i have gone wrong.

i am now listing these four files below : THANKS for your help

file : /etc/bind/named.conf ( belows )
===============================
options {
pid-file "/var/run/bind/run/named.pid";
directory "/etc/bind";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

include "/etc/bind/named.conf.options";


//
// a caching only nameserver config
//
zone "." {
type hint;
file "/etc/bind/db.root";
};

zone "mislab.vgsom.iitkgp.ac.in" {
type master;
file "/etc/bind/zones/mislab.vgsom.iitkgp.ac.in.db";
};

zone "33.43.10.in-addr.arpa" {
type master;
file "/etc/bind/zones/rev.33.43.10.in-addr.arpa";
};

zone "localhost" {
type master;
file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
type master;
file "etc/bind/db.127";
};

zone "0.in-addr.arpa" {
type master;
file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
type master;
file "/etc/bind/db.255";
};

include "/etc/bind/named.conf.local";


//zone "0.0.127.in-addr.arpa" {
// type master;
// file "db.local";
//};

//zone "iitkgp.ac.in" {
// type master;
// file "pri.iitkgp.ac.in";
//};
//zone "mislab.vgsom.iitkgp.ac.in" {
// type master;
// file "pri.mislab.vgsom.iitkgp.ac.in";
//};
//zone "vgsom.iitkgp.ac.in" {
// type master;
// file "pri.vgsom.iitkgp.ac.in";
//};



//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////

===============================

file /etc/bind/named.conf.options ( shown below )
========================
options {
directory "/var/cache/bind";

// If there is a firewall between you and nameservers you want
// to talk to, you may need to fix the firewall to allow multiple
// ports to talk. See http://www.kb.cert.org/vuls/id/800113

// If your ISP provided one or more IP addresses for stable
// nameservers, you probably want to use them as forwarders.
// Uncomment the following block, and insert the addresses replacing
// the all-0's placeholder.

// forwarders {
// 0.0.0.0;
// };
forwarders {
144.16.192.55;
144.16.192.1;
};

auth-nxdomain no; # conform to RFC1035
listen-on-v6 { any; };
};
=====================

file : /etc/bind/zones/mislab.vgsom.iitkgp.ac.in.db ( below )

================================================
$ORIGIN .
$TTL 86400
mislab.vgsom.iitkgp.ac.in. IN SOA mislab.vgsom.iitkgp.ac.in. admin.mislab.vgsom.iitkgp.ac.in. (
2010102201 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS mislab.vgsom.iitkgp.ac.in. ; Inet Address of name server 1
// NS mislab.vgsom.iitkgp.ac.in. ; Inet Address of name server 2
;
$ORIGIN mislab.vgsom.iitkgp.ac.in.

IN A 10.43.33.60
test001 IN A 10.43.33.60

=================================================

file /etc/bind/zones/rev.33.43.10.in-addr.arpa ( below)

=================================================
$ORIGIN .
$TTL 86400
33.43.10.IN-ADDR.ARPA IN SOA mislab.vgsom.iitkgp.ac.in. admin.mislab.vgsom.iitkgp.ac.in. (
2010102201 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS mislab.vgsom.iitkgp.ac.in. ; Inet Address of name server 1

;
$ORIGIN 33.43.10.IN-ADDR.ARPA


=================================================
Reply With Quote
  #4  
Old 23rd October 2010, 11:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
 
Default

Quote:
Originally Posted by prithwis View Post
it seems that the institute sysadm wants me to manage the DNS entries on the ISPConfig server itself
That doesn't make sense if the ISPConfig server isn't authoritative for iitkgp.ac.in.

Quote:
Originally Posted by prithwis View Post
unfortunately after making all the changes, the /etc/init.d/bind9 start command fails !
Do you get any errors when you try to start BIND? Any errors in the logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
dns error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help to debug a slow website vtapas Server Operation 15 10th August 2011 10:50
Email problem and website problem raicabogdan Installation/Configuration 5 28th June 2010 16:32
No website folder created. holykim General 2 8th June 2010 15:48
cannot receive emails after made website online llamy General 20 27th December 2007 01:14
set up 301 redirect from old website to new website showe1966 Server Operation 1 22nd September 2007 12:30


All times are GMT +2. The time now is 00:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.