Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th June 2006, 19:56
Pharao Pharao is offline
Junior Member
 
Join Date: Jun 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Cant receive Emails, but they are in the Maildir!!

Hi all

I dont know what do now. I have setup my postfix from new and IPSConfig also. I work with Maildirectorys and Postfix. The Problem is, sending is no problem with webmail and outlook and the Emails arrived corretctly in the Maildir from the appropriate User and i can read it from Webmin.
BUT:
If i try to receive the mails, neither outlook nor webmail will recieve any mails. There is no spamfilter, no antivirus, no firewall between them. All systems are on one Server with Hostname predator.h-wd.ch (Apache, ISPConfig, Webmail, PHP, mySQL, Bind etc...).
Enclosed is the main.cf and the logfile

main.cf: www.h-wd.ch/main.cf.txt
Maillogfile: www.h-wd.ch/log.txt


please help, i have no idea what this could be or what to do....

Franco H. from Switzerland


Reply With Quote
Sponsored Links
  #2  
Old 16th June 2006, 20:32
brainz brainz is offline
Senior Member
 
Join Date: Feb 2006
Location: Sydney, Australia
Posts: 165
Thanks: 9
Thanked 3 Times in 1 Post
Default

Hi Pharao,

Just a question do you have dovcot installed ???

I had this probelm that you are having and i installed postfix and dovecot and it all worked....

regards
brainz
__________________
www.baktim.com
Reply With Quote
  #3  
Old 16th June 2006, 22:22
Jcorrea920 Jcorrea920 is offline
Member
 
Join Date: Feb 2006
Posts: 82
Thanks: 4
Thanked 1 Time in 1 Post
 
Lightbulb Hello Pharao,

Yes I had the same problem and Dovecot seems to solve everything. Whether you have it installed or not we need to know what is running on your system and what is not. What is the result of
Code:
netstat -tap
If you are currently using ipop3 and imap for ports 110 and 143 you need to shut off xinetd and start dovecot.

To stop ipop3
Code:
chkconfig ipop3 off
To stop xinetd
Code:
/etc/init.d/xinetd stop
To check if you have dovecot installed
Code:
dovecot --version
If it is not installed, install it by
Code:
apt-get install dovecot
Disable ipop3 and imap at startup by editing /etc/xinet.d/ipop3 and /etc/xinet.d/imap change disable = no to:
Code:
disable = yes
Finally start dovecot
Code:
/etc/init.d/dovecot start
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot receive emails skeeta Installation/Configuration 18 22nd April 2006 16:02
Maildir: no such file or directory jeanjacquesjeanjacques Installation/Configuration 6 20th January 2006 16:31
Can't receive emails from other domains andre4400 General 2 13th December 2005 06:35
Unable to receive emails?!!! nandhu HOWTO-Related Questions 7 23rd October 2005 23:49
Cannot receive emails skeeta Installation/Configuration 10 3rd September 2005 09:14


All times are GMT +2. The time now is 22:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.