Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th October 2010, 18:40
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default Spam Assassin fails to start

Howdy,

Centos 5.5 perfect server, ISPConfig2 Latest version.

I've had this server up and running for about a week now and got to playing to figure out why SpamAssassin doesn't seem to be working. I tried /etc/init.d/spamassassin restart and start and received this message:

HTML Code:
 [root@newbox init.d]# spamassassin restart

Oct 13 11:29:21.090 [31614] warn: archive-iterator: no access to restart: No such file or directory at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/ArchiveIterator.pm line 771.

Oct 13 11:29:21.090 [31614] warn: archive-iterator: unable to open restart: No such file or directory
Clues would be greatly appreciated!
Reply With Quote
Sponsored Links
  #2  
Old 14th October 2010, 16:01
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default

bump bump?
Reply With Quote
  #3  
Old 14th October 2010, 18:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Can you try to uninstall and reinstall SpamAssassin?

Which tutorial (URL) did you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 14th October 2010, 19:55
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Hi Falko,

Not sure which URL it was but it was the centos 5 32 bit perfect server installation and the newest ISPConfig2 (last week)

I will try uninstalling/reinstalling later but right now I'm scratching my head to figure out why perl scripts are not running in either cgi-bin or root web directories. I get 403 errors in the main web directory and 500 errors in the cgi-bin but yet it runs fine in the ssh shell ---and this is only your basic "hello world" test script.
Reply With Quote
  #5  
Old 14th October 2010, 23:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Are you sure it was the tutorial for ISPConfig 2 and not for ISPConfig 3?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 14th October 2010, 23:33
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Yep-- ISPConfig2 I have this shortcut saved from when I did the install.

http://www.howtoforge.org/perfect-se...64-ispconfig-2

It's been a long week-and-a-half for me here..haven't been this deep into it for a while.
Reply With Quote
  #7  
Old 15th October 2010, 17:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

But we don't install SpamAssassin in that tutorial... It comes with ISPConfig 2, but has different paths from what you posted here...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 15th October 2010, 19:59
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
Default

I suppose that's why it's not there...because it wasn't installed.

The option exists in ISPConfig to turn it on per account so I thought it was installed. I thought that after following the server setup and installing ISPConfig2, any options shown in ISPConfig would be available like spamassassin and FrontPage. Guess I need to chase down some more info on how to get both of them properly installed although from what I've found so far it doesn't look good for FrontPage with Apache2.

Last edited by mini14; 15th October 2010 at 20:24.
Reply With Quote
  #9  
Old 16th October 2010, 15:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

ISPConfig 2 comes with SpamAssassin, but it's installed in different locations, so I guess that there's a SpamAssassin installed from the CentOS repositories on your system which is generating the error messages.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 18th October 2010, 18:27
mini14 mini14 is offline
Member
 
Join Date: Oct 2010
Posts: 66
Thanks: 2
Thanked 3 Times in 3 Posts
 
Default

Good Morning, (or afternoon over there in Deutchland!)

I took a day off yesterday and let my brain heal up a bit

Ok...Spamassassin service is up but no dice on it actually doing anything,

Could you please point me to configuration files that I need to look at?

Thank you!

BTW.. Have a Spaten for me! We get it here but I'm sure it's much better closer to the source! The last time I was over there was in 1973.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Monit & Munin SamTzu HOWTO-Related Questions 2 23rd September 2014 23:20
monitrc configuration for Debian ISPConfig 3 server Hans Tips/Tricks/Mods 2 28th March 2011 00:22
Spamfilter policy - question about spam actions prisfeo Installation/Configuration 4 2nd February 2010 17:17
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 18:37
"Too many open files in system" problems Berry Installation/Configuration 3 10th November 2007 22:58


All times are GMT +2. The time now is 07:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.