Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th October 2010, 03:58
csabo csabo is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Migrated ispconfig 3 to a new server

Hello,
So I moved an install by doing the following:

1.) tar.gz'ed /var/www & /var/mail with preserve permissions on & extracted on new server

2.) moved /etc/passwd , /etc/group , /etc/shadow

3.) did a mysql dump of all databases and imported on new server

rebooted the new host. and mysql starts, but i get the following trying to get the ispconfig page up:

You don't have permission to access / on this server.

I checked and the permissions on /var/www seem to be correct, there was some stuff in about hostname regarding postfix which ive included below


Oct 26 21:53:11 <HOST> postfix/master[1960]: fatal: open lock file /var/lib/postfix/master.lock: cannot create file exclusively: Permission denied
Oct 26 21:53:45 <HOST> postfix/master[2072]: fatal: fifo_listen: remove public/pickup: Permission denied

thanks
Chris
Reply With Quote
Sponsored Links
  #2  
Old 27th October 2010, 12:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Did you move /var/mail or /var/vmail? The ispconfig directories are in /var/vmail. If you moved/var/mail, then the folders might have wrong permissions.

Regarding the passwd, shadow and group files. Did you move the whole files or just the web* users and client* groups? If you moved the whole files, then it might be that the system permissions on the new server got messaed up as the userid's of the system daemons may not match. If you have backups of the original files, then restore them and copy only the web* user lines and client* group lines plus the lines of the groups that contain web* users.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th October 2010, 17:26
csabo csabo is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Till,

Thank you for your prompt response. Yes i moved /var/mail not "vmail"

so restore the passwd,group,shadow files, and move the web and client lines over, and the vmail folder.. and that should take care of it?

thanks!
Chris
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Ping over VPN RoMiONeT Server Operation 2 4th July 2010 00:19
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
ISPConfig installation into multiple OpenVZ containers letezo Installation/Configuration 11 3rd March 2009 22:47
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04


All times are GMT +2. The time now is 01:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.