#1  
Old 16th June 2006, 18:21
Impulse0022 Impulse0022 is offline
Junior Member
 
Join Date: Jun 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default FC5 Samba Troubles

I found an article at http://www.enterprisenetworkingplane...le.php/3487081 that explained how to join Samba 3 to an Active Directory domain.

I followed everything that the tutorial said to do and everything worked fine. However, I can't browse samba shares. I'm presented with a username and password logon box on windows machines, but no username and password combination works. The only change i had to make that is different from the tutorial is found in /etc/nsswitch.conf

The tutorial said to do the following:
passwd: compat winbind
group: compat winbind
shadow: compat

The only problem with this is that when I make this change my root account goes crazy and the machine wouldn't boot correctly. To solve this problem, I changed the /etc/nsswitch.conf file to the following.

passwd: compat winbind files
group: compat winbind files
shadow: compat files

Also, going off of the tutorial "wbinfo -u", "wbinfo -g", "getend passwd", and "net ads info" all show the proper information.

This is pretty open ended question, but I'm at a loss on how to resolve this issue. Any help would be appreciated.

Thanks,
-Matt
Reply With Quote
Sponsored Links
  #2  
Old 16th June 2006, 21:15
davekeogh davekeogh is offline
Junior Member
 
Join Date: Jun 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Samba 3

I've been using Samba 3 for ages now on SLES9. For /etc/nsswitch.conf i normally place files first and then winbind. I tend to remove compat as it can confuse suse.
As for the root account going mad, thats a little strange. Unless the id's are being resolved correctly and there is an active directory user called root. That could confuse the os. Although the uid's would be different. Are you planning to use Samba for login purposes? Or just file shares.
Reply With Quote
  #3  
Old 16th June 2006, 21:40
Impulse0022 Impulse0022 is offline
Junior Member
 
Join Date: Jun 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I think I found my problem. SeLinux was blocking my shares. To solve the problem, I turned SELinux off for my samba shares.

Found this in "man samba_selinux"

You can disable SELinux protection for the samba daemon by executing:

setsebool -P smbd_disable_trans 1
service smb restart

Everything appears to be working fine now.

-Matt
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
File Sharing Problem With Samba & (MS)ADS papaqube Server Operation 8 10th November 2008 12:25
Configure Linux client to join a Samba domain controller denny_lin Installation/Configuration 1 9th June 2006 13:31
Samba as a PDC HOWTO help jesterking HOWTO-Related Questions 2 23rd February 2006 20:45
Date stamp problem with samba file sharing cioscott HOWTO-Related Questions 0 11th January 2006 20:29
Support samba misterm Feature Requests 1 18th September 2005 02:16


All times are GMT +2. The time now is 12:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.