Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st October 2010, 15:22
todgerme todgerme is offline
Member
 
Join Date: Dec 2005
Location: Belfast, Northern Ireland
Posts: 56
Thanks: 0
Thanked 2 Times in 2 Posts
Default Disable "Welcome to your new email account"

Hi All,

Can someone point me where in the code I can comment out temporarily the welcome email that new mailbox users receive in ISPC3?

Thanks,

Keith
Reply With Quote
Sponsored Links
  #2  
Old 1st October 2010, 15:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

The code is in the file /usr/local/ispconfig/interface/web/mail/mail_user_edit.php, comment out the line (approx line number 236):

mail($mailTarget, $mailSubject, $mailBody, $mailHeaders);
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st October 2010, 15:37
todgerme todgerme is offline
Member
 
Join Date: Dec 2005
Location: Belfast, Northern Ireland
Posts: 56
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Thanks - your help is much appreciated!
Reply With Quote
  #4  
Old 14th December 2011, 01:21
matiasCU matiasCU is offline
Member
 
Join Date: Apr 2007
Posts: 57
Thanks: 5
Thanked 2 Times in 2 Posts
Default Hi all

I can disable the sending of the message "Welcome to your new email account" on ISPConfig Version: 3.0.4.1.
I looked the function at the following file but I can not find /usr/local/ispconfig/interface/web/mail/mail_user_edit.php

Tks
Reply With Quote
  #5  
Old 14th December 2011, 09:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

The emailis now send by the mail server plugin and not from the interface.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 14th December 2011, 15:01
matiasCU matiasCU is offline
Member
 
Join Date: Apr 2007
Posts: 57
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till View Post
The emailis now send by the mail server plugin and not from the interface.
Thank Till, but is possible then disable the welcome email?
Reply With Quote
  #7  
Old 14th December 2011, 15:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

You will have to edit the sourcecode of the mail plugin and comment out the mail() function which sends the welcome message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 14th December 2011, 23:13
matiasCU matiasCU is offline
Member
 
Join Date: Apr 2007
Posts: 57
Thanks: 5
Thanked 2 Times in 2 Posts
Thumbs up Problem solved!

Thanks Till,

I comment out the function on line 191
mail($mailTarget, $mailSubject, $welcome_mail_message, $mailHeaders);
Reply With Quote
  #9  
Old 5th September 2013, 17:09
gendalone gendalone is offline
Junior Member
 
Join Date: Jun 2011
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

under ispconfig 3 (if plugin is enabled....)
file should be: /usr/local/ispconfig/server/plugins-available/mail_plugin.inc.php
line to comment out should be: 196

Last edited by gendalone; 5th September 2013 at 19:16.
Reply With Quote
The Following User Says Thank You to gendalone For This Useful Post:
stef157 (5th September 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable Email functionality kalib General 3 24th August 2010 16:13
Email delivery problem - Ubuntu Karmic Koala (Ubuntu 9.10) [ISPConfig 2] qiubosu Installation/Configuration 1 18th January 2010 10:21
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 04:39
Email "catch-all" disabled "per account" ? mumbly Installation/Configuration 4 5th January 2008 09:40
email forwarding locally consumes all resources rdells General 20 1st May 2006 20:43


All times are GMT +2. The time now is 22:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.