#1  
Old 9th June 2006, 05:35
whitty whitty is offline
Member
 
Join Date: May 2006
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix issues

For a while during my tweaking/learning phase of installation, I couldn't get email to work at all, then I hammered out the issue and got it working 100% but another one popped up and my solution broke postfix again, and now I can't get postfix to recieve incoming mail anymore. Through some trial-and error analysis and log/config snooping, i've figured out that everything is perfect, but during the phase when i COULD send AND recieve email, the server hello line was the hostname of my server instead of its reverse dns entry (note, not the hostname which was being used for mail, a different one that always resolved). This should help: http://pingability.com/zoneinfo.jsp?...ittyhost.us.to Very helpful for domain troubleshooting. I've tried everything I can think of, making sure absolutely every dns entry is super clean and the like, making sure the users are set up, and when it still wouldnt work I looked at the postfix log in /var/log/maillog. What I saw was odd. Hopefully you can help me figure it out (note my current email account on the server is admin.@.whittyhost.us.to, other entries in the log are gmail resending faild emails from a while ago, and galexyalex.@.gmail.com (minus the dots) is the email it's sending from.

Code:
Jun  8 23:19:18 www postfix/smtpd[4810]: connect from wr-out-0506.google.com[64.233.184.238]
Jun  8 23:19:19 www postfix/smtpd[4810]: 2E29C2B7649: client=wr-out-0506.google.com[ 64.233.184.238]
Jun  8 23:19:19 www postfix/cleanup[4817]: 2E29C2B7649: message-id=<d72259a30606082019y34a2cc86y590eb1da194daa32@mail.gmail.com >
Jun  8 23:19:19 www postfix/qmgr[4801]: 2E29C2B7649: from=<galexyalex@gmail.com>, size=1593, nrcpt=1 (queue active)
Jun  8 23:19:19 www postfix/smtp[4818]: connect to cpe-69-207-240-89.maine.res.rr.com[69.207.240.89]: Connection refused (port 25)
Jun  8 23:19:19 www postfix/smtp[4818]: 2E29C2B7649: to=< web1_admin@cpe-69-207-240-89.maine.res.rr.com>, orig_to=<admin@whittyhost.us.to>, relay=none, delay=0, status=deferred (connect to cpe-69-207-240-89.maine.res.rr.com [69.207.240.89]: Connection refused)
Thanks for the help, let me know if you need anything else in the way of configs/logs!
Reply With Quote
Sponsored Links
  #2  
Old 9th June 2006, 10:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Please post your postfix main.cf. If it is too long, you can attach it as .txt file.

What is in your /etc/hostname file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th June 2006, 12:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Please make sure your ISP doesn't block port 25.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 9th June 2006, 18:38
whitty whitty is offline
Member
 
Join Date: May 2006
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

maybe that's the problem - nothing in hostname i'll play with that, hadn't noticed. Thanks! In case not, here's main.cf

and no, port 25 is fine since mail worked in the past. My ISP is great besides the slowish speed, they don't block/shape/filter anything whatsoever (besides maybe a 5 IP cap that I haven't hit yet)and I doubt you could do anything to get banned short of maybe trippling your bandwidth with an uncapped modem or something.

EDIT: Nope, adding the right host did take care of the using rdns in the hello line and such, but it didn't change the behavior, i still get that same log pattern above.
Attached Files
File Type: gz main.cf.txt.tar.gz (9.1 KB, 211 views)

Last edited by whitty; 9th June 2006 at 19:07.
Reply With Quote
  #5  
Old 9th June 2006, 23:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

You should add myorigin, myhostname and mydomain entries in main.cf and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 10th June 2006, 04:08
whitty whitty is offline
Member
 
Join Date: May 2006
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

YAY thanks a bunch, never would have figured it out. I figured ispconfig did stuff like that automatically. Here's another one: the default email address for a user is always user@www.domain.tld instead of user@domain.tld, despite an entry in codomains with no hostname, just domain.tld, allowing mail to be sent to user@domain.tld just fine. This is also new since the system worked last. Is there any way to change that without the user adding their own identity in the mail program?
Reply With Quote
  #7  
Old 10th June 2006, 21:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

If you have domain.tld on the Co-domains tab, you automatically have the email addresses user@domain.tld and user@www.domain.tld.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 10th June 2006, 22:10
whitty whitty is offline
Member
 
Join Date: May 2006
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

right, but when i log into the webmail app with webX_user, the default address it uses is user@www.domain.tld. Is there any way to change that to user@domain.tld
Reply With Quote
  #9  
Old 11th June 2006, 14:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

You can change that in the webmail settings. Every user has to configure his email address in the webmail settings, just as you do in any normal email client.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 11th June 2006, 17:54
whitty whitty is offline
Member
 
Join Date: May 2006
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

hmm, not quite sure we're on the same page: when i set up an email user for a site "domain.tld", i have no option but to set it up with what it tells me is user@domain.tld. I then log into webmail with webx_user or user@domain.tld (Both work) and the default email address that email is sent from for that user is user@www.domain.tld. It used to be that when i logged in (when i first had email working this is) i would default to sending email from user@domain.tld and not have to set up an alias, which would be far more convienient. Is there any way to replicate that without needing to set up the alias manually?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
IMAP question - Moving servers and mail. Brenton Installation/Configuration 11 14th May 2010 14:38
Postfix smtpd_banner lehadi Server Operation 7 15th May 2006 17:14
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20
postfix problem flourishing General 1 7th December 2005 17:39


All times are GMT +2. The time now is 16:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.