#1  
Old 2nd April 2012, 21:56
davew davew is offline
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrade problem with courier

Just a heads up as this has caused me some problems and may help others.

I have an old ISPConfig 3 server that's been running for a few years now and uses Courier rather than Dovecot. I updated to the latest release ISPConfig 3 a short while ago and thought everything was OK until I got an email from one of my resellers yesterday.

Any new mailboxes added since the upgrade aren't functioning correctly. Any attempt to connect to them via pop3 produces the error...

-ERR Maildir invalid (no 'cur' directory)

It would appear that as part of the upgrade the mail configuration had been changed to dovecot from courier. Not sure if this is a new configuration option that has been added or the existing one that was changed as part of the upgrade.

Changing the server configuration to Courier and recreating the bad mailboxes has fixed the problem. The other servers I upgraded at the same time were running dovecot anyway so it wasn't an issue on those.
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2012, 21:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

Just a guess, you have courier and dovecot installed at the same time. You can test this with:

which dovecot

If it finds a dovecot binary, you should uninstall it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd April 2012, 22:31
davew davew is offline
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

It doesn't have Dovecot installed - I had problems a few upgrades ago with that when it went horribly wrong and I had to remove the dovecot and re ran the upgrade which worked OK. I've double checked it with "which dovecot" and there's nothing there.

Since then I've upgraded it maybe 3 or 4 times with the upgrade script without any problem. Just the latest upgrade that seems to have caused a problem either by changing or adding the configuration option.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with upgrade Captain Installation/Configuration 25 21st July 2010 15:56
Upgrade from 2.2.22 to 2.2.25 problem with mail andron26 Installation/Configuration 2 2nd September 2008 21:11
suPHP problem after PHP upgrade - ubuntu SupuS Installation/Configuration 6 21st May 2008 21:36
Postfix - Courier problem Ward Server Operation 1 13th December 2006 14:21
Upgrade question for "Virtual Users And Domains With Postfix, Courier And MySQL" emresumengen HOWTO-Related Questions 3 1st December 2006 15:33


All times are GMT +2. The time now is 04:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.