Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 2nd October 2010, 14:14
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hello Falko thank you for your reply

This is the content of the file

# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
DirectoryIndex index.php
AddHandler fcgid-script .php .php3 .php4 .php5

FCGIWrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter .php
Options +ExecCGI Indexes FollowSymLinks
AllowOverride all
Order allow,deny
Allow from all

# Authorize for setup
<Files setup.php>
# For Apache 1.3 and 2.0
<IfModule mod_auth.c>
AuthType Basic
AuthName "phpMyAdmin Setup"
AuthUserFile /etc/phpmyadmin/htpasswd.setup
</IfModule>
# For Apache 2.2
<IfModule mod_authn_file.c>
AuthType Basic
AuthName "phpMyAdmin Setup"
AuthUserFile /etc/phpmyadmin/htpasswd.setup
</IfModule>
Require valid-user
</Files>
<IfModule mod_php4.c>
AddType application/x-httpd-php .php
FCGIWrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>
<IfModule mod_php5.c>
AddType application/x-httpd-php .php
FCGIWrapper /var/www/php-fcgi-scripts/web5/.php-fcgi-starter .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>
</Directory>


<IfModule mod_rewrite.c>
<IfModule mod_ssl.c>
<Location /phpmyadmin>
RewriteEngine on
Reply With Quote
Sponsored Links
  #12  
Old 3rd October 2010, 12:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,736 Times in 2,571 Posts
Default

Can you make a backup of your current phpmyadmin.conf and use this instead?

Code:
# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
        Options Indexes FollowSymLinks
        DirectoryIndex index.php

        # Authorize for setup
        <Files setup.php>
            # For Apache 1.3 and 2.0
            <IfModule mod_auth.c>
                AuthType Basic
                AuthName "phpMyAdmin Setup"
                AuthUserFile /etc/phpmyadmin/htpasswd.setup
            </IfModule>
            # For Apache 2.2
            <IfModule mod_authn_file.c>
                AuthType Basic
                AuthName "phpMyAdmin Setup"
                AuthUserFile /etc/phpmyadmin/htpasswd.setup
            </IfModule>
            Require valid-user
        </Files>
        <IfModule mod_php4.c>
                AddType application/x-httpd-php .php

                php_flag magic_quotes_gpc Off
                php_flag track_vars On
                php_flag register_globals Off
                php_value include_path .
        </IfModule>
        <IfModule mod_php5.c>
                AddType application/x-httpd-php .php

                php_flag magic_quotes_gpc Off
                php_flag track_vars On
                php_flag register_globals Off
                php_value include_path .
        </IfModule>
AuthType Basic
AuthName "Members Only"
AuthUserFile /usr/share/phpmyadmin/.htpasswd
<limit GET PUT POST>
require valid-user
</limit>
</Directory>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
toux (5th October 2010)
  #13  
Old 3rd October 2010, 15:24
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hello Falko

Thank you for your reply.

Now I backup the old file and save the new, I try and nothing, but i change on interface config i write on phpmyadmin url phpmyadmin and try to acces by

https://server-ip:8080/phpmyadmin

And show this:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

EDIT:

I try enter by the control panel selecting the database and:

https://Server-ip:8080/sites/phpmyadmin

and show: Not Found

The requested URL /sites/phpmyadmin was not found on this server.

Thank you

Last edited by toux; 3rd October 2010 at 17:24. Reason: Complete information
Reply With Quote
  #14  
Old 5th October 2010, 03:59
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Please any idea to fix it?

I have some scripts without control panel and i must access trought phpmyadmin for manage the sites, and is very important but i have not idea what can be the problem

Thank you and greetens!
Reply With Quote
  #15  
Old 5th October 2010, 09:26
tef tef is offline
Junior Member
 
Join Date: Oct 2010
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Default

I think that the falco's configuration is for an url like

http://serverip/phpmyadmin
and not with ispconfig apache port.

my file was only like this:

#
# Web application to manage MySQL
#
Alias /phpmyadmin /usr/share/phpmyadmin
Alias /phpMyAdmin /usr/share/phpmyadmin
Alias /mysqladmin /usr/share/phpmyadmin


i will try ur suggestione
Reply With Quote
  #16  
Old 5th October 2010, 09:36
tef tef is offline
Junior Member
 
Join Date: Oct 2010
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Default

I've tryed ur suggestion.
which user and password phpmyadmin try to read?
Reply With Quote
The Following User Says Thank You to tef For This Useful Post:
toux (5th October 2010)
  #17  
Old 5th October 2010, 13:58
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Tef,

thank you for your reply.

I try write this alias but nothing...

Y try with ssl certificacte, ispconfig port, without, all! but only i can see, the server missconfiguration with :8080/phpmyadmin and show a password and user, but not with phpmyadmin index.php.

I write the root data login and after show the internal server error

Thank you!
Reply With Quote
  #18  
Old 5th October 2010, 14:42
tef tef is offline
Junior Member
 
Join Date: Oct 2010
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Default

same to me.
with the falco's script i can't get access
Reply With Quote
  #19  
Old 5th October 2010, 15:21
toux toux is offline
Member
 
Join Date: Sep 2010
Posts: 36
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Tef, I found a solution try this:

Go to :/var/www/ispconfig/sites/database_phpmyadmin.php

The last if replace for this code:

if($global_config['phpmyadmin_url'] != '') {
header('Location:'.$global_config['phpmyadmin_url']);
} else {
isset($_SERVER['HTTPS'])? $http = 'https' : $http = 'http';
header('location:/phpmyadmin');
}
exit;
?>

===========================================
After put the original phpconfig.conf on:

/etc/apache2/conf.d/phpmyadmin.conf

If you need the original file please say to me.

and after them restart apache:

/etc/init.d/apache2 restart


For me work, I hope can work for you, if not i see on other forums, that if you try reconfigure phpmyadmin can be solved, but first try this better

Greetens!
Reply With Quote
  #20  
Old 6th October 2010, 09:20
tef tef is offline
Junior Member
 
Join Date: Oct 2010
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Hi, thanks.

This solve https problems or general problem for phpmyadmin?


Yes i need the original.

Now i'm really lost in this modifications.
Why can't i return on default setting? phphmyadmin must run on same port of ispconfig? like myservername:8080/phpmyadmin?

After ispconfig istallation i can't let phpmyadmin works. i solved adding a non existent file to the folder, and then phpmyadmin starts to work on normal path like a normal site. (not ispconfig port)
This was incorrect right?

Last edited by tef; 6th October 2010 at 09:32.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please review RKHUNTER Log jmh_fl General 1 27th April 2010 16:44
Debian 5.0 'hangs' GHz Installation/Configuration 5 1st October 2009 12:57
domains not accessible gillesdevals Installation/Configuration 3 17th June 2009 09:12
Server Randomly Kills ALL Internet Connectivity for ALL Devices giganet Server Operation 5 11th June 2009 17:33
help on /etc/rc0.d/K20dnsctl -> ../init.d/dnsctl zimele General 13 23rd August 2006 16:06


All times are GMT +2. The time now is 09:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.