Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th September 2009, 16:59
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 82
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default no view permission in ispconfig 3, php 5.3

Hi,

Recently when i want to view and edit a ftp user i get:
Error
1.error_no_view_permission.

Is this a bug or.?

PS: I am logged in as admin so..
Reply With Quote
Sponsored Links
  #2  
Old 21st September 2009, 09:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,466
Thanks: 813
Thanked 5,253 Times in 4,119 Posts
Default

I'am sure that its not a bug as adding FTP users as admin works fine and there are no error reported for this. Maybe you modified anything in the sys user settings for the admin user or you added a admin user manually which does not has correct permission settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th September 2009, 00:09
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 82
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

Can you speficy what query turns to zero at the point that i get that error? Or some instruction on how to change the database to a not getting error way
Reply With Quote
  #4  
Old 29th September 2009, 08:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,466
Thanks: 813
Thanked 5,253 Times in 4,119 Posts
Default

This is a complex set of several queries, so it is not easily to explain that here especially as all queries are build dynamically. If you user would be an admin, there would be no restrictions, so the admin user must have been modified.

1) Did you use the admin user that was inserted by the installer?
2) Did you do any modifications on this admin user?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th September 2009, 10:13
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 82
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

1. Yes
2. Could be, not sure anymore. I use MySQL verry much myself, i have spitted the ispconfig db out so could be yeah.

But i get when i login with admin when i want to add a site/user/dns/mail/e.d everything the same error. That must be simply to fix. My admin sys_user is group of sys_group admin group.

""error_no_view_permission""

By the way: this error var is set in my nl.lang file so it should be shown in the dutch isnt it?
My admin lang is nl and the default ispconfig lang have i set to nl, could this be a bug?

Last edited by Stown; 29th September 2009 at 10:16.
Reply With Quote
  #6  
Old 29th September 2009, 10:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,466
Thanks: 813
Thanked 5,253 Times in 4,119 Posts
Default

Please ensure that the type of the user is "admin" and not "user".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 29th September 2009, 12:46
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 82
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

This is the data for admin, there are more data in this tables but thats not important. Yes the type is user. It should work like the structure below? I set my pass to ~~...

sys_user table
userid sys_userid sys_groupid sys_perm_user sys_perm_group sys_perm_other username passwort modules startmodule app_theme typ active language groups default_group client_id
1 1 0 riud riud admin ~~ tools,mail,client,dns,admin,sites,help,monitor monitor default admin 1 nl 1 1 0

sys_group table
groupid name description client_id
1 admin Administrators group 0
Reply With Quote
  #8  
Old 29th September 2009, 12:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,466
Thanks: 813
Thanked 5,253 Times in 4,119 Posts
Default

The type must be "admin" for an admin user and not "user".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 29th September 2009, 12:51
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 82
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

I am sorry, i sayd it wrong, the type is admin as you can see in my table data from my previous post.

EDIT: it works now! weard, i didnt do anything. I think it has changed when i did update from svn.

Last edited by Stown; 29th September 2009 at 12:54.
Reply With Quote
  #10  
Old 25th September 2010, 17:34
jldbaro jldbaro is offline
Junior Member
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I had the same problem. After two hours of searching ... It is because the cache of the browser (firefox for me).
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP code for PHPMyAdmin is not parsed parkerj Installation/Configuration 3 26th May 2009 13:40
Newly Installed ISPConfig3 on Ubuntu 8.04 : login redirect fail ? cripperz Installation/Configuration 5 22nd March 2009 12:15
ISPconfig vhosts apache mod and/or fcgi, php ... hrvbid Feature Requests 1 8th June 2008 12:50
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 09:54
ubuntu ispconfig joomla .htaccess steve1084 General 8 6th January 2007 15:55


All times are GMT +2. The time now is 06:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.