Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd September 2010, 15:11
logicasrl logicasrl is offline
Junior Member
 
Join Date: Aug 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Question Postfix timed out while receiving the initial server greeting

Hi everybody,

I obtain the warning in the title when I use IPConfig 3 as outgoing mail server, but only for certain destination domains.

After some testing, I've noticed that this happens only with destination mail servers that does not respond immediately to a connection to their TCP:25 port. In these cases my Postfix think that the destination server is not responding, write the warning "timed out ..." to the mail.err log and maintain the undelivered messages in the queue (postqueue -p), indefinitely...

I would have found a solution, consisting in configuring a custom "transport" in Postfix and adding the parameters "smtp_connect_timeout" and "smtp_helo_timeout" to this new transport (in /etc/postfix/master.cf) but I'm wondering which is it the best way to realize this in ISPConfig3.
Within ISPConfig3 there is no "/etc/postfix/transport" file (replaced by the "mail_transport" table in the "dbispconfig" database, I suppose) and then I'm wondering if it is correct to manually modify "main.cf" (adding the file to "transport_maps"), "transport" and "master.cf" files.

Any suggestion?

Thank you very much,
Luca
Reply With Quote
Sponsored Links
  #2  
Old 22nd September 2010, 17:05
logicasrl logicasrl is offline
Junior Member
 
Join Date: Aug 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Solved!!!

I've tried to configure a custom transport in Postfix, but with no success.

The problem was solved, instead, simply executing the following command:

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

and restarting Postfix.

A bit strange, in my opinion, but the important aspect is that now there are no more problems in delivery mail to "slow response" mail servers...

Luca
Reply With Quote
  #3  
Old 6th January 2011, 05:55
lancia lancia is offline
Junior Member
 
Join Date: Jan 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Luca, sorry to grave-dig your thread here, but I've been experiencing the same issue and your suggested fix did, in fact, solve the problem. However, considering the implications of disabling tcp_window_scaling (effectively setting your maximum TCP window size to 64k), this does not seem like the best practical long-term solution - especially if the server is performing other duties such as web-serving.

Since posting this, have you discovered any other way around the issue? Or, can anyone else chime in on perhaps a better way to handle such troublesome remote mail servers?
Reply With Quote
  #4  
Old 7th January 2011, 10:32
bajodel bajodel is offline
Member
 
Join Date: Jul 2007
Location: Italy
Posts: 63
Thanks: 26
Thanked 12 Times in 11 Posts
Default

RFC 2821 (SMTP) says that a client should wait 5 minutes for the "Initial 220 Message". Many SMTP servers accept a TCP connection but delay delivery of the 220 message for different reasons (slamming/GreetPause , more mail to be processed, ..others..)

Insert in your postfix main.cf a higher timeout value (default is 30 sec).. i think 120 sec should be enough:
Quote:
smtp_connect_timeout = 120s
bye..
Reply With Quote
  #5  
Old 10th January 2011, 08:46
logicasrl logicasrl is offline
Junior Member
 
Join Date: Aug 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Arrow

Hi Lancia,
no, I didn't find other solutions... In my case setting the tcp_window_scaling parameter did not have collateral effects, apparently...
In any case if you find alternative solutions, let me know (thank you).
Ah, I do not remember for sure if I tried the smtp_connect_timeout, but I think of having given it a try, with no great results...
Good luck,
Luca

Quote:
Originally Posted by lancia View Post
Hi Luca, sorry to grave-dig your thread here, but I've been experiencing the same issue and your suggested fix did, in fact, solve the problem. However, considering the implications of disabling tcp_window_scaling (effectively setting your maximum TCP window size to 64k), this does not seem like the best practical long-term solution - especially if the server is performing other duties such as web-serving.

Since posting this, have you discovered any other way around the issue? Or, can anyone else chime in on perhaps a better way to handle such troublesome remote mail servers?
Reply With Quote
  #6  
Old 18th July 2011, 13:03
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
Default

Hey folks, I have the same problem and another.

I try to echo 0 > /proc/sys/net/ipv4/tcp_window_scaling but I'm not allowed. The files permissions are 444, i try to change to 644 but it won't allow me to change it. I am running Debian 6 on a VPS Virtuozzo

Any other solutions?

PS:
The timeout option doesn't work either.
Reply With Quote
  #7  
Old 19th July 2011, 10:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You can try this instead: put
Code:
net.ipv4.tcp_window_scaling = 0
in /etc/sysctl.conf and run
Code:
sysctl -p
Afterwards
Code:
cat /proc/sys/net/ipv4/tcp_window_scaling
should show "0".
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 19th July 2011, 10:42
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
 
Default

I fixed it by setting in my /etc/amavis/conf.d/50-user $max_servers = 1; and not 0 as I had defined it first.
Reply With Quote
The Following User Says Thank You to alleks For This Useful Post:
falko (20th July 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11


All times are GMT +2. The time now is 16:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.