#1  
Old 12th September 2010, 11:19
staatslot staatslot is offline
Junior Member
 
Join Date: Aug 2010
Posts: 10
Thanks: 1
Thanked 2 Times in 1 Post
Default aliasdomain doesn't redirect

Hi all,

This is the situation:
I have www.website1.com and www.website2.com
www.website1.com is installed as a website, so it has a folder on the server and everything works fine.

I want www.website2.com to redirect into a subfolder of www.website1.com.
Lets say the subfolder is called test.

I added a aliasdomain with this information:
domain: website2.com
parent website: website1.com
Redirect type R
redirect path /test/
auto subdomain *.
Active: checked

But when i visit www.website2.com I just get the root of www.website1.com.
The addressbar is displaying website2.com.

I changed the flag, I even tried to redirect to www.differentsite.com but it allways goes to the root of www.website1.com.

Can anyone please help?
Reply With Quote
Sponsored Links
  #2  
Old 12th September 2010, 18:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

Use redirect type "noflag". If I remember correctly, the redirect will only work for the domain that you specified and not * wildcards. So your redirect will work for website2.com but not www.website2.com.

If a domain shall have its own folder, then it is recommended to create a new website and not a aliasdomain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th September 2010, 09:24
staatslot staatslot is offline
Junior Member
 
Join Date: Aug 2010
Posts: 10
Thanks: 1
Thanked 2 Times in 1 Post
 
Default

Quote:
Originally Posted by till View Post
Use redirect type "noflag". If I remember correctly, the redirect will only work for the domain that you specified and not * wildcards. So your redirect will work for website2.com but not www.website2.com.

If a domain shall have its own folder, then it is recommended to create a new website and not a aliasdomain.
Thanks, that cleared something up.
I works just as long as I don't use the * for automatic subdomain.
I prefer the * so all subdomains are being redirected, but i'm glad this works for now!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Infinite redirect loop stolenpants General 13 23rd August 2010 17:36
add new subdomain with redirect type L fails when redirect path is /home/ finn Installation/Configuration 7 22nd August 2010 09:42
Redirect Wireless Client to Late-Pay Notice giganet Server Operation 1 19th June 2009 08:57
Aliasdomain with 301 redirect oncletom Feature Requests 2 18th May 2009 19:53
Strange Redirect of the Co-Domains vaio1 Installation/Configuration 9 19th October 2008 13:35


All times are GMT +2. The time now is 04:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.