Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th September 2010, 09:56
Azimuth Azimuth is offline
Junior Member
 
Join Date: Sep 2007
Posts: 16
Thanks: 0
Thanked 4 Times in 1 Post
Default messing with website path and symlink values

Ideally I would love to have my website paths as /var/www/clients/domain/
but that didn't seem to work.
I started getting apache vhosts with paths that were literally /var/www/clients/[website_domain]

now I'd like to try the default values again but don't have any records of what they were.

If anyone has any insight on the default settings or how to get my preferred settings to work, please let me know.

thanks.
Reply With Quote
Sponsored Links
  #2  
Old 7th September 2010, 11:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,781
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Quote:
Ideally I would love to have my website paths as /var/www/clients/domain/
Such a path can not work as you can not use any changable variables like the domain name in the path. Such a value would break your website when you change the domain later in the website settings. Thats why ISPConfig uses symlinks for asy shell navigation and a fixed path containing ID's. It is highly recommended that you do not change the default values.

Quote:
now I'd like to try the default values again but don't have any records of what they were.
The defaults are:

Website path: /var/www/clients/client[client_id]/web[website_id]
Website Symlinks: /var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th September 2010, 16:47
Azimuth Azimuth is offline
Junior Member
 
Join Date: Sep 2007
Posts: 16
Thanks: 0
Thanked 4 Times in 1 Post
Default

I guess in all my messing around. My apache isn't loading site-available anymore.
On one server webmin/apache page shows the sites-available content as editable but does not on the server i'm having issues with.
The scripts are in that directory. I looked at both my ispconfig servers and both state Include /etc/apache2/sites-enabled/

One server loads ispconfig and the other does not.

both servers are in single server setup.


thanks for all your help.

EDIT: I changed the include line to sites-available and it is up again. The odd thing is that it's working on the other server with sites-enabled

Last edited by Azimuth; 7th September 2010 at 16:58.
Reply With Quote
  #4  
Old 7th September 2010, 17:15
Azimuth Azimuth is offline
Junior Member
 
Join Date: Sep 2007
Posts: 16
Thanks: 0
Thanked 4 Times in 1 Post
Default

Is there any way to remove the client id and the website id and use something more site descriptive? we only have a small number of clients and websites so uniqueness isn't an issue for us.
Reply With Quote
  #5  
Old 7th September 2010, 21:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,781
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
 
Default

Quote:
Is there any way to remove the client id and the website id and use something more site descriptive? we only have a small number of clients and websites so uniqueness isn't an issue for us.
No, I explained above why it is not possible to use the domain in a path. But it is not needed to do that as you use the symlinks which have the name of the domain for shell paths anyway, so you dont have to care about the real path. If you want to go to a domain on the shell, simply go to /var/www/domain.com/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig3 - website path ilaidlaw Developers' Forum 2 23rd February 2009 14:38


All times are GMT +2. The time now is 09:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.