Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd July 2010, 12:21
mrtns mrtns is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't receive mail

ISPconfig 2 + postfix 2.5.1.

I have problem: can't receive mail from senders.
Mail log shows:
Jul 2 13:15:09 ub postfix/cleanup[3624]: 13A9E6BE349: message-id=<64281532270134.1R8Z21X7523@jcikpenvesepu.waiwa i.net>
Jul 2 13:15:09 ub postfix/qmgr[8265]: 13A9E6BE349: from=<jiri.kulicka@centrum.cz>, size=2428, nrcpt=2 (queue active)
Jul 2 13:15:25 ub postfix/local[3479]: 13A9E6BE349: to=<web1.danute@ub.vvspt.lt>, orig_to=<danute.sidiskiene@vvspt.lt>, relay=local, delay=18, delays=1.8/0/0/16, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 2 13:15:25 ub postfix/qmgr[8265]: 13A9E6BE349: removed

But I didn't get any mail to my mailbox.
What's the problem?
Reply With Quote
Sponsored Links
  #2  
Old 2nd July 2010, 13:12
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

add this line to your .procmailrc file:

Code:
LOGFILE=/var/log/procmail.log
chmod it to ehm, say 666

Code:
chmod 666 /var/log/procmail.log
now send another mail, and check the contents of the logfile.
Reply With Quote
  #3  
Old 28th July 2010, 08:28
mrtns mrtns is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The log file is empty. It's possible?
Reply With Quote
  #4  
Old 28th July 2010, 10:46
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

if you create a new email account in the same domain, can that one receive mail?
Reply With Quote
  #5  
Old 28th July 2010, 10:54
mrtns mrtns is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I didn't receive not all mail.
Some mails arives, but some no...
What's the problem?
Reply With Quote
  #6  
Old 28th July 2010, 11:11
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

check the logfil /var/log/mail.log and see what lines you get with a mail that you receive and the ones which you didn't receive it, see if there are differences .. also set a procmail log on both those mailboxes and see if the logfiles show you anything helpfull.
Reply With Quote
  #7  
Old 28th July 2010, 12:56
mrtns mrtns is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

From mail.log.
Received mail:
Jul 28 13:54:40 ub postfix/smtpd[27420]: 7AD1C6BE1DA: client=unknown[192.168.1.115], sasl_method=PLAIN, sasl_username=web1.martynas
Jul 28 13:54:40 ub postfix/cleanup[3186]: 7AD1C6BE1DA: message-id=<4C500C2A.1080700@martynas.net>
Jul 28 13:54:40 ub postfix/qmgr[27127]: 7AD1C6BE1DA: from=<martynas@martynas.net>, size=755, nrcpt=1 (queue active)
Jul 28 13:54:56 ub postfix/local[2034]: 7AD1C6BE1DA: to=<web1.martynas@ub.vvspt.lt>, orig_to=<martynas@vvspt.lt>, relay=local, delay=16, delays=0.03/0/0/16, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 28 13:54:56 ub postfix/qmgr[27127]: 7AD1C6BE1DA: removed


Didn't received:
Jul 19 16:36:16 ub postfix/smtpd[17508]: 7E0FB6BE1B2: client=unknown[79.98.28.17]
Jul 19 16:36:16 ub postfix/cleanup[16126]: 7E0FB6BE1B2: message-id=<005001cb2747$32b62430$98226c90$@kiallo@ccg.lt>
Jul 19 16:36:16 ub postfix/qmgr[29266]: 7E0FB6BE1B2: from=<a.kiallo@ccg.lt>, size=109643, nrcpt=1 (queue active)
Jul 19 16:36:32 ub postfix/local[17418]: 7E0FB6BE1B2: to=<web26.jurgitaciuvasoviene@ub.vvspt.lt>, orig_to=<jurgita.ciuvasoviene@klaipeda.vvspt.lt>, relay=local, delay=17, delays=1.2/0/0/16, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 19 16:36:32 ub postfix/qmgr[29266]: 7E0FB6BE1B2: removed
Reply With Quote
  #8  
Old 28th July 2010, 13:18
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Received:
to=<web1.martynas@ub.vvspt.lt>, orig_to=<martynas@vvspt.lt>,

Didn't Receive:
to=<web26.jurgitaciuvasoviene@ub.vvspt.lt>, orig_to=<jurgita.ciuvasoviene@klaipeda.vvspt.lt>

send a mail to the same address, but from different locations ..

i'm thinking it has something to do with the used domain names, host file, aliases etc ..
Reply With Quote
  #9  
Old 28th July 2010, 13:32
mrtns mrtns is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have parked some subdomains to one mail server.
Reply With Quote
  #10  
Old 29th July 2010, 14:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

What's the output of
Code:
repquota -avug
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 16:27
Postfix + postfixadmin = SMTP errors... Rashef Server Operation 4 25th June 2009 16:12
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 20:47
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 07:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.