Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd September 2010, 16:01
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default How To Install Alfresco Community 3.3 On Ubuntu Server 10.04 - Start Problem

Hi all,

This is my first post in this forum so hello to everyone.

This is my problem:
I got alfresco working on another machine one year ago (should be ubuntu 9.04 desktop) and now I'm trying to reinstall everything on a fresh install of ubuntu server 10.04 (x64).

I found this excellent tuto on how to forge but i'm stuck at the end (9.3) for a permission problem.

here is my terminal output:
Quote:
root@GED:/opt/alfresco# bash ./alfresco.sh start
./alfresco.sh: line 12: ./tomcat/bin/startup.sh: Permission non accordée
Permission non accordée = permission denied (in french)

As I installed everything in root and all files seem to belong to root, I really dont understand the error. Does some of you already encounter this problem of know how to work around ?

Thanks in advance

Snarf
Reply With Quote
Sponsored Links
  #2  
Old 4th September 2010, 13:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's the output of
Code:
ls -la /opt/alfresco/tomcat/bin/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th September 2010, 14:41
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks in advance for your help...

here the terminal result:

Code:
administrator@GED:/opt/alfresco/tomcat/bin$ ls -la
total 372
drwxr-xr-x  2 root root   4096 2010-09-03 10:35 .
drwxr-xr-x 11 root root   4096 2010-09-03 10:35 ..
-rw-r--r--  1 root root  17519 2008-07-22 03:01 bootstrap.jar
-rwxr-xr-x  1 root root  12907 2008-07-22 03:01 catalina.sh
-rw-r--r--  1 root root   2374 2008-07-22 03:01 catalina-tasks.xml
-rw-r--r--  1 root root   9341 2008-07-22 03:01 commons-daemon.jar
-rwxr-xr-x  1 root root   1624 2008-07-22 03:01 digest.sh
-rw-r--r--  1 root root  74398 2008-07-22 03:01 jsvc.tar.gz
-rwxr-xr-x  1 root root   4447 2008-07-22 03:01 setclasspath.sh
-rwxr-xr-x  1 root root   1563 2008-07-22 03:01 shutdown.sh
-rwxr-xr-x  1 root root   1956 2008-07-22 03:01 startup.sh
-rw-r--r--  1 root root  18984 2008-07-22 03:01 tomcat-juli.jar
-rw-r--r--  1 root root 189757 2008-07-22 03:01 tomcat-native.tar.gz
-rwxr-xr-x  1 root root   3291 2008-07-22 03:01 tool-wrapper.sh
-rwxr-xr-x  1 root root   1567 2008-07-22 03:01 version.sh
administrator@GED:/opt/alfresco/tomcat/bin$
Do you see something abnormal ?

I edit this post to add some details of my install as it could perhaps help anyone to get an idea:

I wanted to install alfresco on a separate partition (lvm type). So I mount this partition in /media/GED.
I then created an alfresco directory under /media/GED and I finally simlinked /opt/alfresco to point to this directory.
That is the only thing which is not exactly as the "how to"
I don't think this can come from this but it's always better to explain !!

Last edited by snarf77; 4th September 2010 at 16:05. Reason: Adding installation detail
Reply With Quote
  #4  
Old 5th September 2010, 10:06
henzbelmont henzbelmont is offline
Junior Member
 
Join Date: Sep 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is it possible to install it on one computer then just copy the registry files and use it on another computer? T His might save us time but is this possible? I have been doing this on games. playpokiesonline

Last edited by henzbelmont; 6th September 2010 at 11:36.
Reply With Quote
  #5  
Old 5th September 2010, 19:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by snarf77 View Post
Thanks in advance for your help...

here the terminal result:

Code:
administrator@GED:/opt/alfresco/tomcat/bin$ ls -la
total 372
drwxr-xr-x  2 root root   4096 2010-09-03 10:35 .
drwxr-xr-x 11 root root   4096 2010-09-03 10:35 ..
-rw-r--r--  1 root root  17519 2008-07-22 03:01 bootstrap.jar
-rwxr-xr-x  1 root root  12907 2008-07-22 03:01 catalina.sh
-rw-r--r--  1 root root   2374 2008-07-22 03:01 catalina-tasks.xml
-rw-r--r--  1 root root   9341 2008-07-22 03:01 commons-daemon.jar
-rwxr-xr-x  1 root root   1624 2008-07-22 03:01 digest.sh
-rw-r--r--  1 root root  74398 2008-07-22 03:01 jsvc.tar.gz
-rwxr-xr-x  1 root root   4447 2008-07-22 03:01 setclasspath.sh
-rwxr-xr-x  1 root root   1563 2008-07-22 03:01 shutdown.sh
-rwxr-xr-x  1 root root   1956 2008-07-22 03:01 startup.sh
-rw-r--r--  1 root root  18984 2008-07-22 03:01 tomcat-juli.jar
-rw-r--r--  1 root root 189757 2008-07-22 03:01 tomcat-native.tar.gz
-rwxr-xr-x  1 root root   3291 2008-07-22 03:01 tool-wrapper.sh
-rwxr-xr-x  1 root root   1567 2008-07-22 03:01 version.sh
administrator@GED:/opt/alfresco/tomcat/bin$
Do you see something abnormal ?

I edit this post to add some details of my install as it could perhaps help anyone to get an idea:

I wanted to install alfresco on a separate partition (lvm type). So I mount this partition in /media/GED.
I then created an alfresco directory under /media/GED and I finally simlinked /opt/alfresco to point to this directory.
That is the only thing which is not exactly as the "how to"
I don't think this can come from this but it's always better to explain !!
Permissions look ok. Did you disable AppArmor?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 5th September 2010, 20:14
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thank you all...

falko,
Apparmor was not disable... That's a good idea. I will try tomorrow without it.


henzbelmont,
What kind of registyry files are you talking about ? all the tomcat directory ?

Bye
Reply With Quote
  #7  
Old 6th September 2010, 21:56
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Unfortunately same problem with apparmor disable...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Maia MailGuard in ISPC3 warlock Tips/Tricks/Mods 7 23rd December 2010 06:51
NOT START Alfresco Community 3.3 On Ubuntu Server 10.04 (Lucid Lynx) MocArt HOWTO-Related Questions 0 5th August 2010 04:03
Maia Mailguard with ISPconfig seangee Installation/Configuration 4 24th June 2010 10:08
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 13:47
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30


All times are GMT +2. The time now is 05:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.