Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st August 2010, 17:26
bjron.mork bjron.mork is offline
Junior Member
 
Join Date: Aug 2010
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default ISPConfig3 on CentOS5.5

Hi,

I am trying to install ISPConfig3 on my Intel Server. Every thing goes fine before install ISPConfig3 package....

############
[root@isp install]# php -q install.php


--------------------------------------------------------------------------------
_____ ___________ _____ __ _
|_ _/ ___| ___ \ / __ \ / _(_)
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` |
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| |
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, |
__/ |
|___/
--------------------------------------------------------------------------------


>> Initial configuration

Operating System: Redhat or compatible, unknown version.

Following will be a few questions for primary configuration so be careful.
Default values are in [brackets] and can be accepted with <ENTER>.
Tap in "quit" (without the quotes) to stop the installer.


Select language (en,de) [en]:

Installation mode (standard,expert) [standard]:

Full qualified hostname (FQDN) of the server, eg server1.domain.tld [isp.config.net]:

MySQL server hostname [localhost]:

MySQL root username [root]:

MySQL root password []: ispconfig

MySQL database to create [dbispconfig]:

MySQL charset [utf8]:

Generating a 2048 bit RSA private key
............................+++
...........+++
writing new private key to 'smtpd.key'
-----
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [GB]:
State or Province Name (full name) [Berkshire]:
Locality Name (eg, city) [Newbury]:
Organization Name (eg, company) [My Company Ltd]:
Organizational Unit Name (eg, section) []:
Common Name (eg, your name or your server's hostname) []:Bjron Mork
Email Address []:bjron.mork@gmail.com
Configuring Jailkit
Configuring Dovecot
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring BIND
Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configuring Firewall
Installing ISPConfig
ISPConfig Port [8080]:

Configuring DBServer
Installing Crontab
no crontab for root
no crontab for getmail
Restarting services ...
Stopping MySQL: [ OK ]
Starting MySQL: [ OK ]
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Stopping saslauthd: [FAILED]
Starting saslauthd: [ OK ]
Shutting down Mail Virus Scanner (amavisd): [FAILED]
Starting Mail Virus Scanner (amavisd): [ OK ]
Stopping Dovecot Imap: [ OK ]
Error: mail_plugin_dir: Can't access directory: /usr/lib/dovecot/imap/: No such file or directory
Fatal: Invalid configuration in /etc/dovecot.conf
Starting Dovecot Imap: [FAILED]

Stopping httpd: [ OK ]
[Tue Aug 31 17:58:59 2010] [warn] NameVirtualHost *:443 has no VirtualHosts
[Tue Aug 31 17:58:59 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
(13)Permission denied: make_sock: could not bind to address [::]:8081
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
no listening sockets available, shutting down
Unable to open logs
Starting httpd: [FAILED]

Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Installation completed.
[root@isp install]#
[root@isp install]#
[root@isp install]#
[root@isp install]#
[root@isp install]# service httpd status
httpd is stopped

[root@isp install]# service httpd start
Starting httpd: [Tue Aug 31 17:59:31 2010] [warn] NameVirtualHost *:443 has no VirtualHosts
[Tue Aug 31 17:59:31 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
(13)Permission denied: make_sock: could not bind to address [::]:8081
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
no listening sockets available, shutting down
Unable to open logs
[FAILED]

[root@isp install]#
#############


i have httpd and dovecot installed...

[root@isp ~]# rpm -qa | grep dovecot
dovecot-devel-1.2.14-1_112.el5
dovecot-sieve-0.1.17-5.el5
dovecot-1.2.14-1_112.el5
dovecot-sieve-devel-0.1.17-5.el5


[root@isp ~]# rpm -qa | grep http
httpd-devel-2.2.3-43.el5.centos.3
httpd-2.2.3-43.el5.centos.3
httpd-devel-2.2.3-43.el5.centos.3



[root@isp ~]# uname -a
Linux isp.config.net 2.6.18-194.11.3.el5 #1 SMP Mon Aug 30 16:19:16 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

What might be wrong with httpd and dovecot....Please help, what i am doing wrong....


________
Regards
BMork
Reply With Quote
Sponsored Links
  #2  
Old 31st August 2010, 19:14
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Shutting down Mail Virus Scanner (amavisd): [FAILED]
doesn't matter - was not started I guess ...
Quote:
Starting Mail Virus Scanner (amavisd): [ OK ]
yeah - that's ok
Quote:
Error: mail_plugin_dir: Can't access directory: /usr/lib/dovecot/imap/: No such file or directory
Take a look at the /etc/dovecot.conf search for mail_plugin_dir
This should point to something existing and i.e. sieve plugin
Maybe it's /usr/lib/64/dovecot/lda - on another host with CO5.5 /usr/lib/dovecot/imap exists ....
Try to find lib20_virtual_plugin.so - this is probably the right place to point to ...
Quote:
Fatal: Invalid configuration in /etc/dovecot.conf
Starting Dovecot Imap: [FAILED][/B]
Sure - see comment above ...

Quote:
Stopping httpd: [ OK ]
[Tue Aug 31 17:58:59 2010] [warn] NameVirtualHost *:443 has no VirtualHosts
[Tue Aug 31 17:58:59 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
(13)Permission denied: make_sock: could not bind to address [::]:8081
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
no listening sockets available, shutting down
Unable to open logs
Starting httpd: [FAILED]
Two ideas:
- is there really nothing listening on the 8081 port? (check with netstat)
- edit the httpd.conf file manually and check with httpd -S for errors. You can change the port there as well and give it a shot ...

Cheers, Patrick
Reply With Quote
  #3  
Old 31st August 2010, 19:47
bjron.mork bjron.mork is offline
Junior Member
 
Join Date: Aug 2010
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default

As i commit out below mentioned lines from httpd.conf

NameVirtualHost *:80
NameVirtualHost *:443
Include /etc/httpd/conf/sites-enabled/


and i manually changed DocumnetRoot to /var/www/ispconfig

i am able to start httpd services, and if i do http://ip-address:8080, ispconfig page is now visible, but i am unable to login using admin/admin....

How this issue can be resolved....

REGARDS
BMORK
Reply With Quote
  #4  
Old 31st August 2010, 20:06
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

you can change the password directly in the mysql db
Think on it that it's an MD5 hash password ....
Table is: sys_user

But I think there is something else wrong. Have you checked all logs i.e. http log incl. error log?

Patrick
Reply With Quote
  #5  
Old 31st August 2010, 20:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

The password is crypt with salt.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 31st August 2010, 20:15
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ups - sorry - you are right - my fault ...
Reply With Quote
  #7  
Old 1st September 2010, 08:06
bjron.mork bjron.mork is offline
Junior Member
 
Join Date: Aug 2010
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default

I dont have sys_user table in both my databases, if you are taking about mysql.user, i have checked there is not any user with the name of admin.

mysql> use dbispconfig
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql>
mysql>
mysql> show tables;
+-----------------------+
| Tables_in_dbispconfig |
+-----------------------+
| client |
| client_template |
| cron |
| dns_rr |
| dns_soa |
| dns_template |
| firewall |
| ftp_user |
| mail_access |
| mail_content_filter |
| mail_domain |
| mail_forwarding |
| mail_get |
| mail_greylist |
| mail_mailman_domain |
| mail_relay_recipient |
| mail_traffic |
| mail_transport |
| mail_user |
| mail_user_filter |
| remote_session |
| remote_user |
+-----------------------+
22 rows in set (0.00 sec)

mysql>
mysql>
mysql> use mysql
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> show tables;
+---------------------------+
| Tables_in_mysql |
+---------------------------+
| columns_priv |
| db |
| func |
| help_category |
| help_keyword |
| help_relation |
| help_topic |
| host |
| proc |
| procs_priv |
| tables_priv |
| time_zone |
| time_zone_leap_second |
| time_zone_name |
| time_zone_transition |
| time_zone_transition_type |
| user |
+---------------------------+
17 rows in set (0.00 sec)



My httpd access_logs are.....

172.29.36.84 - - [01/Sep/2010:08:58:25 +0500] "GET /nav.php?nav=top HTTP/1.1" 200 98 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"
172.29.36.84 - - [01/Sep/2010:08:58:25 +0500] "GET /nav.php?nav=side HTTP/1.1" 200 51 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"
172.29.36.84 - - [01/Sep/2010:08:58:25 +0500] "GET /keepalive.php HTTP/1.1" 200 26 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"
172.29.36.84 - - [01/Sep/2010:08:58:25 +0500] "GET /themes/default/icons/x16/key.png HTTP/1.1" 200 691 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"
172.29.36.84 - - [01/Sep/2010:08:58:25 +0500] "GET /themes/default/images/buttonHolder_bg.gif HTTP/1.1" 200 609 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"
172.29.36.84 - - [01/Sep/2010:08:58:29 +0500] "POST /content.php HTTP/1.1" 200 566 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"
172.29.36.84 - - [01/Sep/2010:08:58:29 +0500] "GET /nav.php?nav=side HTTP/1.1" 200 51 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"
172.29.36.84 - - [01/Sep/2010:08:58:29 +0500] "GET /nav.php?nav=top HTTP/1.1" 200 98 "http://172.26.18.74:8080/" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)"


and my http error_logs are


[Tue Aug 31 19:44:42 2010] [notice] SELinux policy enabled; httpd running as context root:system_r:httpd_t:s0
[Tue Aug 31 19:44:42 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 31 19:44:44 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 31 19:44:44 2010] [notice] Digest: done
[Tue Aug 31 19:44:44 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Tue Aug 31 19:44:47 2010] [error] [client 172.29.3.161] File does not exist: /var/www/html/favicon.ico
[Tue Aug 31 19:44:50 2010] [error] [client 172.29.3.161] File does not exist: /var/www/html/favicon.ico
[Tue Aug 31 19:44:52 2010] [error] [client 172.29.3.161] Directory index forbidden by Options directive: /var/www/html/
[Tue Aug 31 19:50:36 2010] [notice] caught SIGTERM, shutting down
[Tue Aug 31 19:50:37 2010] [notice] SELinux policy enabled; httpd running as context root:system_r:httpd_t:s0
[Tue Aug 31 19:50:37 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 31 19:50:44 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 31 19:50:44 2010] [notice] Digest: done
[Tue Aug 31 19:50:44 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Tue Aug 31 19:55:06 2010] [error] [client 172.29.3.161] Directory index forbidden by Options directive: /var/www/html/
[Tue Aug 31 19:55:13 2010] [error] [client 172.29.3.161] Directory index forbidden by Options directive: /var/www/html/
[Tue Aug 31 19:57:42 2010] [notice] caught SIGTERM, shutting down
[Tue Aug 31 19:59:08 2010] [notice] SELinux policy enabled; httpd running as context root:system_r:httpd_t:s0
[Tue Aug 31 19:59:08 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 31 19:59:10 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 31 19:59:10 2010] [notice] Digest: done
[Tue Aug 31 19:59:10 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Tue Aug 31 19:59:14 2010] [notice] caught SIGTERM, shutting down
[Tue Aug 31 19:59:15 2010] [notice] SELinux policy enabled; httpd running as context root:system_r:httpd_t:s0
[Tue Aug 31 19:59:15 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 31 19:59:17 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 31 19:59:17 2010] [notice] Digest: done
[Tue Aug 31 19:59:17 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Tue Aug 31 19:59:19 2010] [notice] caught SIGTERM, shutting down
[Tue Aug 31 19:59:20 2010] [notice] SELinux policy enabled; httpd running as context root:system_r:httpd_t:s0
[Tue Aug 31 19:59:20 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 31 19:59:21 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 31 19:59:21 2010] [notice] Digest: done
[Tue Aug 31 19:59:22 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Tue Aug 31 20:00:15 2010] [notice] caught SIGTERM, shutting down
[Tue Aug 31 20:00:17 2010] [notice] SELinux policy enabled; httpd running as context root:system_r:httpd_t:s0
[Tue Aug 31 20:00:17 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 31 20:00:18 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 31 20:00:18 2010] [notice] Digest: done
[Tue Aug 31 20:00:19 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Tue Aug 31 20:00:21 2010] [notice] caught SIGTERM, shutting down
[Tue Aug 31 20:00:22 2010] [notice] SELinux policy enabled; httpd running as context root:system_r:httpd_t:s0
[Tue Aug 31 20:00:22 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 31 20:00:24 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 31 20:00:24 2010] [notice] Digest: done
[Tue Aug 31 20:00:24 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations


and mysql logs are


100831 19:27:12 mysqld ended

100831 19:27:16 mysqld started
100831 19:27:17 InnoDB: Started; log sequence number 0 43655
100831 19:27:17 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.0.77' socket: '/var/lib/mysql/mysql.sock' port: 3306 Source distribution
100831 19:27:53 [Note] /usr/libexec/mysqld: Normal shutdown

100831 19:27:55 InnoDB: Starting shutdown...
100831 19:27:56 InnoDB: Shutdown completed; log sequence number 0 43655
100831 19:27:56 [Note] /usr/libexec/mysqld: Shutdown complete

100831 19:27:56 mysqld ended

100831 19:27:57 mysqld started
100831 19:27:57 InnoDB: Started; log sequence number 0 43655
100831 19:27:57 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.0.77' socket: '/var/lib/mysql/mysql.sock' port: 3306 Source distribution
100831 19:40:49 [Note] /usr/libexec/mysqld: Normal shutdown

100831 19:40:51 InnoDB: Starting shutdown...
100831 19:40:52 InnoDB: Shutdown completed; log sequence number 0 43665
100831 19:40:52 [Note] /usr/libexec/mysqld: Shutdown complete

100831 19:40:52 mysqld ended

100831 19:40:53 mysqld started
100831 19:40:53 InnoDB: Started; log sequence number 0 43665
100831 19:40:53 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.0.77' socket: '/var/lib/mysql/mysql.sock' port: 3306 Source distribution
100831 19:50:29 [Note] /usr/libexec/mysqld: Normal shutdown

100831 19:50:29 InnoDB: Starting shutdown...
100831 19:50:31 InnoDB: Shutdown completed; log sequence number 0 43665
100831 19:50:31 [Note] /usr/libexec/mysqld: Shutdown complete

100831 19:50:31 mysqld ended

100831 19:50:31 mysqld started
100831 19:50:32 InnoDB: Started; log sequence number 0 43665
100831 19:50:32 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.0.77' socket: '/var/lib/mysql/mysql.sock' port: 3306 Source distribution

......

is this php script issue of ispconfig3 ?



regards
Bmork
Reply With Quote
  #8  
Old 1st September 2010, 12:01
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

you need to look at the ispconfig database - not somewhere else!
Default DB name is dbispconfig
If this DB is missing you have your problem.

Patrick
Reply With Quote
The Following User Says Thank You to carg For This Useful Post:
bjron.mork (2nd September 2010)
  #9  
Old 2nd September 2010, 10:51
bjron.mork bjron.mork is offline
Junior Member
 
Join Date: Aug 2010
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by carg View Post
Hi,

you need to look at the ispconfig database - not somewhere else!
Default DB name is dbispconfig
If this DB is missing you have your problem.
Patrick
Thank Patric, I have resolved this issue. I uninstalled ISPConfig, downloaded ISPConfig again, and reinstalled. And got the DB upto date and i got login.

I also have resolved second issue of DOVECOT

Error: 3: Can't access directory: /usr/lib/dovecot/imap/: No such file or directory
Fatal: Invalid configuration in /etc/dovecot.conf
Starting Dovecot Imap: [FAILED]


I am using x86_64 bit version, so i did changed /usr/lib/dovecot/imap/ to /usr/lib64/dovecot/imap/

and other values as well......

/usr/lib64/dovecot/pop3/
/usr/lib64/dovecot/lda/

its now working fine... and i am able to send and receive emails...

Thanks..

regards
BMork
Reply With Quote
The Following User Says Thank You to bjron.mork For This Useful Post:
till (2nd September 2010)
  #10  
Old 2nd September 2010, 11:28
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Hi BMork,

good to hear that it is working now :-)

Patrick
Reply With Quote
Reply

Bookmarks

Tags
http

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 | Welcome message has been sent to the wrong host Hans General 6 16th July 2010 11:56
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 05:24
ISPConfig3 FTP problem karazy-k Server Operation 6 3rd September 2009 17:03
Remove-Reinstall Postfix- ISPCONFIG3 need reinstall? RomaSvcs Installation/Configuration 1 7th May 2009 12:11
Questions about ISPConfig3 vs. ISPConfig2 atjensen11 General 1 15th March 2009 00:59


All times are GMT +2. The time now is 16:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.