Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th August 2010, 15:02
mescalina mescalina is offline
Junior Member
 
Join Date: Aug 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Question email problem ISPConfig 3

Hellow i have a server whit ispconfig 3 but i have a problem i make a domain for a client ex: mydomain.com, i create an account from ispconfig panel at: Email Mailbox, and i try to login whit SquirrelMail whit: name@mydomain.com and the password i put that password when i create the account, from outlook i logged id but i try to send an email to a gmail account and i get this error: "The connection to the server has failed. Account: 'mail.mydomain.com, Server: 'mail.mydomain.com', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10061, Error Number: 0x800CCC0E"
what can i do?
thanks and have a nice day.
Reply With Quote
Sponsored Links
  #2  
Old 21st August 2010, 17:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Any errors in your mail log? What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd August 2010, 01:37
d3athrow d3athrow is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i'm having the same issue, but i used the tutorial here - http://www.howtoforge.com/perfect-se...10-ispconfig-3

same error but i'm using thunderbird and when i try to use the squirrelmail i get
Code:
Message not sent. Server replied:

    Service not available, closing channel
    421 4.3.0 collect: Cannot write ./dfo7LNY64o009355 (bfcommit, uid=0, gid=110): No such file or directory
the netstat -tap gives
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      26274/amavisd (mast
tcp        0      0 *:mysql                 *:*                     LISTEN      25955/mysqld    
tcp        0      0 localhost.lo:submission *:*                     LISTEN      22191/sendmail: MTA
tcp        0      0 *:5901                  *:*                     LISTEN      22242/Xtightvnc 
tcp        0      0 *:http-alt              *:*                     LISTEN      28136/apache2   
tcp        0      0 *:www                   *:*                     LISTEN      28136/apache2   
tcp        0      0 *:tproxy                *:*                     LISTEN      28136/apache2   
tcp        0      0 *:x11-1                 *:*                     LISTEN      22242/Xtightvnc 
tcp        0      0 178.18.19.30:domain     *:*                     LISTEN      28177/named     
tcp        0      0 mc.undo.it:domain       *:*                     LISTEN      28177/named     
tcp        0      0 localhost.locald:domain *:*                     LISTEN      28177/named     
tcp        0      0 *:ssh                   *:*                     LISTEN      22000/sshd      
tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN      22064/cupsd     
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      28177/named     
tcp        0      0 localhost.localdom:smtp *:*                     LISTEN      22191/sendmail: MTA
tcp        0      0 *:https                 *:*                     LISTEN      28136/apache2   
tcp        0      0 localhost.localdo:56247 localhost.localdoma:www TIME_WAIT   -               
tcp        0      0 mc.undo.it:5901         ip-foo.:53921 ESTABLISHED 22242/Xtightvnc 
tcp        0      0 localhost.localdo:58797 localhost.locald:domain TIME_WAIT   -               
tcp6       0      0 [::]:25565              [::]:*                  LISTEN      23744/java      
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      28053/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      28102/couriertcpd
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      28077/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      28027/couriertcpd
tcp6       0      0 [::]:domain             [::]:*                  LISTEN      28177/named     
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      3444/proftpd: (acce
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      22000/sshd      
tcp6       0      0 ::1%136933432:ipp       [::]:*                  LISTEN      22064/cupsd     
tcp6       0      0 ::1%136933432:953       [::]:*                  LISTEN      28177/named     
tcp6       0      0 localhost.localdoma:ftp localhost.localdo:37895 TIME_WAIT   -               
tcp6       0    241 mc.undo.it:25565        ip-foo.:53930 ESTABLISHED 23744/java      
tcp6       0    364 mc.undo.it:25565        cpe-foo .:58292 ESTABLISHED 23744/java
also it seems i get this error when emailing myself
Code:
Message not sent. Server replied:

    Requested action not taken: mailbox unavailable
    550 5.1.1 <sysadmin@mc.undo.it>... User unknown

Last edited by d3athrow; 22nd August 2010 at 01:52.
Reply With Quote
  #4  
Old 22nd August 2010, 09:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

@mescalina: Please try to use the IP address of your server as smtp server and not mail.mydomain.com. If it works with the IP, then check that mail.mydomain.com points really to the IP of the server.

@d3athrow: Your problem is different from the poster of the first post. You have a problem with the file system. Take a look into the mail.log and post the errors that you get there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd August 2010, 10:04
d3athrow d3athrow is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
@mescalina: Please try to use the IP address of your server as smtp server and not mail.mydomain.com. If it works with the IP, then check that mail.mydomain.com points really to the IP of the server.

@d3athrow: Your problem is different from the poster of the first post. You have a problem with the file system. Take a look into the mail.log and post the errors that you get there.
ah sorry about hijacking then

also if it matters, when setting up an email account on thunderbird it looks for the incoming and outgoing servers and it find the incoming but has trouble on the smtp

EDIT: uploaded the log as an attachment as per request
Attached Files
File Type: txt mail.txt (49.4 KB, 193 views)

Last edited by d3athrow; 22nd August 2010 at 10:16.
Reply With Quote
  #6  
Old 22nd August 2010, 10:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

There seems to be another mail server installed already or a broken postfix instance. Please post the output of:

netstat -tap

By the way, please post logfiles and command output directly into the forum (or attach them as txt files) and dont use pastebin.org. The problem with pastebin is that it renders the answers that we write here useless after a short period of time. E.g. if someone has the same problem then you and finds this thread in 2 years, he then clicks on the pastebin link to see if the error messages are the same and pastebin has already deleted the log then.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd August 2010, 10:15
d3athrow d3athrow is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
There seems to be another mail server installed already or a broken postfix instance. Please post the output of:

netstat -tap

By the way, please post logfiles and command output directly into the forum (or attach them as txt files) and dont use pastebin.org. The problem with pastebin is that it renders the answers that we write here useless after a short period of time. E.g. if someone has the same problem then you and finds this thread in 2 years, he then clicks on the pastebin link to see if the error messages are the same and pastebin has already deleted the log then.
gotcha
here's the netstat -tap
Attached Files
File Type: txt netstat.txt (2.9 KB, 150 views)
Reply With Quote
  #8  
Old 22nd August 2010, 10:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

On your server, you currently run sendmail and not postfix. Please run:

/etc/init.d/sendmail stop
/etc/init.d/postfix start

and try again. If this dont help, then redo all steps from chapter 12 http://www.howtoforge.com/perfect-se...ispconfig-3-p4
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 22nd August 2010, 10:29
d3athrow d3athrow is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
On your server, you currently run sendmail and not postfix. Please run:

/etc/init.d/sendmail stop
/etc/init.d/postfix start

and try again. If this dont help, then redo all steps from chapter 12 http://www.howtoforge.com/perfect-se...ispconfig-3-p4
ok that fixed the sending but the mail accounts can't receive.

Code:
Note: Forwarded message is attached.

This is the mail system at host mc.undo.it.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                  The mail system

<admin@mc.undo.it>: unknown user: "admin"
Reporting-MTA: dns; mc.undo.it
X-Postfix-Queue-ID: 83AF672E9510
X-Postfix-Sender: rfc822; somepersonsomeplace@yahoo.com
Arrival-Date: Sun, 22 Aug 2010 03:28:19 -0500 (CDT)

Final-Recipient: rfc822; admin@mc.undo.it
Original-Recipient: rfc822;admin@mc.undo.it
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "admin"
Fw: Re: test
Re: test
Sunday, August 22, 2010 3:28:36 AM
From:
"Somebody" <somepersonsomeplace@yahoo.com>
To:
"" <admin@mc.undo.it>
again

From: "admin@mc.undo.it" <admin@mc.undo.it>
To: somepersonsomeplace@yahoo.com
Sent: Sun, August 22, 2010 3:27:35 AM
Subject: test

test
Reply With Quote
  #10  
Old 22nd August 2010, 10:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
 
Default

Please post the exact lines from the mail log. Also the recipient address admin@mc.undo.it seems a bit strange. Please be aware that you can not send emails to the hostname of the server as postfix does not support to mix virtual users and system users. So if mc.undo.it is the server hostname, you can not send emails to it. Login to ispconfig, create a meail domain undo.it and then a email mailbox for admin@undo.it and then try to send a email to admin@undo.it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some Hints to "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" wahid HOWTO-Related Questions 10 25th August 2010 15:18
Problem: DNS Server + ISPConfig Server javierg Installation/Configuration 1 5th July 2010 16:59
ISPConfig functioning problem ? Leszek General 3 16th April 2007 11:09
Email address problem (ISPConfig) birumerah Installation/Configuration 10 9th April 2007 08:13
ISPConfig 2.2.0 problem with email addresses DataJet General 1 29th March 2006 13:29


All times are GMT +2. The time now is 19:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.