Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th August 2010, 06:12
casben79 casben79 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Pop / Imap settings

I have followed the perfect server setup : http://www.howtoforge.com/perfect-se...64-ispconfig-3 about 3 times

Latest round, all went beautifully, no errors, exactly as planned. Except for the email testing.

I can login to squirrellmail and send/receive from there just fine, but keep getting the following error when atempting to login via windows mail:
Code:
Server Error: 0x800CCC90
Server Response: -ERR Cannot connect to POP server 184.106.212.176 (184.106.212.176:995), connect error 10060
Server: 'tigerstrikemedia.com'
Windows Live Mail Error ID: 0x800CCC90
Protocol: POP3
Port: 110
Secure(SSL): No
Here is the output of netstat -tap:

Code:
tcp        0      0 *:imaps                     *:*                         LISTEN      18599/dovecot
tcp        0      0 *:pop3s                     *:*                         LISTEN      18599/dovecot
tcp        0      0 localhost:10024             *:*                         LISTEN      16323/amavisd (mast
tcp        0      0 localhost:10025             *:*                         LISTEN      18718/master
tcp        0      0 *:54345                     *:*                         LISTEN      1300/sshd
tcp        0      0 *:mysql                     *:*                         LISTEN      16181/mysqld
tcp        0      0 *:pop3                      *:*                         LISTEN      18599/dovecot
tcp        0      0 *:imap                      *:*                         LISTEN      18599/dovecot
tcp        0      0 *:ftp                       *:*                         LISTEN      16418/pure-ftpd (SE
tcp        0      0 *:smtp                      *:*                         LISTEN      18718/master
tcp        0      0 localhost:52497             localhost:mysql             ESTABLISHED 16332/amavisd (ch1-
tcp        0      0 localhost:mysql             localhost:52497             ESTABLISHED 16181/mysqld
tcp       61      0 localhost:54134             localhost:10025             CLOSE_WAIT  16332/amavisd (ch1-
tcp        0      0 localhost:mysql             localhost:49163             ESTABLISHED 16181/mysqld
tcp        0      0 Bennys-2:ssh                CPE-124-185-128-142.l:51254 ESTABLISHED 868/sshd: casben79
tcp        0      0 localhost:49163             localhost:mysql             ESTABLISHED 16331/amavisd (ch2-
tcp        0    264 Bennys-2:54345              CPE-124-185-128-142.l:53414 ESTABLISHED 18152/sshd: casben7
tcp        0      0 *:imaps                     *:*                         LISTEN      18599/dovecot
tcp        0      0 *:pop3s                     *:*                         LISTEN      18599/dovecot
tcp        0      0 *:54345                     *:*                         LISTEN      1300/sshd
tcp        0      0 *:pop3                      *:*                         LISTEN      18599/dovecot
tcp        0      0 *:imap                      *:*                         LISTEN      18599/dovecot
tcp        0      0 *:http                      *:*                         LISTEN      16396/httpd
tcp        0      0 *:tproxy                    *:*                         LISTEN      16396/httpd
tcp        0      0 *:ftp                       *:*                         LISTEN      16418/pure-ftpd (SE
tcp        0      0 *:smtp                      *:*                         LISTEN      18718/master
tcp        0      0 *:30234                     *:*                         LISTEN      16396/httpd
tcp        0      0 *:https                     *:*                         LISTEN      16396/httpd
and iptables -L

Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
fail2ban-SSH  tcp  --  anywhere             anywhere            tcp dpt:ssh
ACCEPT     all  --  anywhere             anywhere
REJECT     all  --  anywhere             loopback/8          reject-with icmp-port-unreachable
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:http
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:https
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:https
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:pop3
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:smtp
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ftp
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:30234
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:54345
ACCEPT     icmp --  anywhere             anywhere            icmp echo-request
REJECT     all  --  anywhere             anywhere            reject-with icmp-port-unreachable

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
REJECT     all  --  anywhere             anywhere            reject-with icmp-port-unreachable

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere

Chain fail2ban-SSH (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere
Any other logs you guys need to help me troubleshoot this?
Reply With Quote
Sponsored Links
  #2  
Old 20th August 2010, 10:20
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Code:
mark@mark-desktop:~$ telnet tigerstrikemedia.com 110
Trying 184.106.212.176...
Connected to tigerstrikemedia.com.
Escape character is '^]'.
+OK Dovecot ready.
seems to work just fine ..
Reply With Quote
  #3  
Old 20th August 2010, 10:29
casben79 casben79 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have been fiddling with ports and settings, I can now collect emails, but not send them from windows mail im going to try a few more things and get back to you
Reply With Quote
  #4  
Old 20th August 2010, 10:34
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Try enabling SMTP authentication ;-)
Reply With Quote
  #5  
Old 20th August 2010, 10:57
casben79 casben79 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry to be a noob, But I have followed through with this tut: http://wiki.dovecot.org/HowTo/PostfixAndDovecotSASL

and am still getting this error:

Code:
Subject 'test'
Server Error: 421
Server Response: 421 Cannot connect to SMTP server 184.106.212.176 (184.106.212.176:25), connect error 10060
Server: 'tigerstrikemedia.com'
Windows Live Mail Error ID: 0x800CCC67
Protocol: SMTP
Port: 25
Secure(SSL): No
Reply With Quote
  #6  
Old 20th August 2010, 11:45
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Your ISP probably doesn't allow you to connect to other SMTP server then their own, it's very common ..

open up /etc/postfix/master.cf
and uncomment the "submission" line

Code:
submission inet n       -       -       -       -    smtpd
 -o smtpd_enforce_tls=yes
 -o smtpd_sasl_auth_enable=yes
 -o smtpd_client_restrictions=permit_sasl_authenticated,reject
restart postfix

and tell your mail client to connect with port 587, using SSL (STARTTLS)
Reply With Quote
  #7  
Old 20th August 2010, 12:40
casben79 casben79 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, am now getting a different error message:

Code:
An unknown error has occurred.
Subject 'test'
Server Error: 554
Server Response: 554 5.5.1 Error: TLS already active
Server: 'tigerstrikemedia.com'
Windows Live Mail Error ID: 0x800CCC6F
Protocol: SMTP
Port: 587
Secure(SSL): Yes
And also Auth failure (triple checked the password)

Code:
Unable to send or receive messages for the Tigerstrikemedia (admin) account. An incorrect password was entered. 
Server Error: 0x800CCC90
Server Response: -ERR Authentication failed.
Server: 'tigerstrikemedia.com'
Windows Live Mail Error ID: 0x800CCC92
Protocol: POP3
Port: 110
Secure(SSL): No
any idea?
Reply With Quote
  #8  
Old 20th August 2010, 12:55
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

about sending mail:
don't use SSL in your mail client then eh, the error tells you is't already active.

about receiving mail:
you must've changed something else then just submission in master.cf because pop was working just fine you said .. retrace your steps and double/triple check them
Reply With Quote
  #9  
Old 20th August 2010, 13:27
casben79 casben79 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

can you pls let me know what the dovecot.conf auth default function was originally, being the tool I feel like at the moment, I deleted the original function instead of commenting it out
Reply With Quote
  #10  
Old 20th August 2010, 14:48
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
 
Default

i'd suggest you start over with the how-to .. and use one from howtoforge, those simply work
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pop and Imap problem with Mail.app [MAC] newbie76 Installation/Configuration 7 13th November 2009 18:51
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Tips/Tricks/Mods 1 30th September 2009 19:08
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Installation/Configuration 0 10th April 2009 05:54
after upgrade to 8.04 IMAP and POP disappeared hvrossum HOWTO-Related Questions 1 3rd June 2008 10:50
imap and pop connection failed (debian sarge) ayolo Installation/Configuration 3 30th January 2006 17:19


All times are GMT +2. The time now is 19:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.