#1  
Old 17th August 2010, 15:47
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default phpLDAPadmin issues

HI,

I'm having trouble getting phpLDAPadmin working correctly.

I'm using CENTOS and I have openldap installed according to this manual:
http://www.l4l.be/index.php/linuxdoc...79-centos-ldap

Of course I have the nessecary extensions for php installed too.
Now I installed phpldapadmin and when I go to the admin it displays the admin correctly. However when I click on the "login" link on the left I receive the following error in a javascript popup window:
"There was a problem with the request." and nothing happens. I cannot see any login form. (Screenshot attached of the error)

Anyone has any suggestions why it won't work?
Attached Images
 
Reply With Quote
Sponsored Links
  #2  
Old 17th August 2010, 16:16
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

check your ldap log files, php / apache error logs .. see if you can find anything there.
Reply With Quote
  #3  
Old 17th August 2010, 16:25
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Apache gives the following error:

[Tue Aug 17 16:24:09 2010] [error] [client XXX] mod_security: Access denied with code 403. Pattern match "/(cse|cmd)\\\\.(c|dat|gif|jpe?g|jpeg|png|sh|txt|bmp |dat|txt|js|html?|tmp|php|asp)\\\\?" at REQUEST_URI [severity "EMERGENCY"] [hostname "XXX"] [uri "/phpldapadmin/htdocs/cmd.php?cmd=login_form&server_id=1&meth=ajax"] [unique_id "TGqbiW1GAXUAADuTWIEAAAAG"]
[Tue Aug 17 16:24:09 2010] [error] [client XXX] File does not exist: /var/www/html/403.shtml, referer: http://XXX/phpldapadmin/htdocs/index.php
[Tue Aug 17 16:24:11 2010] [error] [client XXX] mod_security: Access denied with code 403. Pattern match "/(cse|cmd)\\\\.(c|dat|gif|jpe?g|jpeg|png|sh|txt|bmp |dat|txt|js|html?|tmp|php|asp)\\\\?" at REQUEST_URI [severity "EMERGENCY"] [hostname "XXX"] [uri "/phpldapadmin/htdocs/cmd.php?cmd=login_form&server_id=1&meth=ajax"] [unique_id "TGqbi21GAXUAADwxapEAAAAE"]
[Tue Aug 17 16:24:11 2010] [error] [client XXX] File does not exist: /var/www/html/403.shtml, referer: http://XXX/phpldapadmin/htdocs/index.php
Reply With Quote
  #4  
Old 17th August 2010, 16:31
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

disable mod_security, or config it so you're allowed to access those files.
Reply With Quote
  #5  
Old 17th August 2010, 16:39
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I found a modsecurity folder in /etc/httpd/conf.d/mod_security and I have the following files in there:

exclude.conf
rootkids.conf
rules.conf
rules2.conf

What should I do?
Reply With Quote
  #6  
Old 17th August 2010, 17:06
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Problem is solved by creating an htaccess file in that folder with the following code:

SecFilterEngine Off
SecFilterScanPOST Off
Reply With Quote
  #7  
Old 17th August 2010, 18:03
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
 
Default

google is your friend
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect XEN Setup on Debian Lenny - Live Migration Issues AlexKent HOWTO-Related Questions 8 25th April 2009 11:57
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52
Ubuntu Mail Server issues (warning: a long list!) klonos HOWTO-Related Questions 3 6th October 2007 14:18
Couple issues with ispconfig 2.2.12 after Fiesty upgrade pyropoptrt Installation/Configuration 15 1st May 2007 20:37
ISPConfig + Turck MMCache + Hardened-PHP - Any Issues? BobbyQ General 8 3rd May 2006 22:52


All times are GMT +2. The time now is 18:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.