Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th August 2010, 19:37
elorc elorc is offline
Junior Member
 
Join Date: Aug 2010
Posts: 18
Thanks: 3
Thanked 0 Times in 0 Posts
Default Switching domains on a postfix/courier server

Since I'm going to have to do this soon, I just want to clarify. I've got my email server set up per the Ubuntu 8.04 virtual users guide using Postfix and Courier. Right now, I have it set up with a temporary/test domain. Soon, though, I'm going to be migrating a website currently on a shared hosting plan to this dedicated server. So if my testing hostname is srv1.mydomain.com and I want to change it to srv1.newdomain.com, it should just be a matter of changing:
  • The hostname and hosts files of the machine itself
  • Postfix's main.cf
  • The mail database's user and domain table entries

That should be all, right? I figure this will be easier than reconfiguring the whole thing from scratch.
Reply With Quote
Sponsored Links
  #2  
Old 17th August 2010, 18:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Yes, that should work.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with mail server and subdomains MyKE General 7 26th February 2010 10:18
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Connection dropped by IMAP server gublym Server Operation 5 23rd January 2009 09:47
cacti problem - graphs have huge gaps Chip Installation/Configuration 7 7th February 2008 23:24
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11


All times are GMT +2. The time now is 02:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.