Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th August 2010, 13:14
Jawshh Jawshh is offline
Junior Member
 
Join Date: Jul 2010
Posts: 25
Thanks: 2
Thanked 1 Time in 1 Post
Default 404 Erros after chrooting Apache2

Hey,

I just followed the guide for chrooting apache with mod-chroot. Now, all my pages are returning 404 errors. I am pretty sure it's a problem with document root but I don't really know how to configure that. My document root is /home/admin/ , so, how do I configure apache to serve files from this dir?

Thanks,
Josh
Reply With Quote
Sponsored Links
  #2  
Old 18th August 2010, 16:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Which distribution do you use? Any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th August 2010, 09:47
Jawshh Jawshh is offline
Junior Member
 
Join Date: Jul 2010
Posts: 25
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by falko View Post
Which distribution do you use? Any errors in Apache's error log?
Hey,

I am using Centos 5.5 but anyway I reloaded my OS image now and I am using un-chrooted apache-I don't know if I need the extra layer of security or not.

Thanks for replying,
Josh
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.1.4 causes Apache to have too many open files gkovacs Installation/Configuration 29 27th February 2013 08:59
apt-get update Fails For UBUNTU Gutsy Gibbon giganet Server Operation 1 1st May 2009 15:24
Errors on Build Your Own Debian/Ubuntu LAMP Server ngungo Installation/Configuration 5 10th March 2007 15:34
problem in: The Perfect Setup - Ubuntu 6.06 LTS Server PermaNoob HOWTO-Related Questions 6 15th January 2007 19:13
apt-get failure yap HOWTO-Related Questions 1 19th November 2006 22:33


All times are GMT +2. The time now is 11:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.