Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 12th June 2006, 09:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

Quote:
Originally Posted by marclar
if I remove 'reject_unauth_destination', then e-mail is sen't succesfully, but it never cames, though I can see it, in my Maildir folder...
You men you see the email in the maildir folder but cant fetch it with pop3 / IMAP?

Then you must either switch from maildir to mbox in ISPConfig or install an maildir capacle pop3 and imap client like courier or dovecot on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 12th June 2006, 11:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by marclar
Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 550 <me@mydomain.com>: Recipient address rejected: User unknown in local recipient table
Can you post your real domain name here?
Don't remove reject_unauth_destination.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 13th June 2006, 18:06
marclar marclar is offline
Member
 
Join Date: Jun 2006
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to marclar
Default

my real domain is "emanuel.si"
i'll put reject_unauth_destination back!

@till:
I have courier installed!

thanks guys, you're being really helpful here.
ps: if you visit slovenia, I'll buy you a couple of beers

Last edited by marclar; 13th June 2006 at 18:16.
Reply With Quote
  #14  
Old 14th June 2006, 00:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Is this your public IP address? 86.61.69.94

Is me@mydomain.com (replace it with the real email address) listed in /etc/postfix/virtusertable?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 14th June 2006, 19:07
marclar marclar is offline
Member
 
Join Date: Jun 2006
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to marclar
Default

Quote:
Originally Posted by falko
Is this your public IP address? 86.61.69.94
yes, it is.
Quote:
Is me@mydomain.com (replace it with the real email address) listed in /etc/postfix/virtusertable?
there was an mistake here, yes, (me@username.mydomain.com), but i corrected it with me@mydomain.com, but i still get that error message:

Quote:
PERM_FAILURE: SMTP Error (state 9): 550 <me@emanuel.si>: Recipient address rejected: User unknown in local recipient table
Reply With Quote
  #16  
Old 14th June 2006, 19:21
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

Quote:
Originally Posted by marclar
yes, it is.


there was an mistake here, yes, (me@username.mydomain.com), but i corrected it with me@mydomain.com, but i still get that error message:
did you do the postalias /etc/... command?
Reply With Quote
  #17  
Old 14th June 2006, 20:55
marclar marclar is offline
Member
 
Join Date: Jun 2006
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to marclar
Default

Quote:
Originally Posted by fobicodam
did you do the postalias /etc/... command?
hm... no.. I don't even know what that is
but i did now, and still the same error :\

Last edited by marclar; 14th June 2006 at 21:00.
Reply With Quote
  #18  
Old 15th June 2006, 15:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

Quote:
Originally Posted by marclar
there was an mistake here, yes, (me@username.mydomain.com), but i corrected it with me@mydomain.com, but i still get that error
Do not correct anything in the virtusertable file manually! It's useless as ISPConfig removes your changes.

Does the website username.mydomain.com has a co-domain mydomain.com with empty host field? If not, create that co-domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 15th June 2006, 18:13
marclar marclar is offline
Member
 
Join Date: Jun 2006
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to marclar
Default

heh, great, finally some progres!

I found out, that the e-mail is sent successfully, if I send it to username@mydomain.com, and not to the "e-mail@mydomain.com"
why is that so?

not a big problem, just wondering...

E-mail, cames in Outlook to!
But if I make reply, it says:

Quote:
The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'anyone@anydomain.com'. Subject 'Re: reere', Account: 'mail.emanuel.si', Server: 'mail.emanuel.si', Protocol: SMTP, Server Response: '554 <anyone@anydomain.com>: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79
any ideas on that one?
__________________
www.emanuel.si
Reply With Quote
  #20  
Old 15th June 2006, 18:57
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
 
Default

Quote:
Originally Posted by marclar
heh, great, finally some progres!

I found out, that the e-mail is sent successfully, if I send it to username@mydomain.com, and not to the "e-mail@mydomain.com"
why is that so?

not a big problem, just wondering...

E-mail, cames in Outlook to!
But if I make reply, it says:



any ideas on that one?

The relay problem is because the "SMTP server requires autentication" checkbox in outlook.

The account problem is because postfix isnt reading your aliases config file, did you change something on postfix.conf?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 03:39
Read but not send mail briggers HOWTO-Related Questions 24 7th April 2006 19:22
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 22:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.