Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th August 2010, 00:40
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
Default Some odd permission deny's

I logged my procmail and found some issues:

Code:
Aug 12 00:32:44.860 [15485] warn: auto-whitelist: open of auto-whitelist file failed: locker: safe_lock: cannot create tmp lockfile /var/www/web90/user/someuser/.spamassassin/auto-whitelist.lock.somedomail.tld.15485 for /var/www/web90/user/someuser/.spamassassin/auto-whitelist.lock: Permission denied
Aug 12 00:32:44.869 [15485] warn: plugin: eval failed: bayes: (in learn) locker: safe_lock: cannot create tmp lockfile /var/www/web90/user/someuser/.spamassassin/bayes.lock.somedomail.tld.15485 for /var/www/web90/user/someuser/.spamassassin/bayes.lock: Permission denied
Please explain the solution to me!
Reply With Quote
Sponsored Links
  #2  
Old 12th August 2010, 13:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's the output of
Code:
ls -la /var/www/web90/user/someuser/.spamassassin/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th August 2010, 14:09
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
Default

Code:
root@hera:~# ls -la /var/www/web62/user/nutri-anna-marie/.spamassassin/
total 11248
drwx------ 2 root root     4096 2010-05-01 21:06 .
drwxr-xr-x 5 root root     4096 2010-05-01 21:06 ..
-rw------- 1 root root   335872 2010-05-01 21:06 auto-whitelist
-rw------- 1 root root   663552 2010-05-01 21:06 bayes_seen
-rw------- 1 root root 10510336 2010-05-01 21:06 bayes_toks
lrwxrwxrwx 1 root root       48 2010-05-01 21:06 user_prefs -> /var/www/web62/user/nutri-anna-marie/.user_prefs
OFC that is one sample I have a couple of them exactly like this,
Looks like some process / daemon is NOT running in the correct user, I cant imagine how all the directories changed if the problem was directory security!
Reply With Quote
  #4  
Old 12th August 2010, 15:38
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,392
Thanks: 833
Thanked 5,487 Times in 4,319 Posts
Default

Maybe you have reconfigured your system to use spamd instaed of the default spamsacan setup of ispconfig? Or you restored the files from a backup? With spamscan, these files are all owned by the system user that owns the email account, but your files are owned by root, so they must have been written by some kind of daemon or they had been copied from another instal without preserving permissions.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th August 2010, 15:56
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
 
Default yes

Yes probably the backup-restore , Will have to work on those, I will write a bash script to fix permissions,

As before I have pleaded the case for clamd, (BTW changing it back did not change the issue at hand) BUT Please make it an installation option to switch to clamd, as clamd uses almost NO resources whereas clamscan does lock-up cpu to 100%, especailly on slow internet connections witch we have all over the world except US and Europe! Places like South Africa and other have those issues where the ISP's all cache traffic via transparent proxy and no one can do anything about it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SugarCRM Install on ISPConfig3 w/ SuPHP clucena Installation/Configuration 1 9th February 2010 09:29
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Security issue bernholdt General 3 5th November 2008 13:04
Apache Ownership cybereatl General 2 26th March 2008 12:25
very slow domain setting loading Hellbound General 8 2nd January 2008 22:17


All times are GMT +2. The time now is 17:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.