#1  
Old 11th August 2010, 18:20
kurt22 kurt22 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dovecot unknow user

I have a probleme with my configuration of dovecot I think. I have no problem for send a email but I don't want receive a email. In my /var/log/mail.log I have :

Quote:
connect from mail-ww0-f45.google.com[74.125.82.45]
Aug 11 14:21:58 ns351550 postfix/smtpd[1844]: NOQUEUE: reject: RCPT from mail-ww0-f45.google.com[74.125.82.45]: 550 5.1.1 <contact@akairnet.com>: Recipient address rejected: User unknown in local recipient table; from=<fwdavy@gmail.com> to=<contact@akairnet.com> proto=ESMTP helo=<mail-ww0-f45.google.com>
Aug 11 14:21:58 ns351550 postfix/smtpd[1844]: disconnect from mail-ww0-f45.google.com[74.125.82.45]
so...problem on :
Log dovecot

Quote:
dovecot: 2010-08-11 17:53:14 Info: auth(default): client in: AUTH 1 PLAIN service=IMAP secured lip=91.121.76.71 rip=91.121.76.71 resp=AGNvbnRhY3RAYWthaXJuZXQuY29tAFgyMmRiNzgh
dovecot: 2010-08-11 17:53:14 Info: auth-worker(default): sql(contact@akairnet.com,91.121.76.71): query: SELECT CONCAT(user.user, '@', domains.name) AS user,user.password FROM user,domains WHERE user.domain_id=domains.id AND CONCAT(user.user, '@', domains.name)='contact@akairnet.com'
dovecot: 2010-08-11 17:53:14 Info: auth(default): client out: OK 1 user=contact@akairnet.com
dovecot: 2010-08-11 17:53:14 Info: auth(default): master in: REQUEST 1 13716 1
dovecot: 2010-08-11 17:53:14 Info: auth(default): passwd(contact@akairnet.com,91.121.76.71): lookup
dovecot: 2010-08-11 17:53:14 Info: auth(default): passwd(contact@akairnet.com,91.121.76.71): unknown user
dovecot: 2010-08-11 17:53:14 Info: auth(default): master out: USER 1 contact@akairnet.com uid=5000 gid=5000 home=/home/var/vmail/akairnet.com/contact
dovecot: 2010-08-11 17:53:14 Info: imap-login: Login: user=<contact@akairnet.com>, method=PLAIN, rip=91.121.76.71, lip=91.121.76.71, secured
dovecot: 2010-08-11 17:53:14 Info: IMAP(contact@akairnet.com): Disconnected: Logged out


Quote:
Recipient address rejected: User unknown in local recipient table
passwd(contact@akairnet.com,91.121.76.71): unknown user
In my main.cf I have :


Quote:


smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

append_dot_mydomain = no

readme_directory = no

smtpd_tls_cert_file = /etc/ssl/certs/postfix.pem
smtpd_tls_key_file = /etc/ssl/private/postfix.pem
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_tls_auth_only = yes


myhostname = mail.akairnet.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = mail.akairnet.com
mydestination = localhost, localhost.akairnet.com, akairnet.com
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128, 91.121.76.71
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox = Maildir/

virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domaines.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_comptes.cf

virtual_uid_maps = static:5000
virtual_gid_maps = static:5000


virtual_transport = dovecot
dovecot_destination_recipient_limit = 1

smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
smtpd_sasl_auth_enable = yes
smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated
smtpd_sender_restrictions = permit_mynetworks, permit_sasl_authenticated
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination


maximal_queue_lifetime = 3d
bounce_queue_lifetime = 3d
In dovecot.conf for auth default I have :


Quote:
auth default {
mechanisms = plain login
passdb sql {
args = /etc/dovecot/dovecot-sql.conf
}

userdb passwd {

}
userdb static {

args = uid=5000 gid=5000 home=/home/var/vmail/%d/%n allow_all_users=yes

}

socket listen {
master {
path = /var/run/dovecot/auth-master
mode = 0600
user = vmail
}
client {
path = /var/spool/postfix/private/auth
mode = 0660
user = postfix
group = postfix
}
}
}
You want to help me ?
Reply With Quote
Sponsored Links
  #2  
Old 12th August 2010, 12:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Which tutorial (URL) did you use to set up the system? Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th August 2010, 13:29
kurt22 kurt22 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi falko,

I have use many tuto so now it's very personnal configuration

I have a debian 5 lenny.
Reply With Quote
  #4  
Old 12th August 2010, 18:14
kurt22 kurt22 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have exécute différente change but I have a another error now :

mail.log -> local configuration error

Quote:
Aug 12 16:35:19 ns351550 postfix/pipe[24171]: B06633BA9B: to=<contact@akairnet.com>, relay=dovecot, delay=0.11, delays=0.07/0.01/0/0.03, dsn=5.3.5, status=bounced (local configuration error). And so in dovecot log unknow user.
you are a idea for debug this error ?
Reply With Quote
  #5  
Old 12th August 2010, 20:59
kurt22 kurt22 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

It's ok it was :

dovecot unix - n n - - pipe
flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${recipient}
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Can't access to my website - after install problem pallermo Installation/Configuration 18 4th June 2010 13:29
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Postfix can't received email from exterior astra2000 Server Operation 5 17th October 2009 23:26
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15


All times are GMT +2. The time now is 03:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.