Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th June 2006, 13:35
ToysunStory ToysunStory is offline
Junior Member
 
Join Date: Mar 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect Setup Debian Sarge - PHP Problem

Hi,

I've installed and upped a webserver using this howto. It is great working. But now one of my client send me a php script from http://navphp.sourceforge.net/. This is a php script shows everything and everyfile in the server. Is there any security problem with the setup? Or should I make something different ? I've tried to use google but nothing helpful. I found suphp but it is not working well.
Reply With Quote
Sponsored Links
  #2  
Old 7th June 2006, 14:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

To prevent this, you should enable PHP Safe Mode for all your web sites.
I'll post a tutorial about suPHP in the next days.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th June 2006, 20:06
ToysunStory ToysunStory is offline
Junior Member
 
Join Date: Mar 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up

Thanks falko, it would be great.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect Setup Debian Sarge 64bits Pc question toyito HOWTO-Related Questions 1 19th May 2006 20:32
Perfect setup SuSe 10.0 - php problem Victor Skoropupob Installation/Configuration 3 19th May 2006 15:07
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 20:58
Problem on Debian Sarge Perfect Setup daniel_rodriguez HOWTO-Related Questions 4 12th January 2006 14:10
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 10:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.